Inxi -G result for Nvidia driver as N/A

optimus switchable graphics are only on notebooks …

it will not persist to reboots if you switch nvidia on manually…
But if yoiu do “switch” in the meaning of set it up to only run nvidia… there will be an issue loading the driver we cpould check the botjournal if you mind… send me in PM to not post uuids and stuff public:

journalctl -b -0 | eos-sendlog will pastebin it you can PM me the URL or use any other srvice…

xrandr --setprovideroffloadsink nvidia Intel is not working too?

and what is the output of this:

pacman -Qs nvidia

OK this issue has been resolved. It was my own fault. I reinstalled EndeavourOS and this time instead of choosing LEGACY secure boot off I chose UEFI boot and it boots up fasted the grub menu does that little animation thing and the default install driver is noveau. BUT after doing nvidia-inst, rebooting I cannot tell if it has the proprietary driver installed.

output for pacman -Qs nvidia

local/egl-wayland 2:1.1.11-4
    EGLStream-based Wayland external platform
local/envycontrol 3.2.0-2
    CLI tool for Nvidia Optimus graphics mode switching on Linux
local/libvdpau 1.5-1
    Nvidia VDPAU library
local/libxnvctrl 530.41.03-1
    NVIDIA NV-CONTROL X extension
local/nvidia-dkms 530.41.03-1
    NVIDIA drivers - module sources
local/nvidia-hook 1.3-1
    pacman hook for nvidia
local/nvidia-inst 23-4
    Script to setup nvidia drivers (dkms version) in EndeavourOS
local/nvidia-installer-common 23-5
    Common scripts for nvidia-installer-dkms and nvidia-inst
local/nvidia-settings 530.41.03-1
    Tool for configuring the NVIDIA graphics driver
local/nvidia-utils 530.41.03-1
    NVIDIA drivers utilities

It is installed. Check that it is in use:

inxi -Gza
lspci -vnn | grep -PA10 'VGA|3D|Display'
1 Like

please use code tags…


it seems to be installed… if itwould not the nvidia-inst command would show error in output…
and as before… inxi -Gaz will show exactly what drivers are used… and what GPU–

and i mentioned already… i would may came up with a conclusion/solution if you send me the boot journal…
in a P.M. journalctl -b -0 | eos-sendlog and send me the url it shows in a message not here public…

This is the output for inxi -Gaz

  Device-1: Intel HD Graphics 630 vendor: Dell driver: i915 v: kernel
    arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports: active: eDP-1
    empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:591b
    class-ID: 0300
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: Dell driver: N/A
    alternate: nouveau non-free: 530.xx+ status: current (as of 2023-03)
    arch: Pascal code: GP10x process: TSMC 16nm built: 2016-21 pcie: gen: 3
    speed: 8 GT/s lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:1c8d class-ID: 0302
  Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 1-12:5 chip-ID: 0c45:6713 class-ID: 0e02
  Display: wayland server: v: with: Xwayland v: 23.1.1
    compositor: gnome-shell v: 43.4 driver: gpu: i915 display-ID: 0
  Monitor-1: eDP-1 model: Sharp 0x1476 built: 2016 res: 3840x2160 dpi: 282
    gamma: 1.2 size: 346x194mm (13.62x7.64") diag: 397mm (15.6") ratio: 16:9
    modes: 3840x2160
  API: OpenGL v: 4.6 Mesa 23.0.2 renderer: Mesa Intel HD Graphics 630 (KBL
    GT2) direct-render: Yes

moderation edit:
adding codetags!!
code tags bro :wink:

Apr 18 01:42:04 patty-B kernel: Command line: BOOT_IMAGE=/@/boot/vmlinuz-linux root=UUID=XXXX rw rootflags=subvol=@ nowatchdog nvme_load=YES rd.luks.uuid=XXXX loglevel=3

Apr 18 01:42:04 patty-B systemd-modules-load[160]: Failed to find module 'nvidia-uvm'
is the only hint in the journal about nvidia all together because:

i do not see DRM modesetting is added to cmd line… without this it will not load the nvidia modules.

How do I add it?

you have used nvidia-inst to install nvidia?

If so it should be there if it was running without error.

But add it…

running systemd-boot? or you do changed bootloader to grub on installation ?

Yes, you are right. I did change my bootloader to GRUB on install.

okay so you can add it in this way:

gedit admin:///etc/default/grub

and add it to this line:

GRUB_CMDLINE_LINUX_DEFAULT="nvidia-drm.modeset=1 resume=UUID=...

ading this parameter nvidia-drm.modeset=1 sperated by a space … not removing anything else…

see here also:

2. Adding it to grub kernel line:

and regenerate grub.cfg:

sudo grub-mkconfig -o /boot/grub/grub.cfg

gedit command not found

I will do it using the commands in the link provided

This is the result for

sudo nano /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT="nowatchdog nvme_load=YES rd.luks.uuid=fb8cdde0-28b6-4d82-8845-a15f4a99ca4a loglevel=3 nvidia-drm.modeset=1"

gedit is legacy i see… nit anymore installed on gnome :wink:

wiuth “result” you mean after editing it? and do you run the grub-mkconfig command?

Of course not I ran the command sudo nano /etc/default/grub and the NVIDIA modset line was already there.