Invalid PGP in EndeavourOS_Artemis_22_6 offline install and other problems

I have no idea why, but personally for me EndeavourOS_Artemis_22_6 is the most problematic for the both offline and online install.

With offline installation for the last several times I had a problem that the PGP keys are incorrect, so even system update isn’t possible and terminal is full of an errors like -

"libcap, lv2, serd, sord - package is invalid or damaged (signature PGP).

Thankfully, fix for this problem is pretty simple and needs just a one command to install a proper one arch keyring.

sudo pacman -S archlinux-keyring

And if to talk about an online installation, in my case it’s with Artemis version of the EOS is entirely broken.
I’ve tried to install KDE Plasma with it for maybe about 10 or more times, with different usb flash drives, different iso-burners (rufus, ventoy, gnome-disks, balena etcher(unavoidable telemetry but yet still can try it) and etc), different usb ports and their versions from 2.0 to 3.0 and on different machines with different wifi or ethernet networks, buy yet still, online installation of the EndeavourOS_Artemis_22_6 can’t properly install Desktop Environment.
Each time when I tried to install KDE Plasma with it it ended up loading instantly with tty and to install Plasma manually was impossible because of a some errors, I think it’s was too a PGP problems.

So in the end to install plasma before and right now I need to use offline XFCE install, install plasma under it, then load into it and entirely remove XFCE.
Which isn’t a big problem, but in previous versions of the EOS everything worked like a swiss watches and I was able to directly install KDE plasma from the online installation.

This is just a timing issue that occurs with offline installs and arch. Basically, since the time the ISO was created and today, the keyring is out of date. There is no way for us to avoid this except to release a new ISO every time the arch keyring is updated. Since it is an offline install, we can’t/shouldn’t install a new keyring for you from the internet.

As you say, the workaround is simple.

This isn’t normal. In order to help you, we would need some logs to determine what the actual issue is.

This is not likely with an online install since we would have installed the latest arch-keyring as part of the install.

1 Like

The problem with such problems that they’re too random when they are occurring.
Right now I’m writing it from the successfully installed KDE Plasma in the online mode and I have no idea why now everything is fine, thanks God and Deus ex Machina as his aspect I think.

Anyway, yet still in compare when similar shit happening with Windows 10 installation it’s still way more easier to fix it in Linux.
Especially when you’re trying to make this Microsoft crap installing on a m2 ssd drive, I’ve spent a whole day trying to install it on my sister PC, tinkering with bios, different usb drives, different software, ended up with media creation tool but even after it worked only after I don’t know how much time and I have no idea why and how it’s was somehow affected by the fact if a PC was turned off and unplugged from the electricity entirely.

logs logs …
Also i do understand the frustration, i do not see that the ISO is broken that much as hundreds of working installs tell another story.

And without installer there is not much we could investigate in, to make the installer working better and better.

It is very easy to provide the installer logs as there is the installer itself opening a window when install fails and ask to pastbin the log… and in pother case there is the log tool in the panel.


In general everyone:

Please send installer logs if install fails, it is the only way for us to solve issues with your hardware and setup situations!

Manually providing logs:

installer log from live session:

cat /var/log/endeavour-install.log | eos-sendlog

Hardware information:

inxi -Fxxc0z --no-host | eos-sendlog

Boot log:

journalctl -b -0 | eos-sendlog

run the commands and share the short-url in your post.

2 Likes

I would think this could also be useful, here:

and here as well:

2 Likes

Interesting. So my wife has had her Endeavour laptop installed for almost a year and she got this error today during the update. That machine is a vanilla install before Artemis release. My fix was to reinstall the archlinux-keyring as well.

What is a vanilla install? I never understand what that means when people say it? Isn’t every install vanilla until you start modifying it?

Right, will take logs next time.
I’m was just too confused when things out of sudden started to work and I had no desire to try again and maybe see reproducing of a problem.

A vanilla install simply means that the package / packages were installed exactly as the upstream developers issued them. A classic example is XFCE4. If XFCE4 is installed exactly as the upstream XFCE4 developers issued it, most people think is is out of date, and some think it’s downright ugly. As such, EndeavourOS, offers a customized version of the upstream XFCE4 desktop.

Same with i3wm. Most users think i3wm as the upstream developers issue it, is not very useful or user friendly. So EnOS offers a tinkered with version that most new i3wm users prefer.

Pudge

Right. I get that, but like, almost everyone installs a vanilla ______ install. It’s rare someone wouldn’t, so there’s no need to actually specify it.

It’s like that scene in the fast and the furious.

“Pop the hood”

Pop

“2JZ, no sh@#.”

Like. . . This Toyota Supra came with a Toyota Supra engine?!? Why is this guy in shock?!?

Sorry my bad using a general term which is inaccurate.

I should have said it was an install of Endeavour OS online with Gnome desktop. I called it vanilla because I did not open terminal to do something like have to patch something like her wifi card.

On a high level I document how I do my Arch installs for the 5 systems i maintain for my family. So when I’m testing this helps me look for deviations between upgrades or the cases where i reinstall a laptop.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.