Intermittent music freeze when playing music

Hi everyone,

I’m not sure where to start with this one. Forgive my limited understanding of Arch and Linux in general.

I normally have Clementine open on another desktop playing music in the background. After a good 30 minutes to an hour of play, the music stops and starts again. It stops for a few seconds and plays for a few more, longer than the stops. I thought it was Clementine but it also happened with Dragon. I’m testing Eilsa but I suspect this is a system problem.

Is anyone else having a similar issue? I’m not what specs to post here if that helps.

Operating System: EndeavourOS
KDE Plasma Version: 5.24.2
KDE Frameworks Version: 5.91.0
Qt Version: 5.15.2
Kernel Version: 5.15.25-1-lts (64-bit)
Graphics Platform: X11
Processors: 8 × AMD FX™-8320 Eight-Core Processor
Memory: 15.6 GiB of RAM
Graphics Processor: AMD Radeon RX 480 Graphics



Hello I see a similar issue, with audio playback from firefox web app as write to other post in forum, I found a way to trigger the bug. Unlucky I’m not too skilled for do a real debugging, only mark this.

Thanks Babiz. I’m not sure if it happens with Firefox, I use LibreFox, a fork. This happens with all players, which leads me to think it’s a system problem.

I’m looking into using a low latency kernel. That should help. If not, I’m not sure what to do. It’s frustrating. I’m about to bring out my big stereo system. That analog beast always works :slight_smile:

1 Like

Oh yeah, analog stereo is for audiophiles folks today’s millennials guys not known anything of high-end hi-fi stuffs makes golden age era on '80/90 years. loll :smiley:

Anyway if this “issue” is happen only under EOS, I agree with you for some kind of system bug, get many apps to fail streaming, maybe for buffer crash or anything else.

Can you check if “audio mute” behavior will “restore” if you go to mixer icon bar “Application” and click to volume bar to change level?

If is true, same happen to me, and maybe is bug on audio stack pipewire

Sorry for my english isn’t perfect, hope all is clear :slight_smile:

1 Like

Where are you playing the music from?

@dalto In my EOS installation, with firefox, amazon music app, I can trigger the bug when clicking on firefox icon on bottom bar, sometimes audio will get muted…

Edit, oh man, I now see under icon context menu, option to mute audio, lol is for me a surprise, anyway this option is triggered by regular left click, and is unwanted for me, sorry.

1 Like

That is probably unrelated. Are you sure you aren’t clicking on the part of the icon that mutes the audio from that application?

1 Like

You are right, I’ll do pay more attention over click, but I’m blind so difficult for me see tiny things, now I know, thank you

1 Like

Your English is perfect, I understand you :slight_smile:

Yeah, old-school analog is great. I have some half-master Pink Floyd albums and they sound great on a good turntable with a good needle. Next, a reel-to-reel.

Audio mute is off. I turned it on and off. Maybe that will work. I use Kmix. Hopefully, that isn’t the problem. I just installed pipewire. I’m going to test it.


1 Like

I use virtual desktops. I have a desktop dedicated to multimedia. Could that be a problem?

Probably not, I meant where is the music coming from? It is a stream, files on an SSD, internal HDD, external HDD, etc, etc.

1 Like

Oh I’m so sorry for little caos on this thread, I wrongly think about some behaviour of kde, it’s quite different from last use, about many years ago, and my “issue” is not related to this thread.

But if you like understand why your system is “crappy” I will advice you to check logfiles related and starting clementine with debug options, first of all.

For clementine initial debug, starting it from console bt typing : clementine --verbose
Verbose output from shell is very much to check but you’ll traking any issue more precision will get useful for asking a support hand :smiley:

1 Like

Gotcha. On the main drive. I have SMART activated. Tx!

Is it an HDD or an SSD? Are they mp3 or FLAC?

I switched to Strawberry, but I assume it’s the same.

I tested Audacious and after a while the problem happened.

It’s HDD and mostly low compression MP3s, although I have an old collection spanning decades and ranging from MP3s to FLAC, AIFF, WAV. Mostly mp3s.

So ti’s clear system issue, you can try another audio device like usb cheap adapter?

Anyway you need to check your hardware and modules loaded in kernel and it’s global configuration options.

Maybe adjusting “audio profile” from System Settings > Audio will be a trick.

Below is example of my profiles available for bluetooth speaker

Sorry for “italians” description :smiley:

1 Like

No problem, I’m an Alfa Romeo fan and understand a little Italian. I’m also French from Nice, so understand a little :slight_smile:
My setup is a little different. I only have Analog Stereo, Digital Stereo and Digital Surround 5.1. I’m currently using the headphone out to a portable speaker.

I will plug it in another port.

1 Like

Good to hear you like made in Italy man :slight_smile:
Please, go to konsole and paste this:

lspci -v | grep -i audio

followed by Enter, and copy printed output here. Other useful commands to do is:

sudo dmesg | eos-sendlog
inxi -Faz | eos-sendlog

and put here link showned by it

1 Like

Yeah, I’m a big fan of Italian macchina :slight_smile:

For lspci -v | grep -i audio

00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA)
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]


and for sudo dmesg | eos-sendlog :

% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 129k 0 24 100 129k 54 292k --:–:-- --:–:-- --:–:-- 292k


Finally, for inxi -Faz | eos-sendlog :

% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 5053 0 24 100 5029 112 23675 --:–:-- --:–:-- --:–:-- 23834


So tell me doctor, is it bad :rofl: