Intermittent Internet Dropout

With no indication what so ever my internet connection via wifi either slows down significantly or drops to 0 bits completely. No wifi connection is lost. So far only restarting the network manager via systemctl solves the issue for a couple of minutes before it drops out again. This is a fresh install though the problem started about a week ago on a older installation of mine. So far I have tried turning off Bluetooth entirely and switching from wpa_supplicant to iwd. Not sure where else to look to see if stuff is error-ing out, my windows install seems to work fine and I don’t have access to Ethernet so I can’t test if there is a issue there.

See if it’s reproducible on the mainline kernel vs the LTS kernel. Also check if you’re using 2.4Ghz or 5GHz for your router. If you’re router is using 2.4Ghz for example, anytime you use your microwave, that will interfere with the wifi until the microwaves job is done, but using 5Ghz isn’t affected by microwave use. So use a different kernel and/or watch what you cook. This may or may not be useful :stuck_out_tongue:


Unfortunately it does occur on the LTS kernel as well as the mainline. No microwave either though I should mention I am using 5Ghz.

I use at 2.4 GHz on my system. Check whether it helps.

I told this because 5 GHz won’t work here.

Without any information whatsoever about which wifi chip you are using everything at this point would be pure conjecture.

If I had to hazard a guess, I would say this may be a power saving issue. If your wifi driver has the option, I would disable power saving via a driver config file in /etc/modprobe.d.

You could also disable power saving via a Network Manager config file.

For an informed opinion, you would need to provide at the minimum:

inxi -naz

Some logs would also be helpful.


Hi AlphaClover,

We really need to know some details about your setup:

(1) System (run below in terminal).

inxi -FAZ --no-host

(2) Which router and model.

(3) If you boot off the Endeavour Live image USB … are you seeing the same issue when using wifi?

(4) If the computer is dual booted with Windows, are you seeing an issue there with wifi?



Sure thing, this is what the inxi -Faz --no-host outputs.

  Kernel: 5.16.13-arch1-1 x86_64 bits: 64 Desktop: KDE Plasma 5.24.3
    Distro: EndeavourOS
  Type: Desktop Mobo: Micro-Star
    model: MPG X570 GAMING PRO CARBON WIFI (MS-7B93) v: 1.0
    serial: <superuser required> UEFI: American Megatrends LLC. v: 1.C0
    date: 05/18/2021
  Info: 12-core model: AMD Ryzen 9 3900X bits: 64 type: MT MCP cache:
    L2: 6 MiB
  Speed (MHz): avg: 2291 min/max: 2200/4672 cores: 1: 3600 2: 2055 3: 2057
    4: 2199 5: 2198 6: 2200 7: 2199 8: 2199 9: 2200 10: 2198 11: 2199 12: 2200
    13: 3599 14: 2055 15: 2056 16: 2200 17: 2198 18: 2199 19: 2195 20: 2200
    21: 2200 22: 2201 23: 2196 24: 2197
  Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
    driver: amdgpu v: kernel
  Display: x11 server: X.Org v: driver: X: loaded: amdgpu,ati
    unloaded: modesetting,radeon gpu: amdgpu resolution: 1: 1920x1080
    2: 1920x1080~60Hz
  OpenGL: renderer: AMD Radeon RX 5700 XT (NAVI10 DRM 3.44.0
    5.16.13-arch1-1 LLVM 13.0.1)
    v: 4.6 Mesa 21.3.7
  Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel
  Device-2: Focusrite-Novation Scarlett Solo (3rd Gen.) type: USB
    driver: snd-usb-audio
  Device-3: Logitech G733 Gaming Headset type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Sound Server-1: ALSA v: k5.16.13-arch1-1 running: yes
  Sound Server-2: PipeWire v: 0.3.48 running: yes
  Device-1: Intel I211 Gigabit Network driver: igb
  IF: enp38s0 state: down mac: 2c:f0:5d:55:71:90
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi
  IF: wlan0 state: up mac: 14:f6:d8:78:e5:47
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: see --recommends
  Local Storage: total: 11.6 TiB used: 5.26 TiB (45.4%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO Plus 1TB
    size: 931.51 GiB
  ID-2: /dev/sda vendor: Samsung model: SSD 850 EVO 250GB size: 232.89 GiB
  ID-3: /dev/sdb vendor: Samsung model: SSD 850 EVO 500GB size: 465.76 GiB
  ID-4: /dev/sdc vendor: Western Digital model: WD10EZEX-00BN5A0
    size: 931.51 GiB
  ID-5: /dev/sdd vendor: Seagate model: ST4000DM004-2CV104 size: 3.64 TiB
  ID-6: /dev/sde type: USB vendor: Seagate model: ST6000VN001-2BB186
    size: 5.46 TiB
  ID-1: / size: 460.31 GiB used: 39.92 GiB (8.7%) fs: ext4
    dev: /dev/nvme0n1p6
  ID-2: /boot/efi size: 1.04 GiB used: 271.7 MiB (25.6%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-1: swap-1 type: partition size: 19.53 GiB used: 0 KiB (0.0%)
    dev: /dev/nvme0n1p5
  System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 54.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
  Processes: 450 Uptime: 0m Memory: 31.33 GiB used: 2.09 GiB (6.7%)
  Shell: fish inxi: 3.3.13

My wifi and internet work perfectly fine on windows with no slowdowns or dropout issues.
For router stuff, I am at college right now but its a aruba access point which I have had no problem with for the past year I have been here so I have no reason to suspect it.

Not sure my driver has the option, no configs or anything were in the modprobe.d file. I just posted the inxi above in the previous post as well.

To load the iwlwifi module with power saving features disabled use:

nmcli networking off; sleep 1; sudo systemctl stop NetworkManager; sleep 1; sudo lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs sudo rmmod; sudo modprobe -r mac80211; sleep 3; sudo modprobe iwlwifi power_save=0 d0i3_disable=0 uapsd_disable=0; sleep 1; sudo systemctl start NetworkManager; nmcli networking on; sleep 1; nmcli r wifi off; sleep 1; nmcli r wifi on
1 Like

Seems to be working so far, weird how it just started out of the blue a week ago. Thanks!

That is not a permanent solution, it only lasts until you reboot.

To make disabling the iwlwifi power saving options permanent, run the following command:

echo 'options iwlwifi power_save=0 d0i3_disable=0 uapsd_disable=0' | sudo tee /etc/modprobe.d/iwlwifi.conf

Then, reboot.

You’re welcome, and I’m glad that helped. :+1:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.