Intel and Amd on Linux


I got this question in my mind first sorry to not know a lot about Linux I am fairly new compared to my 25 years of windows.

I got a two laptops for work one with the latest Intel base thinkpad x1 9th generation

And the other is just a thinkpad with an AMD build ThinkPad E14 with the Ryzen 4000

Surprisingly my new thinkpad the x1 9th always need to be run on LTS or the graphic card doesn’t work sounds etc…

But my AMD is an absolute rocket I mean its 3 times cheaper and run 3 times faster! I thought Intel was playing nice with Linux definitely not as good as AMD but what is the reason it’s harder to make Linux run with intel? And new stuff?


Some very old and some very new processors can be a bit problematic. I have an ancient laptop with an Intel processor that works best on kernel 4.19.

Just pick a kernel that works, it’s okay to use an LTS kernel (actually, a good idea).


I don’t know anything about the current status of the latest Intel graphics on the latest Linux kernel, perhaps it will be resolved with a new update or another community member can give you a workaround, if there is one.

What I can explain to you is the speed difference between the two devices.
The X1 ships with an Intel CPU that has 4 cores/ 8 threads, your E14 ships with an AMD Ryzen that has 8 cores/ 16 threads.
AMD has been kicking Intel’s butt the last years in performance and they also managed to offer their CPU, or APU as they call it, at a lower price, hence the speed performance.


Do you mean Intel Xe? I use eos on the same machine and don’t have such problem, I can use both current and lts kernel. I don’t have a problem with sound neither.

Needs more hardware info, are you using carbon X1? Did you try to make any changes related to graphics card or sound? and which DE are you using?

You can open the eos welcome app and select log tool to post a link with hardware info. Or on top of this forum, click help, log tool menu.

I personally don’t like Intel Iris graphics. I also don’t like the new onboard graphics on their desktop processors for linux anyway. That’s without even trying them. :grinning_face_with_smiling_eyes:

Hello thanks for the answer here is the configuration of the X1 sounds is actually not to bad very low tho! But yes the graphic card isn’t working at all on that one unless I used LTS! Then its fine!
Here is the machine!

I think I try to get some log before that was hard! But I got some here a bit older:


Thanks you


That the two devices it’s day and night:!


and the other rocket:


Crazy the difference between the 2!

Have you tried removing xf86-video-intel?

1 Like

I think in this case, the Intel CPU has been limited to prevent overheating or from the fan continuously spinning. The X1 is slimmer in design than the E14.

Yes that was one of the first thing I did with the X1 because I couldn’t take any screenshot with that bloody driver install haha!

Here is what I got if I don’t use the LTS

Pretty Funky haha


You are right! It worked before but haven’t logged into recent kernel for a while. Now running on lts no problem. Since the last couple of updates graphics are totally glitchy on newest kernel.

I have 5.15.5 glitchy and 5.10.82-1 lts no problem. What the hell!? They must have messed with the Intel driver. :face_with_raised_eyebrow:

1 Like

Such a bummer cos that was running quite good before hand!