Intel 12th gen compositing issue

I just purchased an Intel i7-12700 to build a new computer. I haven’t bought a gpu yet and was planning to use the integrated graphics cards for a while.
I installed endeavourOS with i3wm. During the install the progress bar of the installer was glitching and was cyclying between 0% and 1%, however the terminal showed that the install was progressing without any issues, so I kept it as a glitch in the current version of the installer. Install finished in the terminal while the gui still kept glitching, moving the installer updated to to show completed.
i3 works fine till I try to enable picom. Enabling picom freezes the whole screen, but the cursor works fine (probably xrender). When I say the screen freezes things are happening in the background as I can hear the sounds and interact with the elements through keyboard and mouse. I don’t know where to find errors if there are any.
Other desktop environments I have tried:
Gnome: Xorg: works similar to i3 without picom, I think. Wayland: Lose access to even the cursor
kde: it just keeps on glitching
XFCE: if you include the live ISO, I now do think that the installer was also glitching for same reason, I have tried on old computer and it works fine there.
(I have tried 2 different ISO files with 2 different USB and the problem persists)

Issues with steam:
Steam also suffers from this issue and is a mess to traverse. I tried a game (StoryBookBrawl) and it also suffers similarly.

One way I have found to force update gui is to move the affected window, which doesn’t always work. As far as I am aware this is a software issue.


inxi -Fxxc0z --no-host

journalctl -b -0

1 Like

Try uninstalling xf86-video-intel. The modesetting driver is often better with the newer Intel chips


This fixed the issue, thank you very much.

1 Like

Welcome to the forum @beigeoat



This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.