Insurgency Sandstorm steam overlay issue

Hello! I got Insurgency running (and it runs excellent!) through Steam with Proton GE-Proton7-47 but after launching the game, the steam overlay just doesn’t work, doesn’t respond to any keyboard shortcut. It works fine in other games, does anyone have any idea on how to fix this?
I’m using endeavor 6.1.7 with gnome.

I know some games the steam overlay doesnt work right. I.E Dark Souls 3 has overlay issues.

Did you check to make sure the overlay isnt disabled for that game somehow? \

Might you be using gamescope or FSR built into GE?

overlay isn’t disabled, no special command lines, it just doesn’t work. Also I didn’t to any changes to Proton GE like use gamescope or FSR (unless they are included somehow). Don’t really know how to check.

Have you tried running it without using Proton-GE and just use regular proton to see if it still happens?

it runs exclusively with proton-GE, any other version I try, it crashes when attempting to launch

you could try running with the launch arguement




to see if one or the other fixes things. Ive had FSR prevent steam overlay working but i also dont generally use GE anymore.

It’s a known issue for games with EAC:

The overlay works indeed, however it is in the EAC window that comes up before the actual game starts.

If you use gamescope, the overlay will work.


There you go, if its an EAC game then its probably this.

1 Like

thank you for the solution, I’ll begin my documentation on how to do that.

yep, I totally forgot to mention that…damned anti cheats

i also couldve done 2 seconds of research on the game to find that lol


done, works fine, I’m playing the game with the following arguement : gamescope -w 2560 -h 1080 -f -- %command%

is this ok? or should I add some other parameter? first time using gamescope

you actually want the command to be this

gamescope -W 2560 -H 1080 -f -e -- %command%

capital W and H is the output resolution for the window and lower case is just the resolution presented to the game. Itll work with lower case but upper/capitals is prefered

-e makes controllers, steam integrations,etc. work properly in gamescope

otherwise youre good

EDIT: From gamescope git

-W, -H: set the resolution used by gamescope. Resizing the gamescope window will update these settings. Ignored in embedded mode. If -H is specified but -W isn't, a 16:9 aspect ratio is assumed. Defaults to 1280×720.

Huh, never had such a problem with Apex Legends which uses EAC.
EDIT: Apperently only EOS EAC is affected, not legacy EAC

Oh I see, thank you for the great tip! These details matter since I’ll be gaming on Linux

Yeah strangely enough I play predecessor on the same machine/proton version which also uses EAC and I have no issues with that…

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.