Installing Spotify

Looks like spotify is flagged out of date again. You can install it using the following command.

yay -S --mflags --skipinteg spotify

Just press n to not import the key.

2 Likes

You can also install it with number 17 of yay spotify:

17 aur/spotify-dev 1.1.26.501-1 (+13 1.11) (Instalado)
    A proprietary music streaming service

I’m not sure. I usually pick 1. This is only for a fresh install. If you already have it installed it’s not going to update because the key is out of date. So if you have it installed and it’s not updating then you’ll have to wait.

I always use the -dev since it is always up to date and I don’t have to wait for the one, since the -dev if I remember correctly, was Debian who brought it to linux.

1 Like

you could also use the snap or flatpak package which are at the same version as spotify-dev

https://aur.archlinux.org/packages/spotify/

Does the snap work again? Couple of weeks ago it was broken AFAIK.

not sure, I use the flatpak which works fine

Really thankful for this wisdom!!

brandent

Changed to the DEV version just to try it and now Spotify just give me err code 4 (No internet) no matter what I do.

Are you referring to the one @Resiliencia mentioned?

Yep. The normal package has been outdated since the 9th.
Edit: It’s my VPN that does it. Works with the old version of Spotify,

I’m not understanding ? What do you mean your VPN does it? I just use the mflags to install #1 without checking the license and it installs. Not sure it works on any of the others.

Not sure you understandd the problem:
I install spotify-dev without problem, but after logging in, it suddenly says I am in offline mode, it cannot reach the internet.

Turns out that after trying everything I found online to solve the issue it is as simple as disabling my VPN, suddenly Spotify can reach it’s servers and play music.

However, uninstalling spotify-dev and reinstalling spotify fixes the issue.

In other words, I probably should never update spotify again or it will stop working with my VPN. Unfortunately.

3 Likes

I just reinstall so much i don’t think about it other than when i try to install spotify and it won’t then i get annoyed. :grin:

1 Like

I was having the same problem with Amaz0n Prime movies. I called my vpn’s support group and was told that Amaz0n was doing things to prevent piracy that most content providers didn’t do. They said not all their remote servers were capable of connecting to Prime. So they gave me a list of their servers that would most likely work. I picked the closest, didn’t work, picked the second closest and it worked.

Maybe the newest version of Spotify is doing similar things. Have you tried changing the VPN server you are using to a different one? Probably a long shot, but what the heck, give it a whirl.

Pudge

2 Likes