Installing Plasma defaults to Wayland

Hello!
I installed plasma too, following the guide provided here (I noticed that qt5ct is not installed by the way) and I think I have the same problem, I login to plasma and when my session loads, I open almost any application, including the system configuration one, and I can see nothing, the icon of the opened app is visible on the taskbar but the windows itself is not visible, if you pass the cursor over the icon on the taskbar, you can view a preview of the window, but it doesn’t matter how many times you click on the icon, the window won’t be visible, I can also get a lot of artifacts on the screen sometimes while the windows is supposed to be visible, if I minimize it, the artifacts go away.
I checked if, as @mjl says, the session starts in wayland, but it doesn’t, it is actually using X11 in my system.
I was able to open some of the apps and they seem to display correctly, I opened “konsole”, the clock configuration GUI, the desktop configuration GUI, the KDE menu and the KDE widgets menu.
I looked for possible solution in the arch wiki, I tried this solution, but it didn’t change anything.
I also deactivated lightdm and activated sddm to see if that solved the problem, but nothing changed.
I wanted to try deactivating the compositor to see if that solved the problem, but I can’t access the GUI and I don’t know where that setting is stored.
Is there any log files I could provide so you can check what’s going on? If so, please tell me where I can find it or how I can get it into a file so I can see it on XFCE (I reinstalled XFCE as I can’t do much on Plasma right now).

I am stuck right now…

Hopefully this won’t happen when the online installer is released, I love KDE and I love EndeavourOS and I CAN’T LIVE WITHOUT THEM (T_T) (LOL).

I have plasma installed in vbox and it all works perfect but it’s not recently that I installed it. How do you know it’s running on Wayland? So i checked and mine is running on X11

[rick@kde-pc ~]$ loginctl
SESSION  UID USER SEAT  TTY
      1 1000 rick seat0    

1 sessions listed.
[rick@kde-pc ~]$ loginctl show-session 1 -p Type
Type=x11
[rick@kde-pc ~]$ 

On mine Qt5 is installed. It just did a pile of updates.

Yes, it seems that older installations of KDE/Plasma are fine and update without problems. It’s just new attempts that have problems. My desktop that has EndeavourOS KDE/Plasma X11 installed for about 3 months is solid. But my attempt to reinstall the latest ISO and convert to KDE and sddm on an Intel I7 notebook fell flat on it’s face just as the OP reported, but I didn’t try to determine if it was running Wayland. Might give it anther try tomorrow.

Maybe i will try installing it again on vbox and see what happens? I ran the commands on mine and it is using x11 and all the Qt5 stuff is there and man does it work good . I have tried KDE plasma so many times and this is the best running version so far. I don’t know why.

Edit: Ya it’s not working i just tried it.

for plasma you must install the wayland session seporate like plasma-session-wayland, make sure you dont have installed that :slight_smile:

As promised, here’s how I reinstalled kde/plasma on my notebook. Something changed on the latest iso (Oct or Sept) to cause problems so I installed the August version and updated. I’m building a new computer and don’t have time to troubleshoot the October release problems. Expect many, many updates.

Install the August 17,2019 version of EOS iso
Boot, but do not login
Open a tty session (ctrl+alt+f2 on my system)
Login
Remove kalu
    sudo pacman -Rsn kalu
Install plasma and sddm
	sudo pacman -Syu plasma sddm sddm-kcm
(Expect a $*%@ load of updates to install with the plasma and sddm)
Enable sddm to start at each boot
	sudo systemctl enable sddm.service --force
Remove xfce4 and lightdm display manager
	sudo pacman -Rsc xfce4 xfce4-goodies lightdm
Reboot and login
Setup kde/plasma as you want

Review other posts and:


for more details.

This doesn’t work for me it has the same graphic problems reported. I have been able to install it another way and it was working but some components are missing and i had to add them but i’m not familiar with all the packages that are required so some may still not be installed. I would have to compare it to my other working vbox install. The online installer will work. We just have to be patient. :wink:

Hmmm don,t know what is going on. It worked for me on 2 systems.

Well that’s strange? It does install and it does work until you try to open an application and then the problems start with graphics. The other way i did it works but some applications are missing. Like the file browser and terminal etc. and more but i’m not sure which ones.

I would not have installed Plasma instead of the XFCE desktop but installed it with it. I have multiple desktop environments installed, namely XFCE, Mate, KDE Plasma, and whatever I enter, it works fine. Of course, this is me, everyone prefers their own aspects.

but wayland is a depency , but to enter wayland you have a seporate start function thats not standard in kde , journalctl -b in a pastebin service would be nice ?

Ok, I’ve fixed it. This is a REALLY simple fix and it works on the latest iso. I have copied most of the steps from CMarch’s post above to make things easier.

  1. When installing, don’t choose the ‘automatically login’ option.
  2. Following the reboot, at the login screen, switch to a new tty (ctrl+alt+f2)
  3. sudo pacman -Rsc kalu
  4. sudo pacman -Syu plasms sddm sddm-kcm
  5. sudo systemctl enable sddm.service --force
  6. sudo pacman -Rsc xfce4 xfce4-goodies lightdm
  7. rm .xprofile
  8. switch back to the lightdm screen (ctrl+alt+f7) and choose reboot
  9. Login and Ta-da!
1 Like

The one thing you didn’t have was remove xprofile which is what did a different way and it was okay except I was missing some apps. So I’m going to try it again tonight and see if I have luck like @mjl.

yep, that was the entire problem - .xprofile needed to be removed to fix it. I just added it in to a step-by-step guide to make it easier. Let me know if it works for you.

1 Like

@mjl thanks for this solution. I don’t have a .xprofile. Maybe the August version did not create one. I’m building a new computer and all the parts will be here in 2 days. I’ll try with the latest release (October) and see if a .xprofile is created.

Did you by chance open .xprofile to see what it contained?

so far i know .xprofile should containing xcompmgr probably that was the issue because plasma also want control te composition.

Okay… well it doesn’t work for me again. Terminal and what ever is missing and you can’t launch applications they just sit in the task bar. :rage:

I already have it installed previously and it’s not a problem. So i stop now…:unamused:

That is the solution for me, so yours is slightly different. I will bet it is still something to do with compositors.

I’m doing it on v-box so maybe there is some difference?