Installing amdgpu-pro-libgl causes black screen

Hi there! I have used Arch-based distros intermittently for the past three or so years, and although I know things aren’t perfect (especially in the world of Linux!), things have been relatively smooth sailing. EndeavourOS, for the most part, is no exception! I really like how close it is to Arch while being its own thing, unlike Manjaro, where it deviated in a few major ways.

However, since pretty much day one, I have had a few major issues, the most severe one being unable to install the amdgpu-pro-libgl drivers, which is needed for using DaVinci Resolve, my preferred editor. Although they will install, upon a reboot, there’s… a black screen. My first instinct was to try to get into a TTY but doing the faithful ctrl-alt-f2 did absolutely nothing. I’ve tried different computer keyboards, including one with extra arrow keys, making getting into TTYs very easily, but that also didn’t work.

I’ve talked to a few people about this, and they have no idea what’s wrong. They said it could have been an issue with my display manager, but I have no way of knowing this. If anyone has any idea why this might happen, I’m happy to hear and try them out. Thank you!

Did you go through the wiki here under:

Workaround for using proprietary OpenGL

I’ve tried that out already, and it sadly didn’t do anything - it still failed to load Resolve. I’ve also tried to install to a non-root location to no avail.

Additionally, as stated, trying to get into tty2 never worked. Do you think it would help if I chose a different DE or display manager?

I really don’t know. I guess you could try. :man_shrugging:

Those drivers were flagged out of date on the 7th of December. Seems the maintainer of that package is having issue as well.
You may find a solution in the comments there. The opencl-amd package is up to date and may solve your issue.

Fickle thing that darned AUR:)

Yeah, that is true. I tried out opencl-amd, but that sadly didn’t work out. The program didn’t open, so that is quite unfortunate.

Yeah, the AUR is such a love-hate relationship. I love it when it works, but when it doesn’t, it gets really annoying haha