Installer does not work correctly on ASUS PN64 mini pc

I have EOS installed on my PC about 2 years and have experience in it. Now I tried to install EOS Cassini on my new ASUS PN64 mini pc and installer did not work correctly. Then tried Artemis and it was better, but also didn’t work correctly. Then tried Manjaro KDE and it works perfect without mistakes. I am writing so that the developers pay attention to this.
The installer interface pages do not load at some steps, the bootloader switches do not work in Cassini. The “next” button stops working at the disk partitioning stage. After installation (1 time the installation went through, although its process was not displayed), the KDE interface looks crooked, the icons in the bottom panel are collected in a heap and the OS interface is buggy and does not load program pages, as during installation.
I tried to install different versions of EOS about 5 times.
I suspect that Manjaro installs and works perfectly on this device because it uses KDE in the installer as opposed to EOS which uses XFCE
And even when the system, by some miracle, was installed blindly, it worked just as incorrectly, despite the fact that it was KDE. Although the same KDE Manjaro works just fine.
I now have Manjaro installed and configured on this device and naturally no logs have been saved.
I have EOS on all devices. Even the macbook has EOS. And I also want to install EOS on this device, but at the moment it is impossible due to the incorrect work of the installer. And I writing here in the chat so that the developers of my favorite distribution kit would pay attention to this.

Does your mini PC have a 12th gen Intel CPU?

Yes, 12.
Checked now manjaro XFCE works correctly, so it’s not about the environment.

It is because of xf86-video-intel. There is an issue with 12th gen CPUs.

Manjaro does driver detection so it probably uses the mode setting driver.

We aware of the issue.

1 Like

You can try uninstalling xf86-video-intel and lockout from Livesession it will restart x …plus removing the same from install list inside installer

Why doesn’t EOS driver detection? When will the problem in installer be fixed approximately?

What driver should be used then?

@dalto Would this be applicable here in the installed system in this case?

Users with newer ~12th gen IGP’s may see issues where plasma desktop is almost unusable. It appears to be an issue with accelerated items. Running glxgears will report a high frame rate, but the animation will not be updated. A possible solution here is to change the driver under X.

/etc/X11/xorg.conf.d/20-intel.conf

Section "Device"
  Identifier "Intel Graphics"
  Driver "modesetting"
EndSection

https://wiki.archlinux.org/title/Intel_graphics#Issues_with_selecting_Qt_elements_within_Plasma_Desktop_on_Alder_Lake/UHD_770

Doing full blown driver detection is a massive effort.

We don’t have a fixed timeline. We are considering alternatives.

I suppose so? That just sets the modesetting driver. I think a better solution would be to not install(or remove) xf86-video-intel which would solve the same problem in a more flexible way. The level of effort is the same either way.

2 Likes

Just checked and now I have xf86-video-intel installed in Manjaro and it works great. Apparently the problem is something else.

It doesn’t mean anything. You can set the driver to be used in the X config too as described above.

Removing it is just a simple way to switch to the modesetting driver with intel hardware that won’t later require X config changes.

What does inxi -Fxxxz show on your Manjaro machine?

System:
  Kernel: 6.1.1-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    Desktop: KDE Plasma v: 5.26.4 tk: Qt v: 5.15.7 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Mini-pc System: ASUSTeK product: MINIPC PN64 v: N/A
    serial: <superuser required>
  Mobo: ASUSTeK model: PN64 serial: <superuser required> UEFI: ASUSTeK
    v: 1.15.00 date: 11/21/2022
Battery:
  Device-1: hidpp_battery_1 model: Logitech G603 Wireless Gaming Mouse
    serial: <filter> charge: 100% (should be ignored) rechargeable: yes
    status: discharging
CPU:
  Info: 14-core (6-mt/8-st) model: 12th Gen Intel Core i7-12700H bits: 64
    type: MST AMCP smt: enabled arch: Alder Lake rev: 3 cache: L1: 1.2 MiB
    L2: 11.5 MiB L3: 24 MiB
  Speed (MHz): avg: 2161 high: 2700 min/max: 400/4600:4700:3500 cores:
    1: 499 2: 2700 3: 2700 4: 2700 5: 582 6: 2700 7: 785 8: 2700 9: 460 10: 2700
    11: 2700 12: 2700 13: 400 14: 2700 15: 2700 16: 2700 17: 2700 18: 2700
    19: 2700 20: 2700 bogomips: 107560
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: Intel Alder Lake-P Integrated Graphics vendor: ASUSTeK
    driver: i915 v: kernel arch: Gen-12.2 ports: active: HDMI-A-1 empty: DP-1,
    DP-2, HDMI-A-2, HDMI-A-3 bus-ID: 00:02.0 chip-ID: 8086:46a6 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.6 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,vesa dri: iris gpu: i915 display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: HDMI-A-1 mapped: HDMI-1 model: Sony TV serial: <filter>
    res: 1920x1080 hz: 60 dpi: 48 size: 1018x573mm (40.08x22.56")
    diag: 1168mm (46") modes: max: 1920x1080 min: 640x480
  API: OpenGL v: 4.6 Mesa 22.3.1 renderer: Mesa Intel Graphics (ADL GT2)
    direct render: Yes
Audio:
  Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:51c8
    class-ID: 0403
  Sound API: ALSA v: k6.1.1-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.63 running: no
Network:
  Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:51f0 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  Device-2: Intel Ethernet I225-V vendor: ASUSTeK driver: igc v: kernel
    pcie: speed: 5 GT/s lanes: 1 port: N/A bus-ID: 02:00.0 chip-ID: 8086:15f3
    class-ID: 0200
  IF: enp2s0 state: down mac: <filter>
Bluetooth:
  Device-1: Intel type: USB driver: btusb v: 0.8 bus-ID: 3-10:4
    chip-ID: 8087:0033 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
RAID:
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
    v: 0.6 port: N/A bus-ID: 00:0e.0 chip-ID: 8086:467f rev: class-ID: 0104
Drives:
  Local Storage: total: 465.76 GiB used: 61.2 GiB (13.1%)
  ID-1: /dev/nvme0n1 vendor: Sabrent model: Rocket 4.0 500GB
    size: 465.76 GiB speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: RKT401.3 temp: 32.9 C scheme: GPT
Partition:
  ID-1: / size: 448.56 GiB used: 61.2 GiB (13.6%) fs: btrfs dev: /dev/dm-0
    mapped: luks-108a362a-9bfc-450a-8cdf-89e517ee0d72
  ID-2: /boot/efi size: 299.4 MiB used: 752 KiB (0.2%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-3: /home size: 448.56 GiB used: 61.2 GiB (13.6%) fs: btrfs
    dev: /dev/dm-0 mapped: luks-108a362a-9bfc-450a-8cdf-89e517ee0d72
  ID-4: /var/log size: 448.56 GiB used: 61.2 GiB (13.6%) fs: btrfs
    dev: /dev/dm-0 mapped: luks-108a362a-9bfc-450a-8cdf-89e517ee0d72
Swap:
  ID-1: swap-1 type: partition size: 16.9 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/dm-1 mapped: luks-f9708cec-e081-4d15-8962-f583c868d104
Sensors:
  System Temperatures: cpu: 33.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 350 Uptime: 13h 34m wakeups: 33 Memory: 15.37 GiB
  used: 2.24 GiB (14.6%) Init: systemd v: 252 default: graphical Compilers:
  gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman pkgs: 1091 Shell: Zsh v: 5.9
  default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.24

As suspected, you are using the modesetting driver.

If you were using the intel driver it would say loaded: intel

3 Likes