Installed , rebooted and stuck in logo

I have tried to install the last two system versions (Gemini,and the previous one ), and upon completion and reboot, it always gets stuck on the Asus logo, or a black screen appears, and the system never starts

Have you checked your boot priority and BBS priority within your BIOS?
if all seems ok, try to press F10,F11 or F8 (but this varies too), during boot, to go into boot selection, and selecth the Linux Boot Manager.

Or simply go into your BIOS and from there, force to boot from the Linux Boot Manager entry.

Are you using UEFI?
You can try booting back to the live install medium then, and see what efibootmgr -v gives back for the boot order with the entries aswell.

1 Like

https://discovery.endeavouros.com/forum-log-tool-options/how-to-include-systemlogs-in-your-post/2021/03/

cat ~/endeavour-install.log | eos-sendlog

Possible also to mount from livesession
in case system do not boot installed system and sens it to pastebin:

sudo cat /run/media/liveuser/endeavouros/var/log/endeavour-install.log | eos-sendlog

In cases i saw also Bios/Firmware settings where you can set usb to boot in legacy mode and harddrives still boot min efi mode…

With this a condition can happen where calamares (Installer) installs in legacy Bios mode but system boots in efi mode.

Yeah, I’ve tried all of that and nothing just happens.


And "[quote=“Magus, post:2, topic:54881”]
efibootmgr -v
[/quote]

Gives “no driver order it’s set”(it’s strange tbh)


image

is this normal?

Yes it is, since you’re trying to read the log files on a live system which is not present. Open up Dolphin, mount up the partition by clicking on the partition you think you installed eos on, and arch-chroot into it, then issue the command again. It should work this time

Or maybe a bit easier way: when you mounted up, start clicking through the folders within that mount point: /var/log/endeavour-install.log it should open up with kwrite or kate - doesn’t matter, and from there you can copy paste here.

you need to mount the partition from livesession before that …

no need to arch-chroot for the log its only a file and eos-sendlog is present on the iso livesession.
So should work after mounting the filesystem from dolphin.

Yeah I just added an easier part edited my OP, while you were typing :smiley:

Ps. I was also suggesting the chroot, as a just in case scenario if we need the actual inxi report from his actual installment, which really needs the chroot then, but hopefully we gonna adress it for the OP soon enoigh.

sorry, my bad, i did not know that
now i have a 0x0 . st link (looks like logs), should i sent it here?

if the file starts with:

########## /home/liveuser/endeavour-install.log by eos-install-mode-run-calamares

then yes.

https://0x0.st/XXR1.txt

1 Like

Ok, I’m not gonna pretend if I could decode everything from the log, but what I can read from it is that you booted your installer into the default option which has the nouveau drivers for your nvidia card, which might caused this behaviour.

Device-2: NVIDIA GM108M [GeForce MX130] vendor: ASUSTeK driver: nouveau v: kernel
    alternate: nvidia_drm,nvidia non-free: 545.xx+ status: current (as of 2024-04; EOL~2026-12-xx)
    arch: Maxwell code: GMxxx process: TSMC 28nm built: 2014-2019 pcie: gen: 1 speed: 2.5 GT/s
    lanes: 4 link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.0 chip-ID: 10de:174d class-ID: 0302

My friend had same symptoms in the past with his nvidia machine by using nouveau, but when I told him to install it through using the 2nd or 3rd option (can’t remember which one really, but it had nvidia keyword in it), then it worked out of the box.

You can wait for others inputs too, maybe they have more ideas, this is what I could think on at first glance, mount points and filesystems seem ok (GPT and seems you’re into UEFI which is the perfect pair), I’m just leaving this suggestion here, if you’re into it, you can always chroot (mentioned in my above post) and use the nvidia-inst tool, in order to install the propriatary nvidia driver and see if it works, or make a clean reinstall, but this time, boot into the supported nvidia driver entry when the live install offers it so.

Thank you very much for your help, I will do a fresh reinstall, it seems strange to me that in other systems I do not use that option and it works (since it says latest cards only), but I suppose it makes sense

Edit : let’s see if this works, I hope so

1 Like

Crossing fingers for ya :crossed_fingers:
Also yeah “latest” your card was released around late 2017s / early '18s, its pretty latest imho. Idk what they mean latest, but I always base on this list:

If my cards are on this Vulkan supported list, I always take it as, its pretty latest then :smiley:

On my other rig Fujitsu Epsrimo 510, I had a nvidia quadro k620 which was released around 2014, I was like, hell ye, for me that 10 year was still yesterday so I was like ok it’s still “latest” haha xD :smiley: Gave it a shot, and it worked like a dream :heart:

edit: Fixed the link, coz it was broken with the search call, but u can type yours in tho

1 Like

Strange, For some reason, it is stuck again on the Asus logo(I don’t know if I did something wrong), what do you recommend I try? The "nvidia-inst " thing?

You can give it a try too then, but at this point, I doubt it would solve the issue. Before you do it, can you post your calamares log again? Just to check

Sure, give me 10m

Take your time, I’m trying to respond asap, I’m multitasking like crazy atm :'D

1 Like

https://0x0.st/XXRC.txt
There is :stuck_out_tongue:

1 Like