Installed 'eos' without 'efi' partition

I installed eos without adding the efi partition. It complained, but that’s fine at the time, because efi is controlled by another linux install. I just added eos to my grub.cfg.

Now I want the eos install to be in control. grub-install doesn’t work because I didn’t include it on original install.

I don’t want to re-create efi partition because I have other OS’s installed.

I tried mounting efi to “/mnt”, which it did but “/boot/efi” isn’t there.

Is there a way to create folder “/efi/EFI” and add eos to the mix. efibootmgr magic??
This is most likely simple, but has slipped my mind.

sudo grub-mkconfig -o /boot/grub/grub.cfg

1 Like

I don’t know how you did it but if you are doing manual partitions you can select the /boot/efi partition that you have for current setup and eos will take over but use that current efi partition. You just have to browse to that /efi partition and mark it as as /boot during the install.

1 Like

you can use the efi partition already there from another linux or windows install, to do so you need to add this to fstab to make sure it is mounted on the right place like so:

UUID=84375803475083475 /boot/efi vfat defaults 0 1

put in the uuid of the efi partition from second installed os
then mount it manually sudo mount /dev/sdXn /boot/efi
you need to get uuid for the partition and current dev path to do so:

lsblk -f
ls -l /dev/disk/by-uuid/
fdisk -l

Thank you!
I tried all the usual fixes. None worked because eos didn’t have ‘efi’ mount on boot.
I could mount it after boot, but that isn’t the same.
Didn’t think fstab would do the trick. I had to use to additional commands to complete the operation:

sudo grub-install /dev/nvme0n1p1
sudo grub-mkconfig -o /boot/grub/grub.cfg

I find all Calamares installs, needs to know where efi files @ efi location is. Lubuntu is another one.

All my Ubiquity installs doesn’t bother to ask where and how to configure ‘efi’. It just does it. Not better, just different.

I have to remember this link, very helpful.

One last thing though. All debian installs, has grub.cfg inside the ‘efi’ partition, as so:

search.fs_uuid 08f6cbed-48d0-44e7-b182-7ab2752d483d root 
set prefix=($root)'/boot/grub'
configfile $prefix/grub.cfg

But ‘eos’ doesn’t have that file. I wonder if its an Arch thing or not.

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=EndeavourOS-grub

as you can see here:


What you do was install grub on mbr (MasterBootRecord) [grub-install /dev/nvme0n1p1] what is not the way to do it on gpt efi systems… where you install into filesystem (/boot/efi) same as what you have on debian systems
2 Likes