Installed Apps Not Working

Hello all,

I am new to Endeavour but not to Linux. however I am mostly a point-and-click guy with little experience of the terminal (one of the reasons I switched to Endeavour).

I used the pacman command to install several programs (Signal, Telegram and Chromuim).

It all seemed to go fine and the installed programmes appear on my launcher - however they do not start when I click them. I also tried running them from the terminal - same problem.

Am I not doing something I should have done?

I’m running endeavour on a Thinkpad X240.

Thank you :slight_smile:

Hello @philco
What happens when you try to launch them from the terminal? Is there not any error messages you can show?

Edit: not sure how you installed them but here are the commands.

sudo pacman -S chromium

sudo pacman -S signal-desktop

sudo pacman -S telegram-desktop

Hi,

Thanks for your reply.

I used exactly those commands to install and they appear to have installed correctly. They are listed in the app list as you would expect. but when I click on them nothing happens.

When I try to run signal-desktop in the terminal I get: electron: error while loading shared libraries: libicui18n.so.67: cannot open shared object file: No such file or directory

Any ideas what I’m doing wrong?

(I presume t is me messing up here :slight_smile:)

Try sudo pacman -Syu first if you haven’t already

Thank you @Tasia91 - I tried that and it seemed to install something or run a process.

Still won’t run the apps.

Thank you though :slight_smile:

/usr/lib/libicui18n.so.67
is included in package icu from core repository:
sudo pacman -S icu

pacman -Qo /usr/lib/libicui18n.so.67
/usr/lib/libicui18n.so.67 is owned by icu 67.1-

1 Like

You beat me to it. :+1:

1 Like

Hi @joekamprad -

I ran the above command in the terminal and lost the launch button. I re-booted the machine but when I entered the password it just hung on a black screen with a cursor in the top right corner.

I booted again with the same result. I’m typing this on another PC.

Any idea how I can fix this or is it FUBAR?

strange… this is mostly installed on every system icu is only International Components for Unicode

So must be something else may you do uninstall something before ? may remove something needed for starting X or similar accidentally. Not FuBar … if you have EndeavourOS usb stick at hand… or try first to login from tty2 [Ctrl+alt+F2] if this shows a login prompt you can reinstall what is missing.

What DE (Desktop Environment) are you using?

If you can not login you can arch-chroot into system after booting installer usb // ISO:

Or boot without try to start Desktop Environment and DM (login manager):

if you are able to login to installed system in one way or the other, you can simple reinstall your Desktop:

Hi @joekamprad,

No, I didn’t uninstall anything or change anything. I was just trying to sort this issue.

I will try your other suggestions. Hopefully I will be able to get my desktop back. I’m using the themed Xfce desktop.

Thank you.

It all got a bit too complex for me so I just re-installed.

This time I installed Libre Office and Chromium through the Welcome dialog and, again, neither are working.

All of the pre-installed software seems to be operating as expected and when I try to add new apps the install process shows every indication of normal operation.

Any help would be appreciated.

I’m beginning to think it’s a problem with my laptop. However it was fine with Ubuntu.

Does it still give the same error about libicui18n.so.67? Because as @joekamprad said the file is owned by icu. So the command he gave was to install icu.

sudo pacman -S icu

Then he gave you the command which asks query ownership of the file.
pacman -Qo /usr/lib/libicu18n.so.67

It should report /usr/lib/libicu18n.so.67 is owned by icu 67.1-

icu needs to be installed so we needed to confirm that it is.

Hi @ricklinux,

Thank for picking this up.

I haven’t installed signal this time but I did install chromium through the welcome dialog.

When I try to run it I get: /usr/lib/chromium/chromium: error while loading shared libraries: libicui18n.so.67: cannot open shared object file: No such file or directory

I typed: pacman -Qo /usr/lib/libicui18n.so.67

And got: error: No package owns /usr/lib/libicui18n.so.67

hello, can you put us a screenshot to see the errors you tell thank you

I installed the three software in three different ways: chromium with the welcome interface, signal with the terminal and telegram with pamac-aur-git, I had no problem or error , on vm

Hi @JR29, yes when I first installed I used the welcome dialog to install Libre Office and Chrmium and pacman to install signal and Telegram. None of them worked.


pacman -Qs icu

should look like this:

pacman -Qs icu
local/harfbuzz-icu 2.6.5-2
    OpenType text shaping engine (ICU integration)
local/icu 67.1-1
    International Components for Unicode library
[joe@t-60 ~]$ 

seems it is again not installed… is system up to date?
sudo pacman -Syyu will make this sure…

@joekamprad I tried to update as you suggested but it failed.

I also tried via the welcome dialog but that failed too.

pacman -Syu --overwrite /usr/lib*/p11-kit-trust.so

1 Like