Installation stuck at 13%

Good morning all,

I am wanting to try and install EOS alongside a Windows 11 installation following the successful creation of a live usb to boot from. I have previously used Manjaro along with other distros and therefore familiar with how linux works but I am not, by no means an expert. My issue is that once booted in the live usb and updated the mirrors from the welcome screen, after which I then try and carry out a live install however this does not progress past 13%. I have even left the pc on overnight in the hope that this would complete, as I read about the slow mirrors articles however surely this should have completed after approx 8 hours. I have yet to try an offline install but specs for my machine are:

The Efi partition is on a NVME drive where windows installation is (unfortunately not enough space to cram eos on the nvme too).

Internet connection is not an issue by the way.

Any advice would be great. Many thanks in advance.

P.S. apologies if this is the wrong place to post this topic too

1 Like

Welcome to the forum! :rocket:

8 hours is absolutely way too much!

Could you post the logs from live environment after installer is stuck? You could use the log tool on live usb, or manually upload the log file from home directory.

If you don’t mind having Xfce desktop, offline install will be way faster. You can update offline install to latest version after installation easily.

1 Like

can you boot on USB live endaevouros
open a terminal and browser on this topic
and return

check all option in your UEFI

SecureBoot off
Fast Boot off
No Legacy
all disks on AHCI
No optane/RST

you can check in terminal before installing

inxi -Fxza
test -d /sys/firmware/efi && echo efi || echo bios
sudo parted -l

you may need vmd package for nvme

Hi please see below for the install log: Install logs

checking keyring...
downloading required keys...
:: Import PGP key C132293954BBE4AD, "Sergej Pupykin <>"? [Y/n] 

This is where it (probably) waited for user interaction.

@joekamprad Any idea?

Apologies I think this is the 2nd attempt to install following a reboot and forgot to run an update on the mirrors, however this was the same issue on the 1st attempt following an update of these. Will repost the log as with it being a live version the update won’t be persistent, right?

Will update once again post reboot and update…


Sorry posted reply incorrectly. Got banging headache :frowning_face:

No worries. Failed installations do make us dizzy :face_with_spiral_eyes:

this will not work we use custom calamares startup scripts, and these run calamares already in debug mode per default…


I did this in VM, seems to automatically proceed for me, without waiting for user input. Maybe I misunderstood the logs :sweat_smile:

As archlinux-keyring is freshly updated before starting base-system install with pacstrap module it looks like an issue with this specific key itself… … we run this before pacstrap install:

And it looks like it hangs on fetching the key … what could be an issue with connection to the keyserver…

1 Like

Ok, so attempting 3rd time install and once again stuck at 13%. Tried the sudo Calamares -d and got the following:

[liveuser@eos-2021.12.17 ~]$ sudo Calamares -d
sudo: Calamares: command not found

2nd set of logs

Hi thanks for the advice so far, would this automatically fix it itself if I did an offline install as it would not need to pull the PGP key down from the server during install or am I wrong in thinking that. Once install is complete I can then import the key by using terminal if that would work and workaround using a different DE post install.

Yep, offline should work perfectly. Once system is installed, you’ll have more options to fix issues.

 ca-certificates-20210603-1-any downloading...
checking keyring...
downloading required keys...
:: Import PGP key C132293954BBE4AD, "Sergej Pupykin <>"? [Y/n] 
checking package integrity...
loading package files...
checking for file conflicts...
:: Processing package changes...
installing iana-etc..

it simply should proceed … and apply “Y” automatically… (–no-confirm) what I just test with the release ISO… must be an issue with fetching key from your destination.

So us offline or if you want try tinkering and add pacman-key --refresh-key into command list on:
that it looks like so:


haveged -w 1024

pacman-key --init

pkill haveged

pacman-key --add /usr/share/pacman/keyrings/endeavouros.gpg && sudo pacman-key --lsign-key 497AF50C92AD2384C56E1ACA003DB8B0CB23504F

pacman-key --populate

pacman-key --refresh-keys

But if it is a keyserver issue from your destination… it will not help…

I am not sure why it needs to fetch that key anyway…

1 Like

I have just tried running the script commands line by line in terminal I am getting the following

So this may be the reason for the online installer failing. Proceeding with Offline and will then tinker about to see what I can do. Can we please keep the thread open while running the offline installer please. Many thanks :slight_smile:


Ok, so offline install successful thanks, but will be opening a new post on OS update as getting stuck in a loop now where it’s telling me there is an unresolvable conflict between jack2 and pipewire-jack once terminal asks if I want to replace hwids with core/hwdata. Irrespective of the choice (Y/n) I get the same error.

sudo pacman -Sy pipewire-jack


sudo pacman -Syu

Thanks will try that when I get back from shopping. Will update the thread with the results :slight_smile:

1 Like

running this on livesession (host) will not affect installation :wink: as install is running on target inside chroot…