Installation problems

Hi, im in a slightly sticky situation. I was on a stable installation (of endeavour os) until it suddenly broke and i was left with only a cli. I had only an outdated endeavour iso at the time and so that is what i burned to the usb. I am currently livebooting and am unable to install using this iso which i have (using other forum posts) put down to an old version. Obviously i am unable to update since i have no other system to use to burn a newer version to. I only have one usb, no other installations; however i do have multiple drives. I am pretty stuck. Any ideas?

You can probably do an offline install off that ISO and then use that install to download and burn a new ISO.


Tried and partly worked. It did install properly but now upon attempting to launch the new install I was met with what can only be described as an array of green dots?

If you have an Android phone, you could download the ISO and use EtchDroid to burn it to the USB.

You would need to have an adapter of some sort to connect the usb drive to the phone.

Disclaimer: I did this once before but it was quite a while ago. It worked for me back then.

Can you start a TTY (by pressing keys Ctrl-Alt-F3 when you see those green dots)? A TTY is a terminal interface where practically all CLI commands work.

If a TTY is available, you probably can download the new ISO e.g. with the wget command. Then burn the ISO to USB with dd. See commands

man wget
man dd


Many thanks for the help however overnight it seems to have magically fixed itself and green dots are now gone. All back to normal, almost.

1 Like

A good night sleep makes wonder! Even for operating systems, it seems.

Good luck!