Installation ISO

Has someone filed a bug report to the Xfce team?

I haven’t, specifically, but this thread appears in the bug reports section, so I hope the developers have read it.

No, I meant to submit a report also to the Xfce devs, the more bug reports come in on this issue, the higher the priority it gets to fix it. The Xfce devs are not a part of our dev team, we submit also bug reports, but the higher the numbers on this issue, the quicker it gets solved.

OK, I’ve submitted a bug report specifying my problem on the Radeon Vega graphics.


Can i have the link to the report? that way i can contribute with information.

When is latest ISO is releasing with kernel 5.3

The report is in ‘Bug Reports’. I think the link below should take you there.

Oh, I thought you sent the report to the XFCE team :thinking:.

To be honest, we all know the problem with Xfce4.14; it’s xfwm4 that doesn’t play nicely with AMD radeon graphics. We know how to solve that. My bug is with the installation iso that won’t allow me to see the desktop and the welcome screen because I get a green overlay. I can sometimes prevent that for a brief moment, but it’s very erratic.

Okay but have you tried other distro’s such as Manjaro because you are saying it’s the ISO? Do other Xfce ISO’s do the same thing? I find on my Radeon they do albeit Arcolinux is less of an issue on mine because they do not load the background and it goes directly into the installer plus they have some other options. But for my Radeon the other options are meaningless because it’s already loading Radeon. I have confirmed that with tests.

I installed my current Arch Linux the ‘arch way’ so obviously no problem. I have run the Zen installer part way and no problem with the ISO because it runs openbox and then presents you with the install setup. It’s a much fuller installer than endeavouros and offers the whole range of desktops. Presumably it’s a net installer. I have experimented with this endeavour os and it just gives me a green screen overlaying the welcome screen and installer. When I occasionally manage to see the welcome screen, I quickly run the vblank stuff in a terminal, but the whole installation is very shaky with frequent flashes of some of the initial loading printouts. It usually reverts to a green screen quite quickly. I’m not bothered about this. I have a perfectly good setup now and I was trying to find the solution to the green screen out of interest. So far, nothing works. I daresay that the next iso will solve the problem.

Update: I’ve had a thought. Perhaps tomorrow, I might run through an installation of Xfce using the Zen installer. At some point it will obviously download and install Xfce4 and it would be interesting to see if that causes the green screen on my system.

I have tried the zen installer and some other install scripts but the zen installer really didn’t impress me or many other install scripts. The best one as far as i’m concerned is Archlabs which uses an install script and you can select what ever desktop and all the applications. It is really good. Anarchy is also pretty good. But i was more interested in the fact if you tried other Xfce ISO’s because i have but i don’t have the AMD Ryzen 2200G with Vega graphics which is newer but my two older Radeons do give troubles also just not as bad because it subsides after a few seconds of going through it. I haven’ tried any install scripts since the new xfce 4.14 only ISO installs. I still beleive it’s an Xfce issue and not necessarily the ISO that is the problem but you are right that something needs to be done to fix it. Everything i have tried with my older two Radeon cards only made it worse like yours is.
I have also installed Arch Xfce the Arch way and it’s less dramatic when it hits the desktop but it’s still noticeable slightly on my Radeons. If you do get around to at least booting up on a few different Xfce ISO’s at least you can report your findings.

I chose Anarchy Installer because it was the most up-to-date. It installed the Anarchy Custom Xfce4 with Kernel 5.3.1 flawlessly. Of course, at the end, I had to deal with some artefacts, but the vblank mode sorted that out. I can’t say that I like the custom Xfce4; I shall probably reinstall my own! Anyway, it seems pretty clear that the endeavouros problem on my Ryzen with radeon is the installation ISO.

If you are interested I could upload a snapshot ISO with latest kernel and firmware, so we can test if this solved the issue on Live-Session.

1 Like

@joekamprad I would be willing to try it also on my older Radeons since i get some of the same issue albeit not as severe.

I believe the Archlabs installer will be even better than Anarchy and you can select everything separately. Manjaro on the other hand is worse for me. With Manjaro all you have to do is boot on the ISO and you’ll know. I don’t care for the custom Xfce4 on Anarchy either. :wink:

I’m willing to try that. It will have to be tomorrow because I am now busy for the rest of the day, just as soon as I can get this nasty Anarchy Linux off my computer!!!

Edit: I have just removed Anarchy and installed a simple Xfce4 from Zen Installer. There was no sign of artefacts - running with fully updated system and kernel 5.3.1.

Good to know…

ISO will be here in the next 3-4 hours …
Linux archiso 5.3.1-arch1-1-ARCH #1 SMP PREEMPT Sat Sep 21 11:33:49 UTC 2019 x86_64 GNU/Linux


1 Like

Finally…Now you have to tell me what changed because this works on my Radeon HD 3870 video card… Not one artifact on the live ISO. Boots up and i get a grey screen and then the cursor and desktop loads. I really hope this works for the AMD GPU 2200G and above.

Edit: I will also test it on my Radeon HD 7650

It is also the same on here. No artifacts on booting the live ISO. :thinking::wink: :+1: