Installation ISO on AMD Radeon Graphics

The latest installation ISO fails on my computer: Asrock Deskmini A300 with Ryzen 2200G w/ Radeon Vega Graphics. I have a Dell 24" monitor with 1920 x 1080 resolution. The earlier installation iso worked and the current installation iso works on my Intel NUC5.

The USB Drive Live CD produces a blank green screen. Nothing gets me out of that, even selecting Ctrl-Alt-F2. After many attempts to try different angles, if I interrupt the startup at automatic login with Ctrl-Alt-F2, I can type startx -- -depth 16 and get the installation welcome screen usually with artefacts. If I then type xfwm4 --vblank=off --replace at the command line, the artefacts stop. However, this situation is unstable and the screen flashes backwards and forwards to the earlier startup screens and eventually the computer locks up. Clearly this is an issue with radeon graphics.

I already have a full working and up-to-date Arch Linux setup. A few days ago, the artefacts started after (probably) a kernel update. I switched to the Arch Linux LTS kernel and all was well. Two days ago there were two updates to the Linux system and this solved the artefacts problem so i am now back to a stable Arch Linux with kernel 5.1.3.

Your installation ISO for me is unuseable on my AMD-based computer.


a new ISO will be there for Oktober, with latest kernel, hopefully solve this issue.


Same thing here, same 2200G CPU. There is a bug, and the only sane way (altough not my favourite) was to install Fedora 30. Everything just works.
I guess Wayland is to “blame”.

1 Like

this is something on with AMD with the latest 5.x series of kernel and XFWM4 , xfwm4 configures itself to auto, and causes artifacts.

to make it permanent after install :slight_smile:

xfconf-query -c xfwm4 -p /general/vblank_mode -s xpresent / off

xpresent or off on of the two…

1 Like

It may seem that the fix for AMD will be in the 5.4 kernel (instead of the scheduled 5.5 kernel.) The 5.4 kernel is scheduled for release in November.

To read more on this:

1 Like

You can install Arch Linux the ‘arch way’. I think the latest firmware update from pacman cured the amd radeon artefacts problem. It’s the installation iso that is the problem.

Yes, I (we) have been doing that to solve the problem once the system is installed, though it appears to be no longer necessary with the latest pacman updates. The problem is getting there with the installation ISO.

good to know :slight_smile:

Just a question please !
Have you tried to install it using the AMD Radeon option?
I too had issues doing that but ended installing in normal mode to get it working and setup my graphic card after install is correct !
Same thing happened with ArcoLinux on the same laptop until i get my hand on their latest release.

Blessings !

What do you mean by ‘AMD Radeon’ option?

Hello @davidw
I think @UncleMez is referring to the Arcolinux ISO which has a number of options in the menu such as Radeon, Nouveau etc.

1 Like