Installation failed (systemd-machine-id-setup not found)

Greetings! I was eager to check out the Endaveour OS April release, so I downloaded it and did an installation with Cinnamon. However, at the end of the installation, I got an error about systemd-machine-id-setup not existing:

I used this ISO just before on another device, and I verified it, so I’m pretty sure that that’s not the problem… Posting this right before I try again. Maybe I’ll boot in and the system will work anyways.

So of course it didn’t work, because it never mangaed to reach the bootloader installation stage which I believe comes at the end. I’ll try again.

it fails to install any package … try updating mirrors before start install

I figured that out, but the issue seems to be that the iso keeps dropping my connection at totally random times. I got it to the installation part, trying again…

I would just use ethernet but i don’t have access to it at the moment. I’d also like to get the core issue solved so that others can benefit :wink:

Some logs would be needed.
With eos-log-tool please provide info about network devices, e.g. the inxi log.

1 Like

I’ll do that as soon as possible, after installation finishes. It seems to be doing well so far. It worked before, so it may be the Usb dying.

Okay, I’ve managed to install enOS. Here is the inxi log:

1 Like

So all is OK now?

Yep, I got an installation going. April release works great! Fixed the bug where the iso randomly froze as well.

I also feel stupid now… the issue was not endaveour but my internet router overheating, lol.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.