Installation failed multiple times

Hello, I’ve tried to install endeavouros multiple times and can’t get it to boot after the installation.
What I’ve tried so far:
i3wm w/systemdboot(this is the current install)- doesn’t boot after installation, i get a black screen after selecting endeavouros at the systemdboot menu
i3wm w/grub- gets stuck at the second option(loading ramdisk i think) after selecting endeavouros at the grub menu
xfce offline install- black screen
arch- i tried to install arch with archinstall and got a pacstrap error
void linux- wasn’t able to get through the installer regarding partitions and filesystems

here’s the system info from the live iso

[liveuser@eos-2023.08.05 ~]$ inxi -Fxxc0z
System:
  Kernel: 6.4.8-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 wm: xfwm dm: LightDM
    Distro: EndeavourOS base: Arch Linux
Machine:
  Type: Laptop System: TOSHIBA product: Satellite P845t v: PSPJ5U-009002
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: TOSHIBA model: TOSHIBA v: 1.00 serial: <superuser required>
    UEFI: TOSHIBA v: 6.50 date: 09/26/2012
Battery:
  ID-1: BAT0 charge: 3.1 Wh (75.6%) condition: 4.1/4.5 Wh (91.0%) volts: 11.5
    min: 10.8 model: TOSHIBA KATMAI serial: <filter> status: not charging
CPU:
  Info: dual core model: Intel Core i5-3317U bits: 64 type: MT MCP
    arch: Ivy Bridge rev: 9 cache: L1: 128 KiB L2: 512 KiB L3: 3 MiB
  Speed (MHz): avg: 889 high: 1093 min/max: 800/2600 cores: 1: 1093 2: 800
    3: 800 4: 866 bogomips: 13574
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Toshiba driver: i915
    v: kernel arch: Gen-7 ports: active: LVDS-1 empty: DP-1,HDMI-A-1,VGA-1
    bus-ID: 00:02.0 chip-ID: 8086:0166
  Device-2: Chicony TOSHIBA Web Camera - HD driver: uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 bus-ID: 1-1.3:3 chip-ID: 04f2:b307
  Display: server: X.Org v: 21.1.8 compositor: xfwm v: 4.18.0 driver: X:
    loaded: modesetting alternate: fbdev,intel,vesa dri: crocus gpu: i915
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96
  Monitor-1: LVDS-1 model: Seiko Epson 0x4b45 res: 1366x768 dpi: 112
    diag: 355mm (14")
  API: OpenGL v: 4.2 Mesa 23.1.5 renderer: Mesa Intel HD Graphics 4000 (IVB
    GT2) direct-render: Yes
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Toshiba 7
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20
  API: ALSA v: k6.4.8-arch1-1 status: kernel-api
  Server-1: PipeWire v: 0.3.76 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin
Network:
  Device-1: Qualcomm Atheros AR8152 v2.0 Fast Ethernet vendor: Toshiba
    driver: atl1c v: kernel pcie: speed: 2.5 GT/s lanes: 1 port: 2000
    bus-ID: 01:00.0 chip-ID: 1969:2062
  IF: enp1s0 state: down mac: <filter>
  Device-2: Intel Centrino Wireless-N 2200 driver: iwlwifi v: kernel pcie:
    speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 8086:0890
  IF: wlan0 state: up mac: <filter>
Drives:
  Local Storage: total: 756.36 GiB used: 0 KiB (0.0%)
  ID-1: /dev/sda vendor: Toshiba model: MQ01ABD075 size: 698.64 GiB
    speed: 3.0 Gb/s serial: <filter>
  ID-2: /dev/sdb vendor: SanDisk model: Cruzer size: 57.73 GiB type: USB
    rev: 2.0 spd: 480 Mb/s lanes: 1 serial: <filter>
Partition:
  ID-1: / size: 10 GiB used: 128.6 MiB (1.3%) fs: overlay source: ERR-102
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 47.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 186 Uptime: 34m Memory: total: 6 GiB available: 5.69 GiB
  used: 2.15 GiB (37.7%) Init: systemd v: 254 default: multi-user Compilers:
  gcc: 13.2.1 Packages: pm: pacman pkgs: 900 Shell: Bash v: 5.1.16
  running-in: xfce4-terminal inxi: 3.3.28

Your hardware is fairly dated. I wonder if you install the lts kernel and try it. Are you able to get into a tty if you boot it up?

I did some research and someone on the linux mint forums had the same problem as me w/ very similar hardware. The person had a efi problem that was solved with refind https://forums.linuxmint.com/viewtopic.php?p=2109627&hilit=toshiba+satellite+p845t#google_vignette

Did you have other OS’s installed on this before installing EndeavourOS?

The only OS on the computer right now is endeavouros. It used to have windows installed. Today i tried to install void linux to see if that would work but it didn’t.

i tried installing arch last month after failing to install endeavouros but got a pacstrap issue

It doesn’t seem then that it would be the same issue that you mention on Mint. :thinking:
Are you able to boot on the live ISO and run

sudo parted -l

im on the live iso right now

[liveuser@eos-2023.08.05 ~]$ sudo parted -l
Model: ATA TOSHIBA MQ01ABD0 (scsi)
Disk /dev/sda: 750GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name         Flags
 1      2097kB  1051MB  1049MB  fat32                     boot, esp
 2      1051MB  750GB   749GB   ext4         endeavouros


Model: SanDisk Cruzer (scsi)
Disk /dev/sdb: 62.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size   Type     File system  Flags
 2      1922MB  2040MB  118MB  primary  fat16        esp

This laptop is UEFI correct?

I believe so. How do i check?

I’m sure it is since you are using systemd-boot.

Edit: You can also check by running

bootctl status

So are you able to boot on the system and get into a tty after by pressing Alt F2 or F7

i select the endeavouros option at the boot menu and it gives me a black screen. it looks like the screen freezes. i don’t believe ill be able to get to a tty.

here’s what that command gave me

[liveuser@eos-2023.08.05 ~]$ bootctl status
Couldn't find EFI system partition. It is recommended to mount it to /boot or /efi.
Alternatively, use --esp-path= to specify path to mount point.
System:
      Firmware: UEFI 2.31 (American Megatrends 4.653)
 Firmware Arch: x64
   Secure Boot: disabled (disabled)
  TPM2 Support: no
  Boot into FW: supported

Current Boot Loader:
      Product: systemd-boot 254-1-arch
     Features: ✓ Boot counting
               ✓ Menu timeout control
               ✓ One-shot menu timeout control
               ✓ Default entry control
               ✓ One-shot entry control
               ✓ Support for XBOOTLDR partition
               ✓ Support for passing random seed to OS
               ✓ Load drop-in drivers
               ✓ Support Type #1 sort-key field
               ✓ Support @saved pseudo-entry
               ✓ Support Type #1 devicetree field
               ✓ Enroll SecureBoot keys
               ✓ Retain SHIM protocols
               ✗ Boot loader sets ESP information
          ESP: n/a
         File: └─/EFI/BOOT/BOOTX64.EFI

Random Seed:
 System Token: set

No boot loaders listed in EFI Variables.

Oh okay… I get you.

Edit: I see what the bootctl status says.

Probably going to need some more advanced help maybe from @dalto

Edit2: Not sure this can be run on the live ISO anyway to give what output is needed. I forget that so this may be meaningless.

You may have to end up using arch-chroot to get some of the info that is needed to verfiy somethings but I don’t have the expertise with systemd-boot and dracut to really help.

thanks for the help up to this point

1 Like