Installation Failed - Bootloader installation error

Quick note: I’m a complete beginner to all this, I just saw endeavor and thought it looked pretty so I don’t understand most things.

Here’s the install log I got on the failure screen:

https://termbin.com/uhvw7

Tried running: 'cat /var/log/endeavour-install.log | eos-sendlog', went into the directory and there was no installation log.

Hardware information:

https://clbin.com/ngGVv

Boot log:

https://clbin.com/a7KHE

1 Like

Some other things that might be useful:

Disk Setup info:

https://clbin.com/KLmXm

"test -d /sys/firmware/efi && echo UEFI || echo BIOS" output:
UEFI

"efibootmgr -v" output:
"No BootOrder is set; firmware will attempt recovery"

Any help would be appreciated, thank you

Something I found here: https://discovery.endeavouros.com/installation/create-install-media-usb-key/2021/03/

I was using Rufus to create the installation media, and in the instructions it said to burn the ISO in DD mode, not ISO mode. Will update to say if this has made a difference.

Update: No it did not

Update your BIOS first.

Then try again (after you disable Secure Boot and Fast Boot).

1 Like

Same error!

efibootmgr -v now works, updated the bios
https://termbin.com/uhvw7

so there’s something in the boot manager, but sudo rm /sys/firmware/efi/efivars/dump-* doesn’t work, spits out an error about an invalid argument.

What are you creating the Live ISO on? Windows?

Edit: Your hardware log is not available.

Edit2: Did see your hardware in the boot log and see the Bios pointed out was quite old so good you updated that.

Just had to take out the “)”
I’m making the boot disk on rufus

Edit: Update, reflashing the disk also did nothing.

I even tried manually partitioning the drives by following these two tutorials:

And they both gave me the same error! I got the link the second time around.
"The installer failed to create partition on disk 'KINGSTON SA400S37240G'."
https://termbin.com/vwut2

If you are creating the ISO on Windows i would use etcher. There are many times users have problems using rufus or ventoy and i don’t recommend them. The other thing you could try is boot on the live ISO and before you run the installer use gparted to create a new gpt partition on the drive. Then close gparted and run the installer. Sometimes an issue happens for whatever reason and it fails to properly overwrite the partitions.

if install fail the log I only on the livusers home:

cat ~/endeavour-install.log | eos-sendlog

and the error:

Could not prepare Boot variable: Input/output error
grub-install: error: efibootmgr failed to register the boot entry: Input/output error.

looks like it can not read/write on the nvram … it could be corrupted, full, or holding a non-working entry… which renders it unreadable.

not much you can do from the installer side would need more likely resetting the nvram or entries inside from the firmware/Bios …

Possible to not write to nvram to create the entry indeed… like some users done to workaround such issue…

As @joekamprad also pointed out it may be that the nvram may be full. So you may want to delete entries using efibootmgr.

example command: bootnum = the boot number you want to remove

sudo efibootmgr -b <bootnum> -B

@ricklinux

I do think it is not showing any entries at all…

Maybe? Will it show if running efibootmgr booted on the live ISO?

let’s see …

From hardware output.

CPU:
  Info: dual core model: Intel Celeron N2830 bits: 64 type: MCP
    arch: Silvermont level: v3 rev: 8 cache: L1: 112 KiB L2: 1024 KiB
  Speed (MHz): avg: 1003 high: 1506 min/max: 500/2416 cores: 1: 1506 2: 500
    bogomips: 8671
  Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx

it even has:

Intel® Virtualization Technology (VT-x)

Apart from/before the vendor, that could give support on this, you have two more options.

  1. Try to install a UEFI entry on the default path, which can be done using the --removable parameter with the grub-install installation command
  2. Create a custom new boot entry, using BIOS UI (page 71).

I’ll try installing etcher and redoing the installation with that boot disk instead, will update.

1 Like

I got efi-bootmgr to output in a previous reply, here’s the link again:
https://clbin.com/YUpZA

I don’t know what to make of it.