Installation error with non-empty /boot partition

Firstly, I had the same problem as Atlantis Installation Failure. There was /home, /boot btrfs partitions that i don’t want to format and a new btrfs for the system. The solution says it works if not making separate /home partition (and it worked for me later), but I also wanted separate /boot.

When I install only / and /boot on separate empty partitions, it gives the same error. But if / partition is Empty and /boot was created by previous distro, there is another error message

Installation Failed: External command finished with errors.
Command systemd-machine-id-setup finished with exit code 127.
/usr/sbin/chroot: failed to run command ‘systemd-machine-id-setup’: No such file or directory

Are you using an efi partition also?

No, I’m on BIOS system

1 Like

I’m having the same issue, did you ever fix this?

No. I then installed system on one partition, it worked.

And it worked with ext4 and several partitions. But /boot was empty and I didn’t test with non-empty.

To be clear, which issue are you having and which specific error are you receiving because there are two separate issues in the first post.