Installation Error Surface Pro 7

I’m trying to get Endeavor OS to install alongside Windows on my Surface, a terrible idea for someone new but here we are.

I’m getting the following error at the end of the installation:

2023-07-09 - 11:23:15 [1]: void Calamares::ViewManager::onInstallationFailed(const QString&, const QString&)
    ERROR: Installation failed: "Boost.Python error in job \"windowsbootentry\"." 
2023-07-09 - 11:23:15 [6]:     .. - message: "Boost.Python error in job \"windowsbootentry\"." 
2023-07-09 - 11:23:15 [6]:     .. - details: <div><strong>&lt;class 'OSError'&gt;</strong></div><div>[Errno 30] Read-only file system: '/tmp/calamares-root-98t3le2h/efi/EFI/Microsoft'</div><div><br/>Traceback:</div><div><pre>File &quot;/usr/lib/calamares/modules/windowsbootentry/;, line 197, in run

I’m getting this has something with the installer not able to install the bootloader correctly into the EFI location, but I am not sure how to fix it. Any help?

Did you turn of Secure Boot?

I would suggest to shrink your disk from within Windows first.
Afterwards launch the EnOS’ installer and point it to that “liberated” space.

First step. Be sure to back up any important data that may be on the disk.


Yeah, I wouldn’t be able to boot into the OS if I hadn’t done that.

Already done! I have 20gb available.
The error seems to be that the efi seems to be write-protected?

Oh yeah, everything important is backed up.

Have you disabled Fast Startup and hibernation in Windows?

Also, are you choosing grub or systemd-boot?

If you feel conformable with partitioning the disk, you could create a new ESP and choose manual installation.

Depending on the choice of bootloader the size and the mountpoint for ESP will vary under EnOS.

fast startup and hibernate are off.

I tried using systemd-boot. I’m going to see if I can manually mount the /boot/efi and see if that’ll help. I found it in another thread.

For systemd-boot you would need an ESP FAT32 and 1000 MB in size. The mountpoint will be /efi.

The rather big size for ESP is because it will house your kernel images.

1 Like

Ah. Maybe that’s the issue? I’ll try Grub and see what happens.

Fixed! Changing to Grub worked.

When all else fails…grub to the rescue! :rofl:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.