Installation does not boot "hub doesn't have any ports!"

Hey guys,
I built a new PC after about 8 years and wanted to install EndearvourOS on the new system.
The Hardware is completely new and top notch with an AMD 7950X so shouldn’t be any problem there.
After trying to boot I got the message “[2.163515] hub 8-0:0.1: config failed, hub doesn’t have any ports! (err -19)”.
Trying to boot in the fallback mode did not solved the issue. I got past the port problem, though the system went into a loop.
Linux Mint and Debian got the same message, though just continued to boot successfully.

Thanks for the help in advance!

How did you create the live ISO on usb?

I installed it as the instructions said, with rufus and the DD-Abbild-modus setting. I also tried a different USB-stick and run through all the USB-ports I could find on my system.

Are you able to create the live usb using another method? I would suggest etcher on Windows or use another method on Linux such as popsicle or even etcher on linux is available. You’ve already tried the current live usb on other ports so this is my suggestion to try. These are what methods i use and have never had an issue although many do on rufus.

Edit: Also since this is a new build did you make sure that secure boot is disabled and CSM is also turned off in UEFI?

Just rechecked everything and tried what you said, the issue is still there.
Maybe an issue in which order the modules load, because I not had any issue with Mint, Debian, ect…

Edit: Manjaro also not boots, with the same error.

What is the motherboard brand and model you are using?

The AMD 7950X is a Ryzen 9 CPU. Have we ever had a Ryzen 9 installed before ?


It’s the MSI Pro B650M A wifi
Edit: Updated to the newest Bios of course.

No, all components are completely new and have never been used before.

I was asking @ricklinux if we knew of anyone who has installed EnOS on a Ryzen 9 system before.


I was going to ask what Bios version.

We have had ryzen 9 but this is the newest platform on AMD both for processor and GPU and the motherboard chipset is also newer. So is most likely a hardware issue.

How do you have the monitor hooked up? Is it hooked directly to your graphics card?

I have an Monitor hooked up to the Mainboard directly (so the GPU of the 7950X).
Here is what I get from booting up with the fallback, what you see just loops the whole time:

So that is the only graphics you have is onboard?

Yes, I could stick in on old GTX 750ti if it helps.

You might want to boot on the distros that work and see what kernel parameters are in their grub command line and compare. I don’t have an answer to magically make it work right now.

1 Like

Haven’t though of that. I will come back if I have something interesting.
Thanks a lot

Let me tell about what happened to me just two days ago.
The AMD Ryzen 7 5700G finally came down to a price I was willing to pay. I was going to replace a AMD Ryzen 7 2700 and AMD Radeon RX 560 combination with the Ryzen 7 5700G.

I went into the BIOS and had it check for a newer BIOS. It had BIOS 1.9 and said there was nothing newer. It did not work.

I did some research and stumbled around and finally found a compatibility page for my ASRock x470 itx mother board. It said that my motherboard needed at least BIOS 4.4 for the 5700G to work. Thank goodness it provided a link and on the ASRock web site it listed both BIOS 4.4 and BIOS 4.5 download links. I re-installed my Ryzen 7 2700 and manually flashed the BIOS to 4.5
I am now using said computer to type this.

So be absoultely sure there is not a newer BIOS for your mother board, especially if you just had the board itself check for a newer version.


No, I grabed the newest version from the Website of MSI. Pretty sure that’s not the problem, since other Linux distros worked.

1 Like