Installation didn't accept 'Automatically log-in'

Hi peepelz

I just installed the latest ISO with Mate DE on my secondary computer and despite me checking Auto log-in Endeavour always asks for my password when I boot up. Even after re-downloading and re-installing no joy. :frowning:

Something wrong with my ISO or was it an oversight by your Mate team?

Some help would be greatly appreciated.

Thank you

It’s a upstream calamares (the EndeavourOS installer) issue.

To set up autologin just follow these instructions on the ArchWiki.

It’s usually enough to add your username to lightdm.conf and reboot.

sudo leafpad /etc/lightdm/lightdm.conf

change the following line:
autologin-user=*username*

That didn’t work. :frowning:

For all the rest I’m too much of a spazz, or too blind to even find all the lines they tell me to edit in the ArchWiki. See, I’m using Mate since 2013 and only today found out that I don’t have Leafpad but Pluma … and what it is and does. Guess this was the first time ever I had to use it.

autologin-user= username

Do you still have a space before “username”.

If yes, try it without a space. “autologin-user=username

edit:
Also try the following commands inside the console. exchange username with your login user.

groupadd -r autologin
gpasswd -a username autologin

Thx very much for your help 2000 & IOF

Sorry again, can’t find groupadd in lightdm.conf and closing the gap in front of my top secret username didn’t help. :frowning:

Are you using an NVIDIA graphics card by any chance? There’s a know bug with autologin in Ubuntu with it, might be related…

Is this bug with Gnome / Mate only?

On KDE + Nvidia proprietary driver it’s fine here :yum:

Just searched for it and it’s slightly different to what the OP reported so probably unrelated: https://bugs.launchpad.net/ubuntu/+source/gnome-session/+bug/1845801

1 Like

No NVIDIA on this laptop.

“Is this bug with Gnome / Mate only?”
No idea, I only tried it with Mate. On my other desktop, where I did install from an older ISO version, it all works fine. This problem is only with 2020.07.15.

cat /etc/lightdm/lightdm.conf | grep -v "#"

For reference, here’s everything not commented in my .conf.

[Seat:*]
[LightDM]
run-directory=/run/lightdm

[Seat:*]
greeter-session=lightdm-gtk-greeter
user-session=xfce
session-wrapper=/etc/lightdm/Xsession
autologin-user=twok

[XDMCPServer]

[VNCServer]

Of course you’d have to change xfce to mate, e. g. user-session=mate


Autologin after an EOS Install (XFCE only) has never worked for me. I’ve always needed to adjust lightdm.conf. Adding the username has then always worked for me. (?)

Sorry, missed your reply.

As @I0F noted you have to run the following in a terminal:

sudo groupadd -r autologin
sudo gpasswd -a USERNAME autologin

Change USERNAME to your actual username!

1 Like

Unfortunately unrelated. :confused: They said they can’t even login with the correct password. But since my good gamer is in repair I’m on a mini Lenovo desktop without Nvidia and all is fine. It’s my stupid Acer mini laptop also on Intel HD graphix, on which I installed the latest version 2020.07.15, that asks for my pword every time I switch it on. :o

Its not inside the file. You run those commands in terminal.

groupadd -r autologin
gpasswd -a username autologin

two seperate commands that you will run in bash.

Didn’t work. I guess it can’t work since my laptop doesn’t know that it’s me when I boot it. All my distros and even Endeavour, up to this ISO, have always done it perfectly. Particularly when I specified right during install that it should boot up without password.

Sorry for being such a pita but for me such stuff is important. Only hubby and me are using our computers, and we trust each other. In airports and restaurants I unpack the lappy, do my stuff on it and pack it away again. No danger of strangers ever logging in.

:question: I don’t quite understand, sorry.
It doesn’t need to. It normally just autologins the user added to lightdm.conf. Of course that user must be an actual user on the system.

1 Like

When I or my husband or just about anyone switches the computer on in the morning it boots up without a password. That’s how all my computers work. I guess I’m the only registered user but my computers think it’s always me. And that is what I want. And with 2020.07.15 it doesn’t work anymore. :frowning:

I just installed the same ISO from the same USB drive on another desktop PC of mine. Same result: It asks for my name. :frowning:

Now I’m gonna try it with another desktop, just to have used all options …

Sorry to post this again, but if done correctly this should absolutely work on a newly installed system.

So, if you’re willing to try anew, after your fresh install, do this:

  1. Login
  2. open a Terminal and run the following
sudo groupadd -r autologin
sudo gpasswd -a USERNAME autologin

Of course you’ll have to use your username, e. g. “orca” (sudo gpasswd -a orca autologin).

  1. also run the following in a terminal

sudo leafpad /etc/lightdm/lightdm.conf

and change the following entries if needed …

user-session=xfce
autologin-user=orca

You’d have to change xfce to mate, e. g. user-session=mate or to the Desktop Environment you’ve installed.

  1. Reboot

On secondary desktop again, freshly installed EndeOS/Mate = No joy
Reinstalled with Cinnamon = No joy
Did again what 2000 told me = No joy

Pheew. Fortunately I have my trusty Endeavour running on my main machine … and will wait for the next snapshot before trying to reinstall it on any of the others.

Thx guys for all your help. This forum is indeed very friendly.
xoxo