Installation crashes at the very end before /boot is filled

failure messge Network Install

I get a message /usr/bin/finish script failed or something to this effect.
I went to a second system and mounted /boot and /boot/efi. Both were empty. The crash occurred before they were filled.
The message said that the cleanup tried 480 seconds to clean-up the installed downloads.
I want to use the network installation version because I wanted gnome and print support. I do not want xfce.
Re gnome and printer_support
I tried the two together --failed
I tried gnome alone --failed
I tried printer-support alone --failed

Suggestion. Does your install script do a rm of the downloaded files, once they are installed or does it wait to the very end to rm the lot?

My endevour system config
500meg fat32 boot/efi and esp flags
1500 ext4 /boot
8 gigs swap
24 gigs /
20 gigs /home

hardware 2700x 16gigs ram 3 SSD, 3x 1 TB hard disks.
I always test install on hardware using one of the TB hard disks.
If it is OK, I will relocate the installion to one of the SSDs.

Want me to test with a patch to the APRIL endevour version. Contact me. I am sure that ChrisT and Derick tested the immediately preceeding version
OTB also tested Endevour and had no issues. He tested an earlier release

Hello @lsatenstein
I’m sorry to hear you didn’t have success. Are you creating the partitions manually during the install or prior to starting the install with gparted. It would be good if you could provide any pertinent logs as it would be helpful.

Edit: I see you have listed most of your hardware except what Graphics card it is.

Hi Joe,
thanks for responding.

I have a year 2015 old nvidia card. However, I opted to not use it. The issue is a script failure with a cleanup-script failure.
That is the message on the display.
I tried manual setup of /boot/efi, /boot, / and /home.
I tried giving the installer a region.
The problem is past that, All the software is being installed and I can see the ribbon showing me the percent accomplished.
Tell me where on the target system the system logs are located. I did my own search within the target system’s /var and other areas.

By the way, I also have Fedora, SUSE Linux, Ubuntu, Deepin, and CLear Linux on that system. I write C code for a pasttime and I am testing the compilers from each system. I could install Manjaro, but then Manjaro’s grub setup does not allow for multiboot, unless you make Manjaro the startup distro. That I do not want to do. Why do I switch. Compiled sizes of the same program can vary from 38k to 44k.
Has anyone installed to tother than virtual box or kvm with this iso?
I am open to redoing he run and taking snaps with my cellphone and also pulling out the log(s).
If the logs are still on the / or /var of the target system, give me the coordinates and I will “tail the end” to provide the exact cleanup message.

Hi @lsatenstein
This is rick here. If you do an install and it fails don’t go out of it as you can post the link for this command if it works to provide the install log. You’ll usually see it in the home folder. This is the Calamares install log.

cat ~/endeavour-install.log | curl -F ‘f:1=<-’ ix.io

Edit: I just did an install with your exact partitioning scheme although i have done it on vbox and it was fine. You didn’t mention what video card you are using?

Correction. I did a re-look I have a the /boot/grub/grub.cfg
mkdir /tmp/bootEFI
mount /dev/sdd2 /tmp/bootEFI
pwd from bottom
/tmp/bootEFI/a

Hi!
cleaner_script is indeed set to timeout after 480 seconds, is not normal that is taking more than 8 minutes to run on your system. Are you using a good usb drive?

In any case you can try:

  • open a terminal before launching calamares

type:

  • sudo su
  • sed -i ‘s/480/4800/’ /usr/share/calamares/modules/shellprocess.conf

Then launch calamares

I hope it works for you, it changes the timeout value from 8 to 80 minutes.

1 Like

I just did a test but in v-box with same parameters for partitions and it installed. So something is going on?

i have this crashes if i install from flash drive to flash drive, in my case is because the transfer is slow, then script also takes too long and reach the timeout value.

We added more code to the script later so it may need some extra time to run everything on some hardwares.

@lsatenstein you just gave me a good idea, changing cleaner_script to the last step of install, so even if it fails the user still has a bootable system to work on. I’ll start testing tomorrow.

I am in the /var/log
It is complaining that it can’t find a grub in /dev/sde.
I presume that /dev/sde is the USB. I am installing to /dev/sdd
BTW, when I try to boot the new installation, system locks up.
I propose to leave this to tomorrow as it is almost 10pm.
There is a large system core dump.
I wonder if I can boot to the new system and do a chimage or something like that
Then I could try to run grub-install
The last three messages from pacman.log
[2020-04-17T19:33:26-0400] [ALPM] running ‘30-systemd-update.hook’…
[2020-04-17T19:33:27-0400] [PACMAN] Running ‘pacman -Rsn --noconfirm xf86-video-intel’
[2020-04-17T19:33:27-0400] [PACMAN] Running ‘pacman -Rsn --noconfirm xf86-video-amdgpu’
[2020-04-17T19:33:27-0400] [PACMAN] Running ‘pacman -Rsn --noconfirm xf86-video-ati’
[2020-04-17T19:33:27-0400] [PACMAN] Running ‘pacman -Rsn --noconfirm broadcom-wl-dkms’

This part bothers me
[2020-04-17T19:24:23-0400] [ALPM-SCRIPTLET] WARNING: Failed to connect to lvmetad. Falling back to device scanning.
[2020-04-17T19:32:59-0400] [ALPM-SCRIPTLET] grub-probe: error: cannot find a GRUB drive for /dev/sde1. Check your device.map.
[2020-04-17T19:32:59-0400] [ALPM-SCRIPTLET] Found Fedora 31 (Workstation Edition) on /dev/nvme0n1p3
[2020-04-17T19:33:05-0400] [ALPM-SCRIPTLET] Found Fedora 32 (Workstation Edition) on /dev/sda4

My root partition is always formatted xfs (following RH advice).
Will do a fresh test tomorrow.
Good night.

2 Likes

Ok, you may have found more than one issue…

I’m leaving here too, good night!

Hi Leslie, welcome to the EndeavourOS forums. I hope you enjoy your time here.
This is Pudge from the Fedora Forums. Glad to see you here.

Still trying to keep busy during the Shutdown I see, at least I assume that’s what brought you here.

Pudge

1 Like

Hi Pudge,
About two years ago I had installed Manjaro alongside Fedora. It was fine, but the forum and the distro and forum were not enjoyable. I wanted to install arch or an arch based system. From youtube (DT, OTB, ChrisTyler and SwitchToLinux demoed Endeavour. These guys like an arch based system.

I want to try arch via Endeavour. Mainly because it took away some drudgery (A full install into Gnome).
As an aside, being a true senior a stone throw away from age 80, my wife and I have not left our home since early March, when we were told “to live, stay safely inside”.

I am going to start a fresh installation now.
This is my setup before I start.

Targeting a standalone mechanical hard disk at /dev/sdd

500meg fat32 for /boot/efi (flag boot, flag esp)
1.5gig ext4 for /boot
8gig swap for swap
24gig xfs for /
24gig ext4 for /home
unassigned 323gigs
backup1 250gigs Current year
backup2 300gigs last year.

I will be omitting using the nvidea option
I will reset a timeout value to 4800 (80 minutes)
sudo su
sed -i ‘s/480/4800/’ /usr/share/calamares/modules/shellprocess.conf

Re journalctl I presume it is the journal from within the installation flashdrive. The flashdrive is a 8gig one.
blkid /dev/sde* (flashdrive)

/dev/sde: UUID=“2020-04-11-19-17-24-00” LABEL=“ENDEAVOUROS” TYPE=“iso9660” PTUUID=“56226b04” PTTYPE=“dos”
/dev/sde1: UUID=“2020-04-11-19-17-24-00” LABEL=“ENDEAVOUROS” TYPE=“iso9660” PTUUID=“56226b04” PTTYPE=“dos” PARTUUID=“56226b04-01”
/dev/sde2: SEC_TYPE=“msdos” LABEL_FATBOOT=“ARCHISO_EFI” LABEL=“ARCHISO_EFI” UUID=“52AC-A508” TYPE=“vfat” PARTUUID=“56226b04-02”

1 Like

I’m antecipating some issues you’ll find, I hope I’m wrong… :shushing_face:

Failed. I looked at the logs and the clean took 10+ minutes so, 480 is insufficient.
Perhaps 960 for the future would be a safe limit
again, it failed.
I have a bit of the end of the journal and my mount attached as “Saturday”
journalctl -b | grep clean

Apr 18 09:05:35 archiso kernel: XFS (sdd6): Ending clean mount
Apr 18 09:10:14 archiso systemd[1]: systemd-tmpfiles-clean.service: Succeeded.
Apr 18 09:10:14 archiso audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 msg=‘unit=systemd-tmpfiles-clean comm=“systemd” exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success’
Apr 18 09:10:14 archiso audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 msg=‘unit=systemd-tmpfiles-clean comm=“systemd” exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success’
Apr 18 09:10:14 archiso kernel: audit: type=1130 audit(1587215414.055:97): pid=1 uid=0 auid=4294967295 ses=4294967295 msg=‘unit=systemd-tmpfiles-clean comm=“systemd” exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success’
Apr 18 09:10:14 archiso kernel: audit: type=1131 audit(1587215414.055:98): pid=1 uid=0 auid=4294967295 ses=4294967295 msg=‘unit=systemd-tmpfiles-clean comm=“systemd” exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success’
mount -l
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
sys on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
dev on /dev type devtmpfs (rw,nosuid,relatime,size=8135756k,nr_inodes=2033939,mode=755)
run on /run type tmpfs (rw,nosuid,nodev,relatime,mode=755)
efivarfs on /sys/firmware/efi/efivars type efivarfs (rw,nosuid,nodev,noexec,relatime)
/dev/sde on /run/archiso/bootmnt type iso9660 (ro,relatime,nojoliet,check=s,map=n,blocksize=2048) [ENDEAVOUROS]
cowspace on /run/archiso/cowspace type tmpfs (rw,relatime,size=10485760k,mode=755)
/dev/loop0 on /run/archiso/sfs/airootfs type squashfs (ro,relatime)
airootfs on / type overlay (rw,relatime,lowerdir=/run/archiso/sfs/airootfs,upperdir=/run/archiso/cowspace/persistent_ENDEAVOUROS/x86_64/upperdir,workdir=/run/archiso/cowspace/persistent_ENDEAVOUROS/x86_64/workdir)
securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
cgroup2 on /sys/fs/cgroup/unified type cgroup2 (rw,nosuid,nodev,noexec,relatime,nsdelegate)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,name=systemd)
pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)
none on /sys/fs/bpf type bpf (rw,nosuid,nodev,noexec,relatime,mode=700)
cgroup on /sys/fs/cgroup/net_cls,net_prio type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls,net_prio)
cgroup on /sys/fs/cgroup/rdma type cgroup (rw,nosuid,nodev,noexec,relatime,rdma)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
cgroup on /sys/fs/cgroup/pids type cgroup (rw,nosuid,nodev,noexec,relatime,pids)
cgroup on /sys/fs/cgroup/perf_event type cgroup (rw,nosuid,nodev,noexec,relatime,perf_event)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/hugetlb type cgroup (rw,nosuid,nodev,noexec,relatime,hugetlb)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=29,pgrp=1,timeout=0,minproto=5,maxproto=5,direct,pipe_ino=30261)
debugfs on /sys/kernel/debug type debugfs (rw,nosuid,nodev,noexec,relatime)
mqueue on /dev/mqueue type mqueue (rw,nosuid,nodev,noexec,relatime)
tracefs on /sys/kernel/tracing type tracefs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime,pagesize=2M)
configfs on /sys/kernel/config type configfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=1637360k,mode=700,uid=1000,gid=985)
fusectl on /sys/fs/fuse/connections type fusectl (rw,nosuid,nodev,noexec,relatime)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=985)
/dev/sdd6 on /tmp/calamares-root-dyo_wiwe type xfs (rw,relatime,attr2,inode64,logbufs=8,logbsize=32k,noquota) [sddslash]
/dev/sdd4 on /tmp/calamares-root-dyo_wiwe/boot type ext4 (rw,relatime)
/dev/sdd2 on /tmp/calamares-root-dyo_wiwe/boot/efi type vfat (rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro)
dev on /tmp/calamares-root-dyo_wiwe/dev type devtmpfs (rw,nosuid,relatime,size=8135756k,nr_inodes=2033939,mode=755)
/dev/sdd7 on /tmp/calamares-root-dyo_wiwe/home type ext4 (rw,relatime) [sddHome]
proc on /tmp/calamares-root-dyo_wiwe/proc type proc (rw,relatime)
tmpfs on /tmp/calamares-root-dyo_wiwe/run type tmpfs (rw,relatime)
run on /tmp/calamares-root-dyo_wiwe/run/udev type tmpfs (rw,nosuid,nodev,relatime,mode=755)
sys on /tmp/calamares-root-dyo_wiwe/sys type sysfs (rw,relatime)
efivarfs on /tmp/calamares-root-dyo_wiwe/sys/firmware/efi/efivars type efivarfs (rw,relatime)
~
I will put the journal output to a file~

Installation log with a rename to allow upload cat ~/endeavour-install.log | curl -F ‘f:1=<-’ ix.io

I have the entire journal as a file on my system.
My USB Creater is the FEDORA mediawriter.
I could retry with DD. I found that often DD was usually OK.
I will sha1sum the USB flashdrive next.
I think its time to prepare debugging stuff for you.

This is the sha1sum of the USB 84 lines
Host=F31Gnome.localdomain |
<-------------HASH--------------------->|<-----Date---->|<- Bytes->|<----------------------- path/filename --------------------->
0ef09a5d184fc0cf3635067ea6ce4c3d7af2103e|20200411-150642| 16170|/run/media/leslie/ENDEAVOUROS/arch/pkglist.x86_64.txt
ba19cae8aca9fdc45baa17af8a53f993d22b0c60|20200411-150616| 40960|/run/media/leslie/ENDEAVOUROS/arch/boot/amd_ucode.img
42f1af248ab8d3ea71eec9d7d4824a675f5d331b|20200411-150616| 3758|/run/media/leslie/ENDEAVOUROS/arch/boot/amd_ucode.LICENSE
491cee5aa348d1a1beac7ec07fe85652f32c37d8|20200411-150616| 3121152|/run/media/leslie/ENDEAVOUROS/arch/boot/intel_ucode.img
a1137013717add73d016680079465587952e5faf|20200411-150616| 1677|/run/media/leslie/ENDEAVOUROS/arch/boot/intel_ucode.LICENSE
636d34c0302b2cc8061281ae3a572b1c1e74f1cd|20200411-150616| 150024|/run/media/leslie/ENDEAVOUROS/arch/boot/memtest
4cc77b90af91e615a64ae04893fdffa7939db84c|20200411-150616| 18092|/run/media/leslie/ENDEAVOUROS/arch/boot/memtest.COPYING
72c7abed5812afdb31bba070ac7b7e6facc35a9b|20200411-151708|1722511360|/run/media/leslie/ENDEAVOUROS/arch/x86_64/airootfs.sfs
d4713d411d603f9d6518f8d7894448c9ce23b70f|20200411-151718| 143|/run/media/leslie/ENDEAVOUROS/arch/x86_64/airootfs.sha512
89adaf91cc2ab4743b02704fbb6342ce2ef8ee0c|20200411-150616| 195|/run/media/leslie/ENDEAVOUROS/arch/boot/syslinux/archiso.cfg
afe1f1c45950dcd0ba54e369cb84dc91e253adce|20200411-150616| 810|/run/media/leslie/ENDEAVOUROS/arch/boot/syslinux/archiso_head.cfg
9fb9430804bc246fbec7eb52187a49c6fa3ee551|20200411-150616| 1237|/run/media/leslie/ENDEAVOUROS/arch/boot/syslinux/archiso_pxe.cfg
7e81e6bb2213cfec076fb4c04d475b34b95edc6c|20200411-150616| 823|/run/media/leslie/ENDEAVOUROS/arch/boot/syslinux/archiso_sys.cfg
0043e69d32896731ef14b4e78370257dc30c9174|20200411-150616| 615|/run/media/leslie/ENDEAVOUROS/arch/boot/syslinux/archiso_tail.cfg
8339f80dfc25416ac03eba529686e4f34710dee3|20200411-150616| 1588|/run/media/leslie/ENDEAVOUROS/arch/boot/syslinux/cat.c32
f5b62568f0c3930b146249ae53147c095a886727|20200411-150616| 25080|/run/media/leslie/ENDEAVOUROS/arch/boot/syslinux/chain.c32
4f8afe5d7032117c592750799310f0bfd22370a6|20200411-150616| 1228|/run/media/leslie/ENDEAVOUROS/arch/boot/syslinux/cmd.c32
9b0b1d78919e02de602a93c7fc2d85f6c76c4681|20200411-150616| 3660|/run/media/leslie/ENDEAVOUROS/arch/boot/syslinux/cmenu.c32
5d533850c7f0865aff62ae148bdc9ed26e1dffe5|20200411-150616| 1464|/run/media/leslie/ENDEAVOUROS/arch/boot/syslinux/config.c32
84d11388a964aaf0ff4abca57af79c931b11d194|20200411-150616| 4236|/run/media/leslie/ENDEAVOUROS/arch/boot/syslinux/cptime.c32
7f237c595568c516f79f1eba479fbbcaa0d677d5|20200411-150616| 4500|/run/media/leslie/ENDEAVOUROS/arch/boot/syslinux/cpu.c32
fe50ca97502648cebdabff478142da43dca7eab6|20200411-150616| 1748|/run/media/leslie/ENDEAVOUROS/arch/boot/syslinux/cpuid.c32
addbdb4f629134c4097aec753b22e866adcc7207|20200411-150616| 2748|/run/media/leslie/ENDEAVOUROS/arch/boot/syslinux/cpuidtest.c32
2db1346a56ef3e6e129834d2343846443383570e|20200411-150616| 1572|/run/media/leslie/ENDEAVOUROS/arch/boot/syslinux/debug.c32
e0e2e531956bf73187e481ffe1559d05b6ec4fc0|20200411-150616| 4200|/run/media/leslie/ENDEAVOUROS/arch/boot/syslinux/dhcp.c32
a0c5d8f94fa6260e2ea509122ff910f48c795de9|20200411-150616| 2956|/run/media/leslie/ENDEAVOUROS/arch/boot/syslinux/dir.c32
2560450a71cbc468e4c0c84144d638157aee7738|20200411-150616| 2000|/run/media/leslie/ENDEAVOUROS/arch/boot/syslinux/disk.c32
d0f4767359b9e5cd91c536847d044ea0189f3615|20200411-150616| 8684|/run/media/leslie/ENDEAVOUROS/arch/boot/syslinux/dmi.c32
5148553ee14859f65e05129ab44d4d95d43fc0b8|20200411-150616| 12500|/run/media/leslie/ENDEAVOUROS/arch/boot/syslinux/dmitest.c32
f7d2e5dce452104fc3463850638eaa61a8664f64|20200411-150616| 3236|/run/media/leslie/ENDEAVOUROS/arch/boot/syslinux/elf.c32
92c72f7bc225c810731fd1919c15b4be6eb2c111|20200411-150616| 2724|/run/media/leslie/ENDEAVOUROS/arch/boot/syslinux/ethersel.c32
0da329500e644521095d22bccf4d2a19c2912cff|20200411-150616| 10476|/run/media/leslie/ENDEAVOUROS/arch/boot/syslinux/gfxboot.c32
b47cfd50742e44cc8b897e7fd16d06611bdd8e61|20200411-150616| 1576|/run/media/leslie/ENDEAVOUROS/arch/boot/syslinux/gpxecmd.c32
d53404072878b6752d56b0ac37679da23a7b91d0|20200411-150616| 167012|/run/media/leslie/ENDEAVOUROS/arch/boot/syslinux/hdt.c32
fcfab922824607a2d88f5744b5737e0301432122|20200411-150616| 3672|/run/media/leslie/ENDEAVOUROS/arch/boot/syslinux/hexdump.c32
a1bd775279e1ff52c752e189d9fafb867cb07dcd|20200411-150616| 1784|/run/media/leslie/ENDEAVOUROS/arch/boot/syslinux/host.c32
27c0c52b358b5b1e7202f6e418ce4dc8580ccbd0|20200411-150616| 4112|/run/media/leslie/ENDEAVOUROS/arch/boot/syslinux/ifcpu.c32
215a9060d8d49d5c8b530db985e3a80762465244|20200411-150616| 1744|/run/media/leslie/ENDEAVOUROS/arch/boot/syslinux/ifcpu64.c32
36bbe47fd97c4aa2d51e9315807c9bc253e69b22|20200411-150616| 4228|/run/media/leslie/ENDEAVOUROS/arch/boot/syslinux/ifmemdsk.c32
146ebdeac8e5d36b46b9e6d6d71634aa0ac7a059|20200411-150616| 1872|/run/media/leslie/ENDEAVOUROS/arch/boot/syslinux/ifplop.c32
a839093b1d9ab3c05d93d0c15af3a5844569203a|20200411-150616| 1648|/run/media/leslie/ENDEAVOUROS/arch/boot/syslinux/kbdmap.c32
20e76659aee4ed4cd22d3403af694ba22f8a1d2b|20200411-150616| 4856|/run/media/leslie/ENDEAVOUROS/arch/boot/syslinux/kontron_wdt.c32
3dac78bb4622f314d4861055e48f0341d722ffe9|20200411-150616| 119668|/run/media/leslie/ENDEAVOUROS/arch/boot/syslinux/ldlinux.c32
2e0e575b658e964722f42d214197aa3e94a0b338|20200411-150616| 5076|/run/media/leslie/ENDEAVOUROS/arch/boot/syslinux/lfs.c32
692fdc37e2e245ed05c163c1220cc5d16cf2040b|20200411-150616| 169824|/run/media/leslie/ENDEAVOUROS/arch/boot/syslinux/libcom32.c32
55f27645b539371c7ae49ec27b28bc45a0b474cd|20200411-150616| 67544|/run/media/leslie/ENDEAVOUROS/arch/boot/syslinux/libgpl.c32
5e383cb421b9ec351371a0d0ca205508dee60b69|20200411-150616| 102512|/run/media/leslie/ENDEAVOUROS/arch/boot/syslinux/liblua.c32
c42ccf6eb9f22981ad6917318c75fed765f928cb|20200411-150616| 23948|/run/media/leslie/ENDEAVOUROS/arch/boot/syslinux/libmenu.c32
453dd3e0c9370f554a0ab4dd05578338a1c64b27|20200411-150616| 23896|/run/media/leslie/ENDEAVOUROS/arch/boot/syslinux/libutil.c32
6b4786fb293feb10a7864c868a8e82f52db8d940|20200411-150616| 4668|/run/media/leslie/ENDEAVOUROS/arch/boot/syslinux/linux.c32
f00318a953753cda8394a31a5112c8ff67b1257e|20200411-150616| 75587|/run/media/leslie/ENDEAVOUROS/arch/boot/syslinux/lpxelinux.0
“/tmp/USB.list” [readonly] 84L, 10627C 31,1 Top

PARTIAL SUCCESS I have a way to boot from the recovery line
The first main grub menu entry did not work. The last in the list of the grub.entries did.
So I will return to research why the first entry fails.

Changing timeout from 480 to 4800 didn’t show timeout error yet still failed to install bootloader?

A look at the actual menuentry thatt works, as opposed to the one that doesn’t, may make things clearer. I’ve had menuentries that tried to boot a picture file (vmlinuz-linux.png) and entries that tried to set initrd to only the microcode file (amd-ucode.img) - that certainly didn’t lead to successful boots! If you’re not sure, a little copy/paste here might help…

Freebird54