Install on encrypted partition

Hello !

I try to install EndeavourOS on the old encrypted part.

Each time, the installation fails. Here is the message I get:

<class 'OSError'>
[Errno 30] Read-only file system: '/tmp/calamares-root-q53m6yss/efi/EFI/Microsoft'

File "/usr/lib/calamares/modules/windowsbootentry/", line 197, in run    handle_systemdboot(efi_directory)

File "/usr/lib/calamares/modules/windowsbootentry/", line 84, in handle_systemdboot copytree(source_path, target_path)

File "/usr/lib/calamares/modules/windowsbootentry/", line 36, in copytree


Please, how can I install my new system ?
Thank you

Can you explain exactly the situation so we can test it?

I try to install EndeavourOS on a partition but the installation fails.

OK, so we need a lot more details than that.

Please share the output of the command lsblk -o name,type,fstype,size.

Then explain the process you are taking. Are you installing into an existing luks encrypted partition? If so, indicate which one.

Are you using manual partitioning? If so, describe all the options you are setting in manual partitioning.

Thank you,

Through your answer, I could understand that I have to partition manually and
and therefore format the encrypted partition to recreate a new one.

By reading the procedures on the partitions, I did not understand everything and do not feel confident.
Would you please have some lines of command to suggest to me? This could make
the changes more secure. Maybe I’m wrong?

Here is the info on my pc :slight_smile:

Capture d’écran_2023-01-06_16-32-05

Thanks in advance.

You don’t have to do that actually.

I am just trying to understand what did you do to get that error.

When I try to replace the encrypted partition with another one, the installation is only possible without encryption.

When trying a manual installation, after selecting this partition nothing happens.

After recreating a new partition, I had successfully performed an encrypted installation on this same partition but I forgot the password.

I tried to do the same thing as before but it doesn’t work.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.