Install fear

So hi, yes the title is weird but it’s what I will mostly talk about here

I really, really want to install Endeavouros on my PC, as I loved it when I have seen it

The problem is, I tried to install it on a old, kinda broken laptop, and it had a error like “Couldn’t write files on new root”, I used the online install for KDE Plasma desktop

I don’t know if this is an error because of a distro I used on the laptop, or because it is of the pendrive storage (It has 2GB total), and yes, I tried to search about it but nothing really appeared that seems to be what happened to me.
Well, should I worry or not?, I don’t really know what to do on this situation and I don’t want to brick my PC because of something like that
Any answers would be grateful, I’m kinda new on this

Welcome to the forum.

Difficult to say, but that’s really tight. The ISO is 1.9 GB, and these USB pendrives often report capacity incorrectly. Get yourself a normal USB drive, any bookstore or office supplies should have them, they are dirt cheap, and I think it’s impossible to buy one that is too small.

Regarding your old “kinda broken” laptop, this could be a problem, too. Once you boot from an ISO run

inxi -Faz

and post it here. This will give us your hardware specs.


Welcome to the forum, @kontiel! Follow the frog’s advice and hopefully you can be using EndeavourOS soon!

welcome here :enos:

not 100% clear where you got the error and where you tried to install on… i bet internal drive of the notebook is bigger than 2GB …
But as @Kresimir mentioned it can be an issue for the installer ISO if pendrive is to small…

In case installer is failing/crashing you should always send the installer log… there is a logh tool on the panel left side that can send the logs over a pastebin you only need to copy/writedown the short url it gives out.

“Couldn’t write files on new root” looks like error with the installer where it fails to write to the disk chosen for the OS to be installed on. could be used manual partitioning and taken non working format/filesystem e.t.c or an issue with the drive itself (hardware failure)

Kernel: 6.4.8-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
parameters: initrd=\arch\boot\intel-ucode.img
initrd=\arch\boot\x86_64\initramfs-linux.img archisobasedir=arch
archisolabel=END cow_spacesize=10G copytoram=n
nouveau.modeset=1 i915.modeset=1 radeon.modeset=1 nvme_load=yes
Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm
v: 4.18.0 vt: 1 dm: LightDM v: 1.32.0 Distro: EndeavourOS base: Arch Linux
Type: Desktop Mobo: N/A model: N/A serial:
UEFI: American Megatrends v: 4.6.5 date: 06/29/2020
Info: model: Intel Core i5-3470 bits: 64 type: MCP arch: Ivy Bridge
gen: core 3 level: v2 built: 2012-15 process: Intel 22nm family: 6
model-id: 0x3A (58) stepping: 9 microcode: 0x21
Topology: cpus: 1x cores: 4 smt: cache: L1: 256 KiB
desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
desc: 1x6 MiB
Speed (MHz): avg: 2000 high: 3200 min/max: 1600/3200 scaling:
driver: intel_cpufreq governor: schedutil cores: 1: 3200 2: 1600 3: 1600
4: 1600 bogomips: 25549
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
Type: itlb_multihit status: KVM: VMX unsupported
Type: l1tf mitigation: PTE Inversion
Type: mds mitigation: Clear CPU buffers; SMT disabled
Type: meltdown mitigation: PTI
Type: mmio_stale_data status: Unknown: No mitigations
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: disabled, RSB filling, PBRSB-eIBRS: Not affected
Type: srbds status: Vulnerable: No microcode
Type: tsx_async_abort status: Not affected
Device-1: NVIDIA GP108 [GeForce GT 1030] driver: nouveau v: kernel
alternate: nvidia_drm,nvidia non-free: 535.xx+
status: current (as of 2023-07) arch: Pascal code: GP10x
process: TSMC 16nm built: 2016-21 pcie: gen: 1 speed: 2.5 GT/s lanes: 4
link-max: gen: 3 speed: 8 GT/s ports: active: HDMI-A-1 empty: DP-1
bus-ID: 01:00.0 chip-ID: 10de:1d01 class-ID: 0300 temp: 40.0 C
Display: server: X.Org v: 21.1.8 compositor: xfwm v: 4.18.0 driver: X:
loaded: modesetting alternate: fbdev,nouveau,nv,vesa dri: nouveau
gpu: nouveau display-ID: :0.0 screens: 1
Screen-1: 0 s-res: 1440x900 s-dpi: 96 s-size: 381x238mm (15.00x9.37")
s-diag: 449mm (17.69")
Monitor-1: HDMI-A-1 mapped: HDMI-1 model-id: LRX 0x2281 built: 2021
res: 1440x900 hz: 60 dpi: 2286 gamma: 1.2 size: 16x10mm (0.63x0.39") modes:
max: 1440x900 min: 720x400
API: OpenGL v: 4.3 Mesa 23.1.5 renderer: NV138 direct-render: Yes
Device-1: Intel 7 Series/C216 Family High Definition Audio
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20
class-ID: 0403
Device-2: NVIDIA GP108 High Definition Audio driver: snd_hda_intel
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 4 link-max: gen: 3
speed: 8 GT/s bus-ID: 01:00.1 chip-ID: 10de:0fb8 class-ID: 0403
API: ALSA v: k6.4.8-arch1-1 status: kernel-api
tools: alsactl,alsamixer,amixer
Server-1: PipeWire v: 0.3.76 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000
bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp3s0 state: down mac:
IF-ID-1: enp0s26u1u4 state: unknown speed: -1 duplex: half mac:
Device-1: Samsung Galaxy series misc. (tethering mode) driver: rndis_host
v: kernel type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0
bus-ID: 1-1.4:6 chip-ID: 04e8:6863 class-ID: 0a00 serial:
Report: This feature requires one of these tools: hciconfig/bt-adapter
Local Storage: total: 225.52 GiB used: 1.79 GiB (0.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: LITE-ON model: TGT-SLSS-240
size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: fw-rev: 1A0 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Generic model: Flash Disk
size: 1.94 GiB block-size: physical: 512 B logical: 512 B type: USB rev: 2.0
spd: 480 Mb/s lanes: 1 mode: 2.0 tech: SSD serial: fw-rev: 8.07
scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
ID-1: / raw-size: N/A size: 10 GiB used: 62.6 MiB (0.6%) fs: overlay
source: ERR-102
Alert: No swap data was found.
System Temperatures: cpu: 53.0 C mobo: N/A gpu: nouveau temp: 40.0 C
Fan Speeds (RPM): N/A
Processes: 232 Uptime: 4m wakeups: 0 Memory: total: 12 GiB
available: 11.65 GiB used: 1.45 GiB (12.4%) Init: systemd v: 254
default: multi-user tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 900 libs: 220 tools: yay Shell: Bash v: 5.1.16
running-in: xfce4-terminal inxi: 3.3.28

This is everything, and this is of my PC, if that’s alright. I can`t check my laptop right now (and it takes a lot of time just to boot up the pendrive compared to the PC, so yeah, but if you want I can check it out later)

About buying one new, I will check it out later too, I don’t know the prices here in Brazil. And I will need to check out if it’s not a flash disk, Some people said that this is an Issue, but I don’t really know.

Do you have Secure boot turned off?

I guess it is a Issue with the hardware itself, these laptops are known for being not-so-great, and I don’t remember if the Laptop has 2GB or more of storage.

About logs, I didn’t knew about it, thanks!
I will try to install it later again if it is needed and send the log, just not right now since as I said, it takes a long time to boot up the pendrive in the laptop.


you are installing on /dev/sda correct?

Yeah, I’m pretty sure, I don’t think the automatic partition manager would mess that up

what is the output of the
lsblk command?

Seeing the spec of the machine you are going to install on would be more useful.