Install, 2 HDD, 2 user - works "bad"


  1. I have mini PC, two years with EOS.
    SSD appr. 200GB with OS and HDD 1TB with /home.
    Now I have decided to install “from zero”.
    /root - was formated.
  2. Certainly, I wanted that information left in /home.
    New user - vlad, old user -vlm.
  3. Install war succsesfull.
  4. BUT there is problem.
    In katalog /home are two katalogs - vlad and vlm, good.
    vlm has my old dates, vlad has normal new Documens, Downliads , ets.
    Only it doesn’t work correctly.
    4.1 vlad:x:1000:1001:vlad:/home/vlad:/bin/bash
    Do not understand - what means way “vlad:/home/vlad”?
    4.2 [vlad@dh370 ~]$ awk -F’:’ ‘{ print $1}’ /etc/passwdPreformatted text

    In passwd two normal users: vlad, vlm
    [vlad@dh370 ~]$ su vlm
    bash: /home/vlm/.bashrc: Permission denied
    [vlm@dh370 vlad]$ - what does it mean? at first vlm…, then …vlad?
    And further
    [vlm@dh370 vlad]$ ls -l
    ls: cannot open directory ‘.’: Permission denied

I suppose, don’t understand something fundamental…
Coudn’t you something to tell?
Thanks very much.

Install, 2 HDD, 2 user - works “bad”

What exactly is it that works “bad”, or is giving you trouble with this new installation?

I can not as user “vlm” work…
And do not understand, for example, this:
[vlm@dh370 vlad]$
vlad is a user, vlm is a user…

Are both vlad and vlm registered as sudoers (i.e. system-administrators)?
Do you have accountsservice installed?


1 Like



1 Like

This is how it should be. You are trying to access the home directory of vlad using user vlm. However, vlm does not have rights to vlad’s files.

Maybe you could explain what you want to happen?


accountsservice was installed (by itself).

?? So far as i know root is system-administrator,
vlad, vlm, … dom,… are usual users. OR?
During install it was asked only name, password of new user.
Can you explain, please?

Explain what? Can you explain what you want to happen here?

You have two separate users created. They each have their own home directory. You are trying to access one user’s home directory from another user. That isn’t allowed by default.

1 Like

So new user vlad should own all the files in vlm’s old home? - Easily done, via:

sudo chown -R vlad /home/vlm/

1 Like

This is rarely the correct thing to do. @chucha, before running this command, please explain what you want.

If you run this command, vlm will no longer be able to login.

It is also the opposite of what you are trying above. Above you are trying to use vlm to access vlad’s files.

1 Like

As far as I could understand, @chucha only wants access to their old home files… created a second (old user vlm) beforehand (after re-installation)… this is what my crystal ball is telling… :smiley:

I might be wrong here. …only my guts, next to the crystal ball on my desk are telling me this, @dalto :rofl:

1 Like

created a second (old user vlm) beforehand (after re-installation)
Before Installation had only vlm and /home/vlm.
In process of installition was born user vlad.
So. What do I want.

  1. To have 2 users.
  2. Both (vlm and vlad) have own directory (/home/vlad, /home/vlm).
    Problem - i can work as vlad,
    vlad @dh370. - Ok
    but as vlm - NO. (see messages of bash) .
    If I change to vlm, I get [vlm @dh370 vlad]$.
    But one need [vlm @dh370]$
    **** @dh370

That message was because you were in vlad’s home directory.

How are you changing between users?

Sorry for my not understanding, so please forget what I told before. (Need to get new guts and crystal ball.) :blush:

but there is only one user as installer has no option to add additional users.
There is only the old home of the user existing before… but as ropot filesystem is reinstalled old user is no user in the new system at all… only if you would use useradd and options to recreate this user using the old home…

1 Like
ty[vlad@dh370 ~]$ su vlm
bash: /home/vlm/.bashrc: Permission denied
[vlm@dh370 vlad]$ ls -l
ls: cannot open directory '.': Permission denied
[vlm@dh370 vlad]$ 

This is your problem

You are switching to a new user but not switching your directory. That leaves you in a place you cannot write to.

Instead use:

su - vlm

Or if you want to act as that user more generally, you can login with that user from your display manager.


Sorry, one quetion.
EOS hat user -root with password 11
and stupid user “vlm”, password 22.
We install new system, /home/vlm is not touched,
New user by install bekame name vlm and password 22.
In this case get I “good” system?
What says crystal ball?

I have tried

[vlm@dh370 vlad]$ su - vlm
su: warning: cannot change directory to /home/vlm: Permission denied
-bash: /home/vlm/.bash_profile: Permission denied

The same…

Have you added both user-paths to it?

1 Like