Inspirion 7510 plus and debugging hints

Hello everyones! This is my personal notes for my new laptop Dell Inspirion 15" 7510+ powered by Endeavour OS. First install start from online setup with Kde Plasma, and indeed first of all after booting task is do a look on dmesg! I think to try for fixing some minor bugs warning reported by it, just for fun :smiley:

[babiz@ni-inspiron157510 ~]$ sudo dmesg -l debug -H

[mar 2 11:44] e820: update [mem 0x5b9a3000-0x5ba2bfff] usable ==> reserved
[ +0,003186] pcpu-alloc: s212992 r8192 d28672 u262144 alloc=1*2097152
[ +0,000002] pcpu-alloc: [0] 00 01 02 03 04 05 06 07 [0] 08 09 10 11 12 13 14 15
[ +1,718613] libata version 3.00 loaded.
[ +0,016585] PCI: pci_cache_line_size set to 64 bytes
[ +0,000241] e820: reserve RAM buffer [mem 0x0009f000-0x0009ffff]
[ +0,000001] e820: reserve RAM buffer [mem 0x5b9a3000-0x5bffffff]
[ +0,000001] e820: reserve RAM buffer [mem 0x6072a000-0x63ffffff]
[ +0,000001] e820: reserve RAM buffer [mem 0x65000000-0x67ffffff]
[ +0,000000] e820: reserve RAM buffer [mem 0x48f800000-0x48fffffff]
[ +0,025931] Monitor-Mwait will be used to enter C-1 state
[ +0,000006] Monitor-Mwait will be used to enter C-2 state
[ +0,000004] Monitor-Mwait will be used to enter C-3 state
[ +0,010803] ahci 0000:00:0e.0: version 3.0
[ +0,063495] with arguments:
[ +0,000002] /init
[ +0,000002] with environment:
[ +0,000001] HOME=/
[ +0,000001] TERM=linux
[ +0,025931] Monitor-Mwait will be used to enter C-1 state
[ +0,000006] Monitor-Mwait will be used to enter C-2 state
[ +0,000004] Monitor-Mwait will be used to enter C-3 state
[ +0,010803] ahci 0000:00:0e.0: version 3.0
[ +0,063495] with arguments:
[ +0,000002] /init
[ +0,000002] with environment:
[ +0,000001] HOME=/
[ +0,000001] TERM=linux
[ +0,000001] pti=on
[ +0,000002] BOOT_IMAGE=/boot/vmlinuz-linux-hardened
[ +0,000001] nvme_load=YES

[ +0,707167] ACPI BIOS Error (bug): Could not resolve symbol [\S4CT], AE_NOT_FOUND (20210730/psargs-330)
[ +0,000004] ACPI Error: Aborting method _SB.PC00.LPCB.ECDV.NGFF._CRT due to previous error (AE_NOT_FOUND) (20210730/psparse-529)
[ +0,000013] ACPI BIOS Error (bug): Could not resolve symbol [\S4HT], AE_NOT_FOUND (20210730/psargs-330)
[ +0,000002] ACPI Error: Aborting method _SB.PC00.LPCB.ECDV.NGFF._HOT due to previous error (AE_NOT_FOUND) (20210730/psparse-529)
[ +0,000014] ACPI BIOS Error (bug): Could not resolve symbol [\S4PT], AE_NOT_FOUND (20210730/psargs-330)
[ +0,000002] ACPI Error: Aborting method _SB.PC00.LPCB.ECDV.NGFF._PSV due to previous error (AE_NOT_FOUND) (20210730/psparse-529)
[ +0,000013] ACPI BIOS Error (bug): Could not resolve symbol [\S4AT], AE_NOT_FOUND (20210730/psargs-330)
[ +0,000001] ACPI Error: Aborting method _SB.PC00.LPCB.ECDV.NGFF._AC0 due to previous error (AE_NOT_FOUND) (20210730/psparse-529)
[ +0,142658] ioremap error for 0x64cc3000-0x64cc4000, requested 0x2, got 0x0
[ +0,340690] dell_smm_hwmon: unable to get SMM Dell signature
[ +0,033672] checking generic (4000000000 7f0000) vs hw (6134000000 1000000)
[ +0,000002] checking generic (4000000000 7f0000) vs hw (4000000000 10000000)
[mar 2 18:47] Bluetooth: hci0: command 0x0c52 tx timeout
[mar 2 20:35] Bluetooth: hci0: Timed out waiting for suspend events
[ +0,000009] Bluetooth: hci0: Suspend timeout bit: 6
[ +0,000024] Bluetooth: hci0: Suspend notifier action (3) failed: -110
[mar 2 20:36] ACPI Error: Thread 846200832 cannot release Mutex [ECMX] acquired by thread 2167098496 (20210730/exmutex-378)
[ +0,000005] ACPI Error: Aborting method _SB.PC00.LPCB.ECDV._Q66 due to previous error (AE_AML_NOT_OWNER) (20210730/psparse-529)
[ +0,020104] ACPI Error: Thread 557304960 cannot release Mutex [ECMX] acquired by thread 2167098496 (20210730/exmutex-378)
[ +0,000003] ACPI Error: Aborting method _SB.PC00.LPCB.ECDV._Q66 due to previous error (AE_AML_NOT_OWNER) (20210730/psparse-529)
[ +9,253621] Bluetooth: hci0: Timed out waiting for suspend events
[ +0,000011] Bluetooth: hci0: Suspend timeout bit: 6
[ +0,000031] Bluetooth: hci0: Suspend notifier action (3) failed: -110
~
…skipping…
[ +0,025931] Monitor-Mwait will be used to enter C-1 state
[ +0,000006] Monitor-Mwait will be used to enter C-2 state
[ +0,000004] Monitor-Mwait will be used to enter C-3 state
[ +0,010803] ahci 0000:00:0e.0: version 3.0
[ +0,063495] with arguments:
[ +0,000002] /init
[ +0,000002] with environment:
[ +0,000001] HOME=/
[ +0,000001] TERM=linux
[ +0,000001] pti=on
[ +0,000002] BOOT_IMAGE=/boot/vmlinuz-linux-hardened
[ +0,000001] nvme_load=YES

[ +0,707167] ACPI BIOS Error (bug): Could not resolve symbol [\S4CT], AE_NOT_FOUND (20210730/psargs-330)
[ +0,000004] ACPI Error: Aborting method _SB.PC00.LPCB.ECDV.NGFF._CRT due to previous error (AE_NOT_FOUND) (20210730/psparse-529)
[ +0,000013] ACPI BIOS Error (bug): Could not resolve symbol [\S4HT], AE_NOT_FOUND (20210730/psargs-330)
[ +0,000002] ACPI Error: Aborting method _SB.PC00.LPCB.ECDV.NGFF._HOT due to previous error (AE_NOT_FOUND) (20210730/psparse-529)
[ +0,000014] ACPI BIOS Error (bug): Could not resolve symbol [\S4PT], AE_NOT_FOUND (20210730/psargs-330)
[ +0,000002] ACPI Error: Aborting method _SB.PC00.LPCB.ECDV.NGFF._PSV due to previous error (AE_NOT_FOUND) (20210730/psparse-529)
[ +0,000013] ACPI BIOS Error (bug): Could not resolve symbol [\S4AT], AE_NOT_FOUND (20210730/psargs-330)
[ +0,000001] ACPI Error: Aborting method _SB.PC00.LPCB.ECDV.NGFF._AC0 due to previous error (AE_NOT_FOUND) (20210730/psparse-529)
[ +0,142658] ioremap error for 0x64cc3000-0x64cc4000, requested 0x2, got 0x0
[ +0,340690] dell_smm_hwmon: unable to get SMM Dell signature
[ +0,033672] checking generic (4000000000 7f0000) vs hw (6134000000 1000000)
[ +0,000002] checking generic (4000000000 7f0000) vs hw (4000000000 10000000)
[mar 2 18:47] Bluetooth: hci0: command 0x0c52 tx timeout
[mar 2 20:35] Bluetooth: hci0: Timed out waiting for suspend events
[ +0,000009] Bluetooth: hci0: Suspend timeout bit: 6
[ +0,000024] Bluetooth: hci0: Suspend notifier action (3) failed: -110
[mar 2 20:36] ACPI Error: Thread 846200832 cannot release Mutex [ECMX] acquired by thread 2167098496 (20210730/exmutex-378)
[ +0,000005] ACPI Error: Aborting method _SB.PC00.LPCB.ECDV._Q66 due to previous error (AE_AML_NOT_OWNER) (20210730/psparse-529)
[ +0,020104] ACPI Error: Thread 557304960 cannot release Mutex [ECMX] acquired by thread 2167098496 (20210730/exmutex-378)
[ +0,000003] ACPI Error: Aborting method _SB.PC00.LPCB.ECDV._Q66 due to previous error (AE_AML_NOT_OWNER) (20210730/psparse-529)
[ +9,253621] Bluetooth: hci0: Timed out waiting for suspend events
[ +0,000011] Bluetooth: hci0: Suspend timeout bit: 6
[ +0,000031] Bluetooth: hci0: Suspend notifier action (3) failed: -110

WELL DONE! Look like not fully perfect loading for kernel in use at time to write.

Now I try to search more info about this;

  • ACPI BIOS Error (bug): Could not resolve symbol (many)

  • ACPI Error: Thread 846200832 cannot release Mutex [ECMX] acquired by thread

and

  • dell_smm_hwmon: unable to get SMM Dell signature

This is all for now, I go to digging out any useful info for this errors, but you’re welcome if want to share with me any kind of infos related! Thanks so much!

It looks pretty good. I see some informational error messages but i wouldn’t get too caught up in that. Some may be solvable by a Bios update or kernel parameter but others are just due to poor Bios implementation. As long as there is no specific problem I wouldn’t worry too much but sure looking at some of them may be worth it. No harm in that as understanding your own hardware is the best route.

1 Like

yeah I think similar as you write, thanks for reply!
So I just rebooted to windows only for check if bios update is available :rofl: for installing and I got it latest bios release at time to writing.

Unlucky not helps too much lol. But my goal is to find any workaround related and write here my discovers.

After BIOS update dmesg -l debug,err -H print:

[mar 2 18:32] e820: update [mem 0x00000000-0x00000fff] usable ==> reserved
[ +0,000002] e820: remove [mem 0x000a0000-0x000fffff] usable
[mar 2 18:32] e820: update [mem 0x00000000-0x00000fff] usable ==> reserved
[ +0,000002] e820: remove [mem 0x000a0000-0x000fffff] usable
[mar 2 18:32] e820: update [mem 0x00000000-0x00000fff] usable ==> reserved
[ +0,000002] e820: remove [mem 0x000a0000-0x000fffff] usable
[mar 2 18:32] e820: update [mem 0x00000000-0x00000fff] usable ==> reserved
[ +0,000002] e820: remove [mem 0x000a0000-0x000fffff] usable
[ +0,049306] e820: update [mem 0x5b9a3000-0x5ba2bfff] usable ==> reserved
[ +0,003236] pcpu-alloc: s212992 r8192 d28672 u262144 alloc=1*2097152
[ +0,000001] pcpu-alloc: [0] 00 01 02 03 04 05 06 07 [0] 08 09 10 11 12 13 14 15
[ +1,661531] pci 0000:00:07.0: DPC: RP PIO log size 0 is invalid
[ +0,068350] libata version 3.00 loaded.
[ +0,015653] PCI: pci_cache_line_size set to 64 bytes
[ +0,000262] e820: reserve RAM buffer [mem 0x0009f000-0x0009ffff]
[ +0,000001] e820: reserve RAM buffer [mem 0x5b9a3000-0x5bffffff]
[ +0,000001] e820: reserve RAM buffer [mem 0x6072a000-0x63ffffff]
[ +0,000000] e820: reserve RAM buffer [mem 0x65000000-0x67ffffff]
[ +0,000001] e820: reserve RAM buffer [mem 0x48f800000-0x48fffffff]
[ +0,029894] Monitor-Mwait will be used to enter C-1 state
[ +0,000005] Monitor-Mwait will be used to enter C-2 state
[ +0,000004] Monitor-Mwait will be used to enter C-3 state
[ +0,011222] ahci 0000:00:0e.0: version 3.0
[ +0,062194] with arguments:
[ +0,000002] /init
[ +0,000002] with environment:
[ +0,000001] HOME=/
[ +0,000001] TERM=linux
[ +0,000001] pti=on
[ +0,000001] BOOT_IMAGE=/boot/vmlinuz-linux-hardened
[ +0,000001] nvme_load=YES

[ +0,730716] ACPI BIOS Error (bug): Could not resolve symbol [\S4CT], AE_NOT_FOUND (20210730/psargs-330)
[ +0,000005] ACPI Error: Aborting method _SB.PC00.LPCB.ECDV.NGFF._CRT due to previous error (AE_NOT_FOUND) (20210730/psparse-529)
[ +0,000015] ACPI BIOS Error (bug): Could not resolve symbol [\S4HT], AE_NOT_FOUND (20210730/psargs-330)
[ +0,000002] ACPI Error: Aborting method _SB.PC00.LPCB.ECDV.NGFF._HOT due to previous error (AE_NOT_FOUND) (20210730/psparse-529)
[ +0,000014] ACPI BIOS Error (bug): Could not resolve symbol [\S4PT], AE_NOT_FOUND (20210730/psargs-330)
[ +0,000002] ACPI Error: Aborting method _SB.PC00.LPCB.ECDV.NGFF._PSV due to previous error (AE_NOT_FOUND) (20210730/psparse-529)
[ +0,000015] ACPI BIOS Error (bug): Could not resolve symbol [\S4AT], AE_NOT_FOUND (20210730/psargs-330)
[ +0,000001] ACPI Error: Aborting method _SB.PC00.LPCB.ECDV.NGFF._AC0 due to previous error (AE_NOT_FOUND) (20210730/psparse-529)
[ +0,319929] ioremap error for 0x64cc3000-0x64cc4000, requested 0x2, got 0x0
[ +0,182351] dell_smm_hwmon: unable to get SMM Dell signature
[ +0,253320] checking generic (4000000000 7f0000) vs hw (6134000000 1000000)
[ +0,000006] checking generic (4000000000 7f0000) vs hw (4000000000 10000000)
(END)

I get too many stuff to read and learning about new Tiger Lake platform by Intel it’s look pretty strong, allowing great performance on Linux. Nice stuff! I go to learn more now.
( I’m come from very old Centrino Core Duo codename Santa Rosa, this is obsolete but still running fine laptop after +12 years of work)

What does this show?

sudo dmesg | grep Dell 

[ 0.000000] efi: EFI v2.70 by Dell
[ 0.000000] DMI: Dell Inc. Inspiron 15 7510/0J0MWF, BIOS 1.3.0 11/05/2021
[ 0.007726] ACPI: XSDT 0x0000000064F72188 000124 (v01 DELL Dell Inc 00000002 01000013)
[ 0.007729] ACPI: FACP 0x0000000064FF2000 000114 (v06 DELL Dell Inc 00000002 01000013)
[ 0.007733] ACPI: DSDT 0x0000000064F8F000 05F262 (v02 DELL Dell Inc 00000002 01000013)
[ 0.007741] ACPI: HPET 0x0000000064FF1000 000038 (v01 DELL Dell Inc 00000002 01000013)
[ 0.007743] ACPI: APIC 0x0000000064FF0000 00012C (v04 DELL Dell Inc 00000002 01000013)
[ 0.007745] ACPI: MCFG 0x0000000064FEF000 00003C (v01 DELL Dell Inc 00000002 01000013)
[ 0.007747] ACPI: SSDT 0x0000000064F8E000 000B05 (v02 DELL DellRtd3 00001000 INTL 20191018)
[ 0.007749] ACPI: NHLT 0x0000000064F8C000 00189E (v00 DELL Dell Inc 00000002 01000013)
[ 0.007759] ACPI: LPIT 0x0000000064F7B000 0000CC (v01 DELL Dell Inc 00000002 01000013)
[ 0.007760] ACPI: WSMT 0x0000000064F7A000 000028 (v01 DELL Dell Inc 00000002 01000013)
[ 0.007766] ACPI: DBGP 0x0000000064F77000 000034 (v01 DELL Dell Inc 00000002 01000013)
[ 0.007768] ACPI: DBG2 0x0000000064F76000 000054 (v00 DELL Dell Inc 00000002 01000013)
[ 0.007774] ACPI: TPM2 0x0000000064F73000 00004C (v04 DELL Dell Inc 00000002 01000013)
[ 0.007778] ACPI: DMAR 0x0000000064F71000 0000A0 (v02 INTEL Dell Inc 00000002 01000013)
[ 0.007784] ACPI: SSDT 0x0000000064F66000 001083 (v02 DELL xh_Dell_ 00000000 INTL 20191018)
[ 0.007792] ACPI: PTDT 0x0000000064F65000 000D44 (v00 DELL Dell Inc 00000005 MSFT 0100000D)
[ 0.007794] ACPI: BGRT 0x0000000064F64000 000038 (v01 DELL Dell Inc 00000002 01000013)
[ 0.007796] ACPI: FPDT 0x0000000064F63000 000034 (v01 DELL Dell Inc 00000002 01000013)
[ 1.436255] ACPI: Added _OSI(Linux-Dell-Video)
[ 3.134727] dell_smm_hwmon: unable to get SMM Dell signature
[ 3.387016] input: Dell Privacy Driver as /devices/platform/PNP0C14:02/wmi_bus/wmi_bus-PNP0C14:02/6932965F-1671-4CEB-B988-D3AB0A901919/input/input9
[ 3.396917] input: Dell WMI hotkeys as /devices/platform/PNP0C14:02/wmi_bus/wmi_bus-PNP0C14:02/9DBB5994-A997-11DA-B012-B622A1EF5492/input/input11

1 Like

I was just curious if i see any other info. Does this processor have Intel on-board video? What is the hardware? Post the link to this command.

inxi -Faz | eos-sendlog
1 Like

Wow, this is powerful tool generate online log details, cool :smiley:

https://clbin.com/YDZcl

1 Like

Nice hardware! Everything looks good.

1 Like

I was just curious if any messages come up on boot regarding 8K

Edit: I don’t see anything in the dmesg so maybe not

Edit2: Looks like you had no problem installing the nvidia drivers so you must have installed with the nvidia option.

Yes driver is installed but not active, I’m under reading about Nvidia optimus switch, great post on wiki https://discovery.endeavouros.com/nvidia/optimus-switch-another-solution-for-optimus-laptops/2021/04/

nothing about 8k (resolution I guess) I know this laptop support 3 displays lvds, hdmi and thunderbolt at 4k

(missing one 4k screen / thunderbolt video adapter to really see if it’s true as Dell say lol)

You can always use a splitter with Display port but you have be careful with what product you buy. Some only work on Windows. Cables matter and so do other hardware when it comes to this stuff.

1 Like

Thank you for advice.
Maybe discovering new laptop feature and new OS like Endeavour is too much for me at same time ehehe.
Because I will take note of my little progress day by day on this thread :slight_smile: well, bye.

1 Like

Then you should change topic category to #lounge:endeavour-pub , because people who want to help you with a problem (when/if you find one) will not read your topic.
When you find a problem, create a different topic for support.
Just saying… :man_shrugging:

1 Like

After digging into ACPI stuff I found something interest by reading excellent post at wiki, acpi-kernel-parameters

and huge admin guide for kernel parameters

Discovered one cool option to force 8k driver activation even SMM is unsupported
but no output on dmesg confirm me for option enabled, damn :smiley: i8k.force

After this is still on search of better ACPI support found specific Dell option acpi_rev_override from 1 to 5 looks set different acpi errors printed by dmesg, so it’s very long to test’em all. Need to check _REV dmesg output after twice power cycle to be effective on bios firmware. Now is:
ACPI: OSL: Overriding _REV return value to 5 < acpi_rev_override=3 (looks good as acpi manual said?)

Default status is: (to update)

+Note kernel print lot of error time by time for;

  • bluetooth

  • DPC: RP PIO log size 0 is invalid

  • unable to resolve symlinks (acpi)

And debug_objects option still useless because debugfs is unavailable on current kernel.

Kernel command line at time to write:
pti=on page_alloc.shuffle=1 i8k.force debug_objects acpi_rev_override=3 loglevel=3 nowatchdog nvme_load=YES nvidia-drm.modeset=1

You could try the following kernel parameter to see whether it gets rid of the message

[ +0,340690] dell_smm_hwmon: unable to get SMM Dell signature

i8k.force [HW] Activate i8k driver even if SMM BIOS signature
does not match list of supported models.

Yes @ricklinux I already try, but no “effective” on this hardware, nothing result from query dmesg|grep 8k (or 8K), anyway now I’m :anguished: after better look over dmesg -l warn,err Acutally I think to try kernel recompilation manually, starting with .config generated at boot time (this avoid much work) and editing it looking if possible adjusting first of all this below;

  • [mar 4 16:49] pinctrl core: failed to create debugfs directory
    (try to enable debugfs mount point hardcoded)

  • [ +0,018722] hpet_acpi_add: no address or irqs in _CRS
    (try to disable CRS)

  • [ +0,000377] pci 10000:e0:06.0: Primary bus is hard wired to 0
    [ +0,000047] pcieport 10000:e0:06.0: can’t derive routing for PCI INT D
    [ +0,000002] pcieport 10000:e0:06.0: PCI INT D: no GSI
    [ +0,000307] pcieport 10000:e0:06.0: can’t derive routing for PCI INT A
    [ +0,000001] nvme 10000:e1:00.0: PCI INT A: not connected
    [ +0,092511] usb: port power management may be unreliable

(try to get PCI options consistent for hard wired bus)

Also need to find a way for remove AE stuff from acpi and check WMI options for

  • [ +0,000006] acpi PNP0C14:02: duplicate WMI GUID (first instance was on PNP0C14:00)

[ +0,016046] ACPI BIOS Error (bug): Could not resolve symbol [\S4CT], AE_NOT_FOUND

If I’m lucky enough :smiley: lol.

Well some things i wouldn’t be that concerned about as they are more informational than actually an error. A lot of Acpi error messages are because of poor implementation of the Bios. I would only worry about specific issues you have that cause hardware problems. If they can be traced and corrected by some means then that’s okay. My dmesg is pretty clean on my system.
If you look at the link to this command you can see the info it shows.

sudo dmesg | eos-sendlog

Yeah I understand, only my mind flight over and think “possible” disable acpi interactions with bios, or maybe will fix’em all from kernel parameters (probably not agree with you)…

Putting dmesg on eos-sendlog if you like do a look are welcome https://clbin.com/7dfy5

I go to learn about mysterious error codes eheh :smiley: but I want to revert LTS kernel after this post.
I see much errors for bluetooth and audio “calls” under way
(happens while normal use after boot)
So still read about kernel works, like to try manage my own kernel recompiled “magic” options if it looks relevant, hope get less warning and error… is good for me I think this way.

Edit: new LTS dmesg with some boot parameters changed https://clbin.com/riYGA

That would be understandable if you are using a hardened kernel and then lts. Did you try the zen kernel? The error codes mostly ACPI i don’t think you could get rid of them if you wanted. Even turning ACPI off or using a kernel parameter for ACPI that is Windows version. I don’t think there is a problem with these messages unless you have a specific hardware problem where something doesn’t work. Then you look at that specific hardware issue and try to narrow it down. Otherwise if computer is working fine there is no issue just because it has messages. :man_shrugging: