Initial system build, getting xrdp to work

Greetings all, Endeavour and Arch newbie but decades of *NIX experience.

I’m trying to build a (mostly) headless system out of an old laptop to act as a Plex server for my house. I have plex up and working, ssh enabled, all of that is great. I thought it would be nice to be able to connect graphically to the system as well. Since I run Win11 as my daily driver connecting via RDP made the most sense for my use case.

I’ve installed xrdp and I can connect to the service, but I get a blank screen when I login. A bit of googling shows that there is an issue when the user is already logged in that seems to match my symptoms. I am logged into the console directly as well.

Cool. So I tried to create a new user and I think I have one, but rdp still isn’t doing anything. So I figured I’d try here for any advice people can provide.

This isn’t a show stopper to my use case, but a nice to have. I’m toying with setting up a dual boot on my main into EnOS and I’d like to get a bit more sense of the look and feel before I commit, which is why this effort.

Thanks in advance and happy new year all.


x2go is a good alternative for a remote desktop.

Although, it also depends on your specific use-case - do you want a “thin-client-like” desktop (x2go), or remote desktop control (VNC)?

I haven’t used x2go so can’t comment, but I was looking for something which had a classic desktop experience, mostly to get a feel for what it is like. Most of the tasks relevant to the server I can do from the CLI, but I’d (a) like to test out the XCFE environment and (b) occasionally run things like browsers or other GUI programs.

I’ve used VNC before and can install the client on my windows machine, I was just thinking that RDP would prove easier coming from Windows. If that’s a fallacy then I’m happy to change my approach.

I’m going to look up x2go right now. :slight_smile:

EDIT UPDATE: I tried x2go and it is “working” in a sense, but laggy as all hell to the point of uselessness. I was trying it in “connect to existing desktop” mode, going to see if other modes are any better. If things stick the same then I’ll need to go with VNC/RDP. (xrdp already installed tigervnc so I suspect that will need minimal tire kicking to get to useability.)

Maybe i missunderstood something, but a headless Server with a gui? Then it isnt headless?

It’s a laptop with a dead screen that may or may not have a monitor attached, which is why the “headless”. I would still like the option to have a remote GUI if possible.

Working on configuring VNC now.

EDIT: VNC is up and working, quite snappy. I think I’ve found my solution.

Thanks for looking. :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.