In search for a stable unmoving desktop (looking for a DP adapter of sorts)

Greetings all!

I hope maybe one of you know the name of a device that can help me.

Yesterday I received the “HDMI EDID Emulator”. What it does is basically telling my PC that my TV is always on.

Took me a while to find this device since I didn’t really knew the name of the device I needed.

But it works wonderfully, I can turn my TV on or off and my desktop remains stable, plasma doesn’t crash, windows don’t move around anymore, no more flickering and all that annoying stuff.

Now I also need to find something like that device, but now for my two DisplayPort monitors. They also have that useless feature where after being off for a certain amount of time, my PC get;s the signal that the monitors aren’t there anymore which has resulted in my session crashing.

I looked into the monitors OSD, but cant find a function where I can turn off the “signal” that tells my PC that the monitor is gone.

Does anyone know the name of a device that I can buy that tells my PC the monitor is always there? Or maybe a Linux boot flag or whatever that disables monitor hot plugging.

I always want my PC to think my monitors are present. because right now, i cant leave my PC running overnight. Well, I can, but I have to enter the full screen terminal for that, since that disables kwin so my monitor being off, doesn’t affect it.

But I much prefer a permanent solution that doesn’t require any work on my end.

Thanks in advance!

Is it a laptop?
If it is, have you checked the battery settings, to see if it’s set to “Suspend session”?

Not that it helps you much but, I have more laptops connect to one or more external monitors, all on HDMI, but they don’t crash if I let them run overnigt or turn of the power on them.

Sorry, no, it’s a desktop.

Even if it’s a desktop-pc, isn’t there power settings in “System Settings” - Powermanagement?
Did you check journalctl to see if there are any errors from the time it happens?
The problem you as you describes it, isn’t something I have ever seen or heard of, Desktop-pc or Laptop, so not much more I can help you with.

Power Savings are all disabled.

It’s a thing modern monitors do. You turn it off, and the monitor after a certain time goes into a deep sleep. The videocard receives information that my two monitors are disconnected and then Plasma does it things where it tries to move all the windows to the last active monitor.

On X11 I could disable the kscreen background service and problem solved but with Wayland this doesn’t work.

So far after googling I can only find " Lindy DisplayPort 1.2 EDID Emulator" but that is 60 bucks and I need 2. Pretty expensive versus the HDMI EDID emulator I have for my TV which is only 20 bucks.

But seems like I have to buy one of those, since I can’t fix it on the software side.

Hot Plug Detection should never have been made. :stuck_out_tongue:

I have never seen this on X11

The monitor on this laptop is under 2 years old, so not that old.
When the powersettings “Screen Energy Savings” kicks in, the screen shows “No input signal”
Nothing bad happen when I move the mouse and the screen turns on again.
Same thing when I turn of power on the screen or take the powercord out of the screen.
How much more deep sleep is there. :grin:

I have not disabled Kscreen 2

With 1 fast shot at the duck, only thing that turned up was that disabling kscreen 2, was to enable the monitor to stay at sleep.

Have you confirmed that anyone else has this problem?

A suggestion could be to connect your monitors to another computer, to see if happens there.

In systemsettings - display and monitor
have you setup the screens like this:

Must be annoying to have this problem. Maybe someone else has an idea. Can’t really belife you have to buy an adapter for that…

Maybe a laptop works different. I have 2 DisplayPort monitors plus my TV. I luckily found a HDMI EDID Emulator for my TV so KDE thinks it’s always on, this fixes 95% of my issues.

But it would be nice to just turn off my monitors when I go to bed without having to enable the full screen terminal.

Even the full screen terminal sometimes breaks and I only see a black screen when I turn my monitor back on in the morning.

It is indeed sad that there isn’t a simple way on Linux to fix this or even in my monitor settings.

The adapter also only mentions 60Hz and I need 144Hz support so right now, I am out of luck. There barely exists DisplayPort EDID emulators.

They have the same EDID Emulators for DisplayPort but they only do 60Hz.

Edit: You can get a KVM switch that will do 120Hz but they aren’t cheap.

Edit: There are some KVM switches that do QHD @ 144Hz

1 Like