I'm Back After Lot of Distro hopping

Hi all,

I have been distro hopping for long time… a few months actually!
I have been here before. I hope I am still welcome!

Burning my just downloaded ISO

EndeavourOS_Artemis-22_6.iso

I hope to install EOS again.

I am looking for a really minimal installation - which is a great feature EOS offers - but I want to be sure I will have the software I need installed without issues, that is:
(all EXT4, no BTRFS)

  1. Baloo (have lots of documents, research papers… etc.)
  2. Koofr Cloud Storage (https://koofr.eu/)
    3- pCloud Cloud Storage (https://www.pcloud.com/)
    4- Zim Notes (https://zim-wiki.org/)
    5- Chromium browser.

I am intending to install Plasma KDE on EXT4.

My question, given the above requirements are there anything I should NOT unselect or anything I SHOULD select during installation?

Any specific recommendations?
Here is my

inxi -Fxxx 
System:
  Host: limo Kernel: 5.15.50-1-MANJARO arch: x86_64 bits: 64 compiler: gcc
    v: 12.1.0 Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.5 wm: kwin_x11 vt: 1
    dm: SDDM Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Laptop System: LENOVO product: 20157 v: Lenovo G580
    serial: <superuser required> Chassis: type: 10 v: Lenovo G580
    serial: <superuser required>
  Mobo: LENOVO model: Lenovo G580 serial: <superuser required> UEFI: LENOVO
    v: 62CN97WW date: 07/12/2013
Battery:
  ID-1: BAT0 charge: 25.4 Wh (99.6%) condition: 25.5/42.8 Wh (59.7%)
    volts: 12.2 min: 10.8 model: SMP LNV-L11M6Y01 type: Li-ion serial: 6365
    status: N/A
CPU:
  Info: dual core model: Intel Core i5-3210M bits: 64 type: MT MCP
    smt: enabled arch: Ivy Bridge rev: 9 cache: L1: 128 KiB L2: 512 KiB
    L3: 3 MiB
  Speed (MHz): avg: 1300 high: 1411 min/max: 1200/3100 cores: 1: 1411
    2: 1198 3: 1197 4: 1397 bogomips: 19963
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
Graphics:
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Lenovo driver: i915
    v: kernel arch: Gen7 ports: active: LVDS-1 empty: DP-1,HDMI-A-1,VGA-1
    bus-ID: 00:02.0 chip-ID: 8086:0166 class-ID: 0300
  Device-2: Acer Lenovo Integrated Webcam type: USB driver: uvcvideo
    bus-ID: 1-1.5:5 chip-ID: 5986:0294 class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
    compositor: kwin_x11 driver: X: loaded: modesetting alternate: fbdev,vesa
    gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
    s-diag: 414mm (16.31")
  Monitor-1: LVDS-1 model: Chi Mei Opto 0x15a7 res: 1366x768 hz: 60
    dpi: 101 size: 344x193mm (13.54x7.6") diag: 398mm (15.7") modes: 1366x768
  OpenGL: renderer: Mesa Intel HD Graphics 4000 (IVB GT2)
    v: 4.2 Mesa 22.1.2 direct render: Yes
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20
    class-ID: 0403
  Sound Server-1: ALSA v: k5.15.50-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.52 running: no
Network:
  Device-1: Broadcom BCM4313 802.11bgn Wireless Network Adapter driver: wl
    v: kernel pcie: speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 14e4:4727
    class-ID: 0280
  IF: wlp2s0 state: up mac: 08:ed:b9:97:27:0f
  Device-2: Qualcomm Atheros AR8162 Fast Ethernet vendor: Lenovo
    driver: alx v: kernel pcie: speed: 2.5 GT/s lanes: 1 port: 2000
    bus-ID: 03:00.0 chip-ID: 1969:1090 class-ID: 0200
  IF: enp3s0 state: down mac: f0:de:f1:fd:53:97
Bluetooth:
  Device-1: Foxconn / Hon Hai Broadcom BCM20702 Bluetooth type: USB
    driver: btusb v: 0.8 bus-ID: 1-1.4:4 chip-ID: 0489:e032 class-ID: fe01
    serial: 08EDB9972710
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends
Drives:
  Local Storage: total: 247.53 GiB used: 79.85 GiB (32.3%)
  ID-1: /dev/sda vendor: Samsung model: SSD 870 EVO 250GB size: 232.89 GiB
    speed: 6.0 Gb/s type: SSD serial: S5Y4NJ0R325556E rev: 1B6Q scheme: GPT
  ID-2: /dev/sdc type: USB model: N/A size: 14.65 GiB type: N/A
    serial: 3592041143277418 rev: 2.00 scheme: MBR
Partition:
  ID-1: / size: 227.88 GiB used: 79.32 GiB (34.8%) fs: ext4 dev: /dev/sda2
  ID-2: /boot/efi size: 299.4 MiB used: 300 KiB (0.1%) fs: vfat
    dev: /dev/sda1
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 56.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 246 Uptime: 3d 17h 2m wakeups: 19 Memory: 7.61 GiB
  used: 3.45 GiB (45.3%) Init: systemd v: 251 default: graphical Compilers:
  gcc: 12.1.0 clang: 13.0.1 Packages: pacman: 1132 Shell: Zsh v: 5.9
  default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.19

I strongly believe one should always consult with the experts (especially I want to make a one time install and stop distro hopping.)

Thank you very much for your understanding and support as usual.

For the DE, I would just roll with the default unless you want to get to extreme minimalism.

There is a section called “EndeavourOS applications selection” which you might want to review. It is a bunch of recommended applications. Up to you if you want any of those or not.

None of these are in the default install but you can install them post-installation.

Thanks a lot @dalto
I will install NOW!

P.S: I’m posting this from the live USB :+1:
Just updating you with the installation process:

  • added LTS
  • added Printing support cups

Currently installing! :+1:
OOOPS! Failed to install https://termbin.com/cpd2n

1 Like

Welcome to the purple side! @limotux

I wonder why iptables is being explicitly installed.

1 Like

Thank you @bitterhalt
I am really glad I am back again.

Yeah i remember @joekamprad have solved this before, weird…

I don’t know! I am not that expert.
But… I retried a few times… (paritioning, flags… etc…), seems to be installing now!

WOW! :smiling_face:

This is just to celebrate my first post from the installed system.
:heart_eyes:

5 Likes

it is not getting installed from pacstrap… so it must be there already ? like manual partition without formatting?

1 Like

Welcome (back)

1 Like

Thanks a lot @fbodymechanic for the welcome.
I am really enjoying EOS and this wonderful community.

Welcome back limotux!

I totally had missed before that you were not here for some months.
I am glad that you are back here now.
And congrats on a successful install!

:enos_flag: :handshake:t5:

Thanks @pebcak
Yeah I was distro hopping, almost tried everything DEBs, RPM, Slackware… Arch based,… even BSD. (to be precise some distros based on…)
I settled for a while on “another” Arch based distro for 3 months but as far as I remember from my first time here and what I found now EOS is the king!

I am really glad I am back.

1 Like

Welcome back @limotux :beers:

Thank you very much @Balder
As usual as I remember a wonderful distro and a wonderful community.

1 Like

Thank you very much @Sharp

I never enjoyed any forum like here​:+1:

The default KDE on EndeavourOS is pretty minimal I just can’t see having less. I mean what is the point of a desktop if you don’t have some software installed. It has the minimal to start. You can add minimal packages as required. Ext4 is fine and maybe you want Timeshift? It’s your computer so you can do what you want and make it your own. Less …more? Your choice. My computer works the same on KDE whether it has 900 packages or 1500 packages. It has more to do with what the stuff is that you install. Some software that is available doesn’t always work well and or causes problems. On KDE i don’t mess around with a lot of changes unless they are solid and i know that they work. If it doesn’t work i don’t use it.

1 Like

Hi @ricklinux

Sure, I can see that. I was just curious. I followed what @dalto suggested and went by defaults.

I just installed Timeshift and took a snapshot just in case! Installed all other software I needed easily.

I don’t think I will go into trouble as all what I need - as in my first post - is just that, and some other few defaults (image viewer, PDF reader… which I see are already there.)

Honestly, I messed around a lot… especially when I was here first time… (EOS was my first thing to try after being on RPM and DEB distros all the time since 2000)
I know I have caused everybody here a lot of headache by being so naughty (BTRFS + Baloo, several desktops with same user, partitioning… I was so… eager to learn) and the support I got here was so amazing and so friendly.
But now, no more messing… I promise I will try to be a good boy. :rofl:

2 Likes