IdeaPad Gaming 3i 16" (12th Gen 12700H, 3050 Ti)

Installing EOS now (online install, XFCE).
I’ll post issues I cant solve and solutions I come across here.

um i cannot get wifi to work lol.
I dont believe that EOS is spotting the wifi card at all.
iwconfig outputs

lo             no wireless extensions.
enp47s0        no wireless extensions

I tried Wifi Not Working top answer here. No avail.
What else is there to try?

Please provide the forum some info on your hardware for people to have an idea what to look for and where to start troubleshooting.

1 Like

inxi output:

$ sudo dmidecode -s system-version
IdeaPad Gaming 3 16IAH7

Not sure the other commands are useful for this case. Correct me if im wrong though!

I know, one thing at a time, but another issue out the box is xfce does not seem to notice that my screen can do more than 60Hz. Running xrandr, it too thinks I’m only on a 60Hz screen (it’s 165, i checked the serial number to be super sure too)

1 Like

Sorry, I didn’t notice you posted the hardware link.

1 Like

Looks like you need to install rtw89-dkms-git


yay -S rtw89-dkms-git

Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Lenovo driver: r8169 v: kernel port: 4000 bus-ID: 0000:2f:00.0
chip-ID: 10ec:8168
IF: enp47s0 state: up speed: 1000 Mbps duplex: full mac:
Device-2: Realtek vendor: Lenovo driver: N/A port: 3000
bus-ID: 0000:30:00.0 chip-ID: 10ec:b852

* Individual Downloads
* Version
* Released
* Size
* Severity
* Download

* Realtek WLAN Driver
* RTL8822CE-2024.0.8.134, 8852BE-6001.0.15.111
* 12 Jun 2022
* 4.71 MB
* Recommended

Does this help?

The WiFi is 802.11ax PCI-E driver for Realtek 8852AE
It needs the above package for the module.

Edit: I thought that that these Realtek chips would work from a kernel module soon but maybe not until the 5.19 kernel?

1 Like

installed this, but not sure if that is all i was meant to do. So i reboot to see if that was all it needed but I dont see an obvious wifi solution?

On a separate note, the battery is vanishing at a rate of .6 of lightspeed. One thing to try is GPU/iGPU config, so I tried optimus-prime-git after reading this arch page but it went to tty after the reboot. I remove the package (with yay - a new tool to me) and it boots into the graphical environment again. But now im still 80% sure that the 3050 ti is on all the time. I am trying my very best to make sense of all these packages but im not sure how to make it work!

im going to try a few other battery related tweaks too. Rather conversely, i also worry about the screen not showing as more than 60Hz still :stuck_out_tongue:

thanks for the help thus far!

Okay you are getting into two different issues here. The WiFi package you say you installed and it didn’t work? Did you restart the computer after?

Edit: If you have dual boot Windows make sure the fast startup feature in Windows is turned off in power management.

Edit2: If this doesn’t work then you can try uninstalling the rtw89-dkms-git with

yay -R rtw89-dkms-git

It was my understanding that this chip should now be working from a kernel module since 5.16 kernel?

Maybe see what modules it is showing.

lsmod | eos-sendlog


Please try resolving one issue at a time.

It will be difficult otherwise to know what the issue at hand is and keep track of what you have done to resolve what issue and what others that might have possibly been created as side-effects.

1 Like

The problem is it’s difficult to know exactly what chip it is. chip-ID: 10ec:b852
It doesn’t show whether it is an RTL8852AE or another. The AE should work with a kernel module as far as i know.

If you remove the AUR package since it doesn’t help right now. Maybe you could install the lts kernel and lts headers to see if it works on that kernel.

I did reboot after installing it, yes.
I have removed rtw89-dkms-git and rebooted since, too.

here ya go.

Dual-boot with Windows and “fast-boot” enabled

If you have a dual-boot machine with a recent version of Windows and start seeing problems during initialization of the WiFi device when booting Linux, the problem could be due to the “fast startup” feature on Windows.

With this feature enabled, Windows don’t really shut down the entire system, but leaves things partially running so you can start the machine faster again. Try to disable this option, on Windows 10 it should be in “Control Panel→Hardware and Sound→Power Options→System Settings”. Select “Chooose what the power buttons do” to access the System Settings from the Power Options. Then disable the “Fast Startup” option in “Shutdown Settings”. This will cause Windows to fully shutdown and may solve the issue.

I dont have windows. was going to keep it but it needed wifi connection to keep going with setup, so i nuked the ssd.
I do have fast boot enabled in the bios, but i have tried it with it off.
using rfkill i can see something named ideapad_wlan if that helps. Not blocked.
you mention to try linux lts. i’ll get onto that now. Not sure what you mean by removing the aur package. rtw89-dkms-git that one?

Yes i just wanted you to remove the AUR package rtw89-dkms-git for now and try installing the lts kernel with lts headers and boot into the lts kernel.

Edit: In case you are not aware you can use the package akm that is a kernel manager. You just have to install it first.

I think this one might be the one:

It may be? It could be the 8852BE chip. :man_shrugging:

Edit: rtw88 is a 802.11ac PCI-E driver for 8822BE, 8822CE, 8723DE and 8821CE devices.

So then you would have to try the AUR package rtw88-dkms-git as this precedes the rtw89-dkms-git for that chip.

Edit2: No harm in trying it as it either will work or not.

My thinking as well.

This is what I’m going by for WiFi. But as i said before it was my understanding that the kernel module should be automatically working for most of these newer realtek that are AX standard.

rtw88 is a 802.11ac PCI-E driver for 8822BE, 8822CE, 8723DE and 8821CE devices.
rtw89 is a 802.11ax PCI-E driver for 8852AE devices.

Edit: The chip id doesn’t tell exactly which one it is.

1 Like