I3 Trasnparency Issues please help

Im having transparency issues I’ve tried all the steps listed here to achieve transparency and it doesn’t work. I’ve uninstalled and reinstalled at least 15 times. Please any advice or point in the right direction would help

  Device-1: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display
    vendor: Hewlett-Packard driver: i915 v: kernel bus-ID: 00:02.0
    chip-ID: 8086:0f31 class-ID: 0300
  Device-2: Chicony HP Truevision HD type: USB driver: uvcvideo
    bus-ID: 1-4.3:5 chip-ID: 04f2:b40d class-ID: 0e02
  Display: x11 server: X.Org driver: loaded: intel
    unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0")
    s-diag: 414mm (16.3")
  Monitor-1: eDP1 res: 1366x768 hz: 60 dpi: 102 size: 340x190mm (13.4x7.5")
    diag: 389mm (15.3")
  OpenGL: renderer: Mesa DRI Intel HD Graphics (BYT) v: 4.2 Mesa 21.3.5
    compat-v: 3.0 direct render: Yes

Please post up your i3 config as well.

1 Like

It keeps saying new users can only post five items.

That is true - Welcome to the forum! It’s so we don’t have a new user or bot spam the forum randomly -

Please just edit your first post to include it :slight_smile:

@moderators - maybe someone if possible can up that limit for them so we can continue to help?

It’s still saying that I can only post five items…
Even in my original post…

Do you have this in your i3 config?

exec --no-startup-id picom -b
1 Like
# xcompmgr: https://wiki.archlinux.org/title/Xcompmgr
# manpage: https://man.archlinux.org/man/xcompmgr.1.en
#exec --no-startup-id xcompmgr -C -n &
# or an more specialized config like this:
#exec --no-startup-id xcompmgr -c -C -t-5 -l-5 -r4.2 -o.55 &
# or:
# picom: https://wiki.archlinux.org/title/Picom
# manpage: https://man.archlinux.org/man/picom.1.en
#exec_always --no-startup-id picom -b
#exec_always --no-startup-id killall picom && picom -b

You need to remove the # for anything you want to work in your config. That’s how you modify i3.


plus restart/refresh i3


I uncommented that and now have to reinstall the is because I can’t log in… Again.

Super + Shift + R to restart i3. Also why can’t you login?

I refresh i3 log out and then can not log back in again. Like I said in my first post I’ve tried everything.

I have never heard of uncommenting picom having any effect on login. . . . that would be a hell of a bug.

What EXACT file did you edit?

After you reinstall or whatever - Please post the entire path to file and the ENTIRE contents of your config with the </> option so we can see what you see. You’re definitely not in the correct place if uncommenting picom renders you unable to login.

I only uncommented what you said in your post that’s it. I think it may be an Intel driver problem.

You should also be able to revert to a TTY - and just hash out the line in the config again - it’s much easier than reinstalling. :slight_smile:

1 Like

file you change in .config this my ( /home/shjimbspwm/.config/ ) ( i keep it simple for you )

your be /home (your usr name ) .config

plus tty like @fbodymechanic say . then put changes back .

EDIt if confuse i3 files in ~/.config ( that why i post " /home (your usr name ).config/ )

EDit … best before make change in any file , make back up of z file ( if all go wrong it will save you )

try again or send me in the PM …i can repost it here…

are you using picom.conf from eos ?

have you tried from tty

mv ~/.config/picom.conf ~/.config/picom.conf.bak

and reboot

maybe like @fbodymechanic said

1 Like

This is the only wm & de in eos that gives me this problem

And I’m wearing black socks. . . .

I’m not really sure how that’s relevant to this thread either though.

Please provide /path/to/file that you edited exactly and the contents of your i3 config. Otherwise this will be my last attempt at help.