I was so sick of Windows

Maybe give it your other thread on solving the issue a bit more time?

Meanwhile you could try to roll back the latest update.

1 Like

Obviously that is not the aim of eos. :rofl:

If stable in your books means less updates, choose Debian. But that won’t solve your problem because this stuff is mostly hardware related and proprietary driver related. Then you could try a Ubuntu derivative that installs these proprietary drivers for you.

EOS requires you to solve the problem but in the long run that means that you can fix and manage this machine and are not at the mercy of others. Meaning if an update breaks this driver in Ubuntu you will be lost again and in a vicious circle of being frustrated with your hardware.

I went through that with Nvidia. Now I know how to fix it and I also know better to choose a Linux compatible hardware for future purchases.

This link loops back to this thread. Am I in the matrix?

1 Like

I’m sure that is exactly secret agenda of :enos: :shushing_face:
IT"S THE AAAAALIENS, MAAAN!!! :alien: :sunglasses:

1 Like

What? Impossible!

(Just fixed it… :grimacing:)

was? I still am!

I could give you a pretty big list … but EndeavourOS is at the top! :enos_flag:

2 Likes

@stemalo
If the monitor is shutting down every ten seconds you got some install problem obviously. Bad live usb creation and or bad install or you have some hardware problem.

1 Like

Linux Mint is probably the best distro for Linux beginners (and advanced users, too, who like a low-maintenance Linux-based OS). I can wholeheartedly recommend it.

Though, if I were the OP, I would put in more effort into solving the original problem. Just changing the OS is not a learning experience.

7 Likes

@Kresimir
Thanks for your suggestion with Linux Mint. Maybe I will give it a try. For days I tried already to solve this issue on software side. But now I guess, it’s a hardware fail. But what? I could be the graphic card or even the monitor. To change this items will be enough costly. I’ve a guess that the monitor itself is causing the issue. It’s a Dell U2715H and it’s not the first time this monitor creates problems. For example, connected with the HDMI port at on-board graphic unit the monitor remains black.
Wanted to say: I already have put a lot efforts into this problem. I’ve worked already for two years with Fedora, another two year with Manjaro on laptop. Of course also there I’ve had my problems, but nothing which couldn’t be resolved. But this one seems to be something fatal.

If it is a hardware failure, then it has nothing to do with the OS of your choice, so you may as well continue using EndeavourOS. :man_shrugging:

2 Likes

First and cheapest thing to check is the monitor cable. Borrow one or order one online for later return.

I would definitely try to figure out what the root of the problem is. First things to have a look at, is screensavers (turn off), power management (tlp → turn off, uninstall). Then I would investigate some vital logs (xorg, journalctl).Which graphics card is run using which driver?
If all software/OS stuff is excluded, I would aim at hardware (test different hardware, if necessary from people I know). One piece after another. In the end it should be possible to find the culprit.
I’m quite sure, EOS is not responsible for the failure.
What comes to my mind, is a possible issue of synchronization of OS and monitor (refresh/frame rate). Changing this might help. xrandr could tell more about the setup.

I did now a parallel installation of Manjaro with KDE desktop to exclude hardware errors. Until now the monitor runs without any problems. Will test this extensively for one week and will see. For the moment many, many thanks for all who tried to help me!

Did you also use KDE on EndeavourOS?

@Trekkie00
No, on EndeavourOS I didn’t use KDE. I used there Gnome and tried also XFCE.
I’ve now another problem to solve. Because I thought, grub will automatically create dual boot, to choose
between EndeavourOS and Manjaro. The partition is now divided in two halves. At the moment I can’t access EndeavourOS to install KDE also there. Have to check how to get a dual boot. I think the way achieve this is via grub.config. But I’m a little bit afraid to make a mistake there.

So it might even be a DE specific problem. Gnome uses wayland and KDE uses X11 as a default. Hard to compare those.
You need to activate os-prober and then update grub. Should be possible to do when using Green “Arch”.

What is the output of lsblk?

1 Like

Thanks to all here and I wish you all a Happy New Year!

The solution finally was so simple: I changed from HDMI to Display Port and everything is fine! No more problems. Maybe something was wrong with the cable. And I switched back from Manjoro to Endeavouros.

Upgrading these two is difficult to a newer release. Sometimes you just end up have to do a clean install.

I prefer rolling release approach personally.

MX is my preferred choice over Mint. I’ve been following their development and tried the distro in virtual machine. Quite liked it.