I updated cinnamon edition ,and then I encountered a bug

yay

extra/alsa-lib 1.2.7-2 1.2.7.1-1 0.00 MiB
extra/alsa-plugins 1:1.2.6-3 1:1.2.7.1-1 0.00 MiB
extra/alsa-ucm-conf 1.2.7-1 1.2.7.1-1 0.01 MiB
extra/bind 9.18.3-1 9.18.4-1 0.00 MiB
community/cinnamon 5.2.7-2 5.4.0-1 0.07 MiB
community/cinnamon-desktop 5.2.1-1 5.4.0-1 0.03 MiB
community/cinnamon-menus 5.2.0-1 5.4.0-1 0.00 MiB
community/cinnamon-session 5.2.0-1 5.4.0-1 0.00 MiB
community/cinnamon-settings-daemon 5.2.0-2 5.4.0-1 -0.24 MiB
community/cinnamon-translations 5.2.2-1 5.4.0-1 0.00 MiB
community/cjs 5.2.0-1 5.4.0-1 0.20 MiB
community/muffin 5.2.1-1 5.4.0-1 -2.79 MiB
community/python-xapp 2.2.1-4 2.2.2-1 0.00 MiB
community/xapp 2.2.8-1 2.2.9-1 0.00 MiB

cinnamon-desktop-editor

Traceback (most recent call last):
File “/usr/share/cinnamon/cinnamon-desktop-editor/cinnamon-desktop-editor.py”, line 21, in
import JsonSettingsWidgets
File “/usr/share/cinnamon/cinnamon-settings/bin/JsonSettingsWidgets.py”, line 5, in
from SettingsWidgets import SoundFileChooser, DateChooser, TimeChooser, Keybinding
File “/usr/share/cinnamon/cinnamon-settings/bin/SettingsWidgets.py”, line 14, in
import util
File “/usr/share/cinnamon/cinnamon-settings/bin/util.py”, line 3, in
gi.require_version(‘GSound’, ‘1.0’)
File “/usr/lib/python3.10/site-packages/gi/**init**.py”, line 126, in require_version
raise ValueError(‘Namespace %s not available’ % namespace)
ValueError: Namespace GSound not available

cinnamon-settings

Traceback (most recent call last):
File “/usr/share/cinnamon/cinnamon-settings/cinnamon-settings.py”, line 2, in
from bin import util
File “/usr/share/cinnamon/cinnamon-settings/bin/util.py”, line 3, in
gi.require_version(‘GSound’, ‘1.0’)
File “/usr/lib/python3.10/site-packages/gi/**init**.py”, line 126, in require_version
raise ValueError(‘Namespace %s not available’ % namespace)
ValueError: Namespace GSound not available

Edited to add code tags

This can be fixed by the installing gsound:

sudo pacman -Syu gsound

3 Likes

It’s worked!!!
Thank you very much.

That’s great!

Please mark @nohbody’s post as solution for the topic to close and for other users with similar issue to find the solution more easily.

:enos_flag:

Done! :wink:

1 Like

Looks like cinnamon profile needs to be modified to integrate gsound. It can be annoying for cinnamon users not to be able to launch Control center.

Issue reported on archlinux bugtracker: https://bugs.archlinux.org/task/75110

3 Likes

I just did a fresh install last night on vmware and after updating just now i can confirm. I had to add gsound also.

1 Like

Fixed upstream. See https://github.com/archlinux/svntogit-community/commit/1a00a919a9283270bd6796e58842dad6a7187501

Just do a pacman -Syyu to get the fixed version.

2 Likes

So it won’t need to be added to packages then?

depends=(accountsservice caribou cinnamon-control-center cinnamon-menus cinnamon-screensaver
         cinnamon-session cinnamon-settings-daemon cjs gnome-backgrounds
         cinnamon-session cinnamon-settings-daemon cjs gnome-backgrounds gsound

they added sound as a dependency for cinnamon package… so yes it will solve itself :wink:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.