I love the new parallel downloads feature in Pacman 6

The new pacman is just fantastic! What a great update! I just did a minor update and the download happened before I even noticed it started.

Just add

ParallelDownloads = 5

(or whatever number of parallel downloads you want) to your /etc/pacman.conf (it you’ve applied the pacnew file after the last update to pacman, it should be commented under # Misc options).

To test it run sudo pacman -Syyu and be amazed at the lightning speed at which it updates the local package database and downloads packages!


Why the hell it’s not enabled by default is my question :upside_down_face:


Not really sure… There’s probably a good reason that eludes me for the moment.



Why 5, not 6 or 8 ?

5 is the default… Try with more or fewer to see what works best for you.

That’s really weird, coz at the moment (i’ve watched development of that feature) it should be tested as f**k already…

My guess would be they want to make sure it works properly first before they enable it for all. At least that would be a somewhat decent reason.

By the way, will pacstrap benefit from this update, too?

First world Arch problems:
When your system is fully updated but you want to see how fast the new pacman downloads updates…

Time to downgrade stuff! :rofl:


Or you can just skip updates for a month or two…CAN YOU??? :rofl:


I would think that for some use cases it would be questionable to add it by default.

It could be a big hit to short-term bandwidth. Could be an issue depending on the nature of your device.



If you said two hours, I’d reply with: “tough, but I’ll try!”… But two months? Surely, you’re joking…


Certain kinds of servers, embedded devices, containers with network sensative workloads, etc.

Arch isn’t just for desktops. :wink:


That’s why they implemented the pacnew file methodology - if you look at it (merge it/pacdiff it/meld it) you will see the change, and put it into action. BTW - anyone else notice that TotalDownload is now gone? I guess it can’t cope with parallel downloads! :grin:

I did a new install of kde yesterday and i don’t see the ParallelDownloads = 5 under #Misc options?


pacman --version

give you 6 for the version? If not, you need to update your pacman (using pacman1).

Then, check if there is any pacman.conf.pacnew there.

If not, just add it manually.

1 Yo dawg…


No it’s the right version.

[ricklinux@eos-kde ~]$ pacman -V

 .--.                  Pacman v6.0.0 - libalpm v13.0.0
/ _.-' .-.  .-.  .-.   Copyright (C) 2006-2021 Pacman Development Team
\  '-. '-'  '-'  '-'   Copyright (C) 2002-2006 Judd Vinet
                       This program may be freely redistributed under
                       the terms of the GNU General Public License.

[ricklinux@eos-kde ~]$ 

Edit: Just one pacman.conf file in /etc/


Is there no file pacman.conf.pacnew? In there you would find it. Here is the Misc section as you may want it to be:

# Misc options
# We cannot check disk space from within a chroot environment
ParallelDownloads = 5

Just add it for a REAL quick dload experience, given your connection speeds! :grin:

EDIT: Try 5 - they probably suggest it so that mirrors don’t get hammered too hard by higher numbers!

It was a new install so no. It would be in the same folder /etc/?

Just add it manually, for the third time. :smiley:

The file is /etc/pacman.conf. Add it there, doesn’t matter where exactly, but under # Misc options is fine, because you’ll find it there easily next time you have a pacnew file.