I cant upgrade my system

error: libpsl: signature from “Levente Polyak (anthraxx) levente@leventepolyak.net” is unknown trust
:: File /var/cache/pacman/pkg/libpsl-0.21.5-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (P
GP signature)).
Do you want to delete it? [Y/n] n
error: libdvbpsi: signature from “Levente Polyak (anthraxx) levente@leventepolyak.net” is unknown trust
:: File /var/cache/pacman/pkg/libdvbpsi-1:1.3.3-3-x86_64.pkg.tar.zst is corrupted (invalid or corrupted packag
e (PGP signature)).
Do you want to delete it? [Y/n] n
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.
If you answer yes, then the result is the same

sudo pacman -Sy archlinux-keyring
sudo pacman -Syu

Thanks, now it works

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.