I can't update my gpu cuz of lib32-nvidia-utils

Hi everyone,
i’m trying to update my gpu (nvidia) but i can’t because removing lib32-nvidia-utils might break lib32-vulkan-driver

error: failed to prepare transaction (could not satisfy dependencies)
:: removing lib32-nvidia-utils breaks dependency 'lib32-vulkan-driver' required by steam

i don’t know what to do, i tried updating these files then updating but it didn’t work, i even tried deleting them by force but the system is saying you can’t because the file is required by steam.

Edit:: Are you updating the the drivers, or upgrading your card? you shouldn’t need to use the below command for a simple driver upgrade, unless you are using something form the AUR.


So, This is not a recommended command, but I have used it multiple times for the same reason as you .

If you run “pacman -Rdd lib32-nvidia-utils” the package will be removed and ignore any dependency breakage. Just make sure you realize what stupid crap could come of doing this and fix it before it becomes a problem.

1 Like

Post the command your running and the whole of terminal output.

1 Like
nvidia-inst 
2024-04-03 22:07:38: Info: Running: nvidia-inst v24-1
2024-04-03 22:07:38: Info: Command line: nvidia-inst 
2024-04-03 22:07:38: Info: Selected mode: nvidia
NVIDIA card id: 1f82
Fetching driver data from nvidia.com ...
2024-04-03 22:07:43: Info: Removing packages: lib32-nvidia-utils
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
COMMANDS TO RUN:
    pacman -Rs --noconfirm --noprogressbar --nodeps lib32-nvidia-utils
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

==> NOTE: running the commands may take several minutes...

Root Password: 
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing lib32-nvidia-utils breaks dependency 'lib32-vulkan-driver' required by steam

after that command i tried this:

nvidia-inst 
2024-04-03 22:11:17: Info: Running: nvidia-inst v24-1
2024-04-03 22:11:17: Info: Command line: nvidia-inst 
2024-04-03 22:11:17: Info: Selected mode: nvidia
NVIDIA card id: 1f82
Fetching driver data from nvidia.com ...
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
COMMANDS TO RUN:
    ==> Looks like all requested packages and settings are already OK!
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

If you need that 32-bit package for steam, use option --32 with nvidia-inst.

1 Like