I cant seem to set a default resolution please help

Ram:4gb ; VMware ; 20GB Storage (6GB Used) 4 cores

I cant seem to set a default resolution.I want it to to be 1920x1080 but it always returns to 800x600
I tried with a xrandr script, that wont work i don’t know what to do.

xrandr --output Virtual1 -mode 1920x10808

The xranr script works but you have to manually execute it every time you login.The grub bootloader is also of incorrect resolution.
Please Help

Did you start/enable vmtoolsd.service?

In addition to checking what @dalto mentioned above, try adding the following line to your ~/.config/i3/config, save the file and restart i3 to see if the resolution stays as it should:

exec_always xrandr --output Virtual-1 --mode 1920x1080


this will be added per default in next release to be running.
On my testings i see that you need to use the fullscreen switcher from vmware menu twice to get it working, and it could be that for i3 you need to add the resolution to be applied like so:

using arandr tool and save the settings as monitor what will get saved as ~/.screenlayout/monitor.sh and used by eos i3 config to set display

1 Like

Sorry this did not work, it just made my display a mess!

1 Like

Thank You! This is working but my grub and login screen are still at 800x600 any fixes for it?

It should have, I believe. It’s almost the same command you have been running but made to stick through the config file. Perhaps someone could correct me it I am wrong :thinking:
Sorry anyways if it caused more trouble for you.

Yes, e.g. https://wiki.archlinux.org/title/GRUB/Tips_and_tricks#Setting_the_framebuffer_resolution.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.