I can't seem to get nvidia-inst to install proper drivers

no matter how hard I try, I can’t seem to get these drivers to install or work, I’ve looked all over the forums and can’t make much progress here’s what I’m seeing (empty commands to run list with no install) and what I’m working with. Thanks in advance for anyone helping me with this!

[yofou@yofou ~]$ nvidia-inst --drivers
NVIDIA card id: 2460
Fetching driver data from nvidia.com ...

Series 525: supported (nvidia.com: 525.60.11)

[yofou@yofou ~]$ nvidia-inst
2022-12-13 20:43:37: Info: Running: nvidia-inst v1.7-1
2022-12-13 20:43:37: Info: Command line: nvidia-inst 
2022-12-13 20:43:37: Info: Selected mode: nvidia
NVIDIA card id: 2460
Fetching driver data from nvidia.com ...
[yofou@yofou ~]$ glxinfo | grep OpenGL
OpenGL vendor string: Intel
OpenGL renderer string: Mesa Intel(R) Graphics (ADL GT2)
OpenGL core profile version string: 4.6 (Core Profile) Mesa 22.2.3
OpenGL core profile shading language version string: 4.60
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.6 (Compatibility Profile) Mesa 22.2.3
OpenGL shading language version string: 4.60
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 Mesa 22.2.3
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:
[yofou@yofou ~]$ inxi -Ga
  Device-1: Intel Alder Lake-P Integrated Graphics vendor: Razer USA
    driver: i915 v: kernel arch: Gen-12.2 process: Intel 10nm built: 2021-22+
    ports: active: eDP-1 empty: none bus-ID: 00:02.0 chip-ID: 8086:46a6
    class-ID: 0300
  Device-2: NVIDIA GA103M [GeForce RTX 3080 Ti Laptop GPU] vendor: Razer USA
    driver: N/A alternate: nouveau, nvidia_drm, nvidia non-free: 525.xx+
    status: current (as of 2022-12) arch: Ampere code: GAxxx
    process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s lanes: 8
    link-max: lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:2460 class-ID: 0300
  Device-3: IMC Networks Integrated RGB Camera type: USB driver: uvcvideo
    bus-ID: 1-2:2 chip-ID: 13d3:5279 class-ID: 0e02 serial: 01.00.00
  Display: x11 server: X.Org v: 21.1.4 driver: X: loaded: modesetting
    dri: iris gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 677x381mm (26.65x15.00")
    s-diag: 777mm (30.58")
  Monitor-1: eDP-1 model: Sharp LQ156T1JW03 built: 2020 res: 2560x1440
    hz: 240 dpi: 189 gamma: 1.2 size: 344x194mm (13.54x7.64")
    diag: 395mm (15.5") ratio: 16:9 modes: 2560x1440
  API: OpenGL v: 4.6 Mesa 22.2.3 renderer: Mesa Intel Graphics (ADL GT2)
    direct render: Yes
[yofou@yofou ~]$ 

I guess I don’t really know how that nvidia-inst works. But can’t you just use?:
sudo pacman -S nvidia-dkms nvidia-settings nvidia-utils
followed by
sudo mkinitcpio -P

1 Like

Could be that you need kernel parameter ibt=off.

But can you show some details with commands

inxi -Gza | eos-sendlog
pacman -Qs nvidia | eos-sendlog

by posting the returned URLs here?

1 Like

As @manuel stated you need to add the kernel parameter ibt=off in the default grub command line in /etc/default/grub and then update grub with sudo grub-mkconfig -o /boot/grub/grub.cfg


1 Like

Thanks @ricklinux & @manuel setting ibt=off in grub settings worked perfectly thanks loads!

1 Like

Huh, I guess because I don’t use Intel I’m not too familiar with that issue. But a did a quick look to see what it is. Apparently, for open gpu kernel modules that issue should be fixed as of 525.53

However, there’s no ETA for proprietary modules. Not too surprising that is I guess heh.

I wonder if the EOS dev team might think it’s a good idea to put in an architecture check in that install script to notify users to modify their grub with ibt=off?

Source: https://github.com/NVIDIA/open-gpu-kernel-modules/issues/256

Note that ibt=off is only a temporary workaround.
More info: https://wiki.archlinux.org/title/NVIDIA#Installation

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.