I cant find /etc/default/grub

Im trying to undervolt my gpu using corectrl but in order to enable it i need to edit /etc/default/grub, it is empty, where do i go for making the parameter?

If you do not have that file, it is likely you are using systemd-boot instead of Grub. You can still add kernel parameters with systemd-boot, but the process for setting it up is different. See the wiki post here:

How to modify kernel options

In systemd-boot, it is actually quite simple. You edit the appropriate entry file which can be found on your EFI partition in the loader/entries directory. Each entry is a boot option on the menu and each has a line called options. You can modify these entries directly, however, these changes may be overwritten when packages are installed or updated.

To make the changes, instead of modifying the entries, modify the file /etc/kernel/cmdline which is a one-line file containing a list of kernel options. Then run sudo reinstall-kernels which will populate the entries and regenerate the initrds.

I see, so what commando should I add in /etc/kernel/cmdline? Im running a rx580

What is the parameter you want to add to your kernel boot options?

For editing the file in a terminal: sudo nano /etc/kernel/cmdline

The you would add the parameter to the line of kernel boot options.

If your question is “what parameter do I need to add to my kernel boot options”, then please edit the title of the topic and specify exactly what problem you are trying to solve.

Read this ;

What was the change you were originally planning to make to /etc/default/grub?

This only work for Grub

Planning to add amdgpu.ppfeaturemask=0xffffffff but it doesnt work in /etc/kernel/cmdline. if i put it there my system wont boot.

Grub or systemd-boot, the kernel parameters are the same, I was answering to “what parameter do I need to add to my kernel boot options”.

Arch wiki is your friend :