I can only boot with kernel 5.10 LTS

I just installed Endeavouros on a new PC and I have a problem. When doing the installation I marked the option to also install the 5.10 LTS kernel, so far so good, when I start the PC with 5.10 everything is perfect but when I start I select the option to start with 5.15 it is not possible, everything is frozen and I have to restart the PC with the power button.
What could be the problem.
Thank you very much in advance.

We will likely need some more information to help you out.

Can you share the output of this command?

inxi -Fxxxz

Also, welcome!

Hi, welcome to the forum, it would be helpful if you give us some more info on your hardware.

Just check out this post to help you ease the way to get your issue solved.




System:    Kernel: 5.10.83-1-lts x86_64 bits: 64 compiler: gcc v: 11.1.0
           Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
           Distro: EndeavourOS base: Arch Linux
Machine:   Type: Desktop Mobo: Micro-Star model: MS-AE011 v: 1.0 serial: <superuser required>
           UEFI: American Megatrends LLC. v: 8.10 date: 04/13/2021
CPU:       Info: Quad Core model: 11th Gen Intel Core i7-1165G7 bits: 64 type: MT MCP
           arch: Tiger Lake rev: 1 cache: L1: 320 KiB L2: 5 MiB L3: 12 MiB
           flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 44851
           Speed: 1465 MHz min/max: 400/4700 MHz Core speeds (MHz): 1: 1407 2: 1411 3: 1435
           4: 1402 5: 1404 6: 1410 7: 1408 8: 1401
Graphics:  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Micro-Star MSI
           driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:9a49 class-ID: 0300
           Display: x11 server: X.org compositor: kwin_x11 driver: loaded: intel
           unloaded: fbdev,modesetting,vesa resolution: <missing: xdpyinfo>
           Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:     Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Micro-Star MSI
           driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a0c8 class-ID: 0401
           Sound Server-1: ALSA v: k5.10.83-1-lts running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: yes
           Sound Server-4: PipeWire v: 0.3.40 running: no
Network:   Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel bus-ID: 00:14.3
           chip-ID: 8086:a0f0 class-ID: 0280
           IF: wlan0 state: down mac: <filter>
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
           vendor: Micro-Star MSI driver: r8169 v: kernel port: 3000 bus-ID: 03:00.0
           chip-ID: 10ec:8168 class-ID: 0200
           IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Bluetooth: Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 3-10:3
           chip-ID: 8087:0026 class-ID: e001
           Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: disabled rfk-block:
           hardware: no software: no address: see --recommends
Drives:    Local Storage: total: 476.94 GiB used: 40.58 GiB (8.5%)
           ID-1: /dev/nvme0n1 vendor: Western Digital model: PC SN530 SDBPNPZ-512G-1032
           size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 21111000
           temp: 34.9 C scheme: GPT
Partition: ID-1: / size: 451.19 GiB used: 40.58 GiB (9.0%) fs: ext4 dev: /dev/nvme0n1p2
           ID-2: /boot/efi size: 511 MiB used: 296 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1
Swap:      ID-1: swap-1 type: partition size: 16.96 GiB used: 0 KiB (0.0%) priority: -2
           dev: /dev/nvme0n1p3
Sensors:   System Temperatures: cpu: 27.8 C mobo: N/A
           Fan Speeds (RPM): N/A
Info:      Processes: 211 Uptime: 31m wakeups: 0 Memory: 15.42 GiB used: 1.68 GiB (10.9%)
           Init: systemd v: 249 Compilers: gcc: 11.1.0 Packages: pacman: 1036 Shell: Bash
           v: 5.1.12 running-in: konsole inxi: 3.3.09

Thank you

What are you seeing exactly when you boot off the 5.15 kernel? Does it fail during the boot process, do you get to the login screen, etc?


I get to the login screen but then everything freezes.

Try removing the package xf86-video-intel

If that doesn’t work, we are going to need to see the logs.

It takes me longer to get to the login screen, and sometimes I can log in but the whole desktop is left black and frozen.

I would try the following kernel parameter in the default grub command line and see if it works. You need to update grub after adding this the the command line in /etc/default/grub and saving. Then update grub with sudo grub-mkconfig -o /boot/grub/grub.cfg

1 Like

If the solutions @dalto and @ricklinux don’t work. You’re not the only one with this issue, it seems to be an upstream issue with your CPU and the latest kernel.


There might be a motherboard BIOS/Firmware update? Yours is from April.

If there is an update and you are willing to update, make sure it is exactly right BIOS/Firmware for your machine. Otherwise, in the worst case, it may brick the machine.

I can’t even find this motherboard listing on MSI site.

It could be an OEM part.

Ya…i figured as much. I suggested the kernel parameter because it has the western digital drive which has a bug in the firmware causes freezing. It takes two minutes to try it. Either that is the problem or it’s something else.

I think it would be hard to argue that.



You know what i mean. It’s just an uneducated guess. :rofl:

Edit: Well some of the thought is educated. If it’s the same issue. Hard to tell from here. :earth_americas:

1 Like

Have you tried the suggestions given?

I’ve personally had issues over the years on the latest kernel. Usually audio or Bluetooth, but anything could come and go as it is worked on. I personally stick to the LTS day to day, and it may serve you better as well.

1 Like

Not me … i don’t use lts. I stay rolling!

Says the guy who installs so often they don’t have to do pacnew updates :crazy_face:

You’re the install help man. You gotta stay current, I’ll keep living in the past.

1 Like