I broke something gpu drivers related?

Hello there, newbie here again, I was following a tutorial for stuff and after rebooting the screen settings completely lost it, I have two monitors (one 4k and another fullHD) the smaller above the big one, now my screens are duplicated instead of extended and the resolution is 1024x768; everything seems “fine” but there are certain things I can’t do like using my KDE plasma environment to the full extent (I can’t prompt the menu but I can tab between apps although the only apps I can run are through shortcuts so Firefox that inits itself on start and terminal because is the only shortcut I know of)

Here are some logs that can be of help:

➜  ~ inxi -Ga 
Graphics:
  Device-1: NVIDIA GA104 [GeForce RTX 3070 Ti] vendor: ASUSTeK driver: nvidia
    v: 555.58.02 alternate: nouveau,nvidia_drm non-free: 550.xx+ status: current
    (as of 2024-06; EOL~2026-12-xx) arch: Ampere code: GAxxx
    process: TSMC n7 (7nm) built: 2020-2023 pcie: gen: 1 speed: 2.5 GT/s
    lanes: 8 link-max: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 01:00.0
    chip-ID: 10de:2482 class-ID: 0300
  Device-2: Logitech HD Pro Webcam C920 driver: snd-usb-audio,uvcvideo
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-5.1.2:14
    chip-ID: 046d:082d class-ID: 0102 serial: F29EBF4F
  Display: wayland server: X.org v: 1.21.1.13 with: Xwayland v: 24.1.0
    compositor: kwin_wayland driver: X: loaded: N/A unloaded: modesetting
    failed: nvidia alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: 0
  Monitor-1: Unknown-1 res: 1024x768 size: N/A modes: N/A
  API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2
    drv: swrast gbm: drv: kms_swrast surfaceless: drv: nvidia wayland: drv: zink
    x11: drv: swrast inactive: device-1
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: mesa v: 24.1.3-arch1.1
    glx-v: 1.4 direct-render: yes renderer: llvmpipe (LLVM 18.1.8 256 bits)
    device-ID: ffffffff:ffffffff memory: 30.36 GiB unified: yes
    display-ID: :1.0
  API: Vulkan v: 1.3.279 layers: 8 device: 0 type: discrete-gpu name: NVIDIA
    GeForce RTX 3070 Ti driver: nvidia v: 555.58.02 device-ID: 10de:2482
    surfaces: xcb,xlib

➜  ~ xrandr -q                        
Screen 0: minimum 16 x 16, current 1024 x 768, maximum 32767 x 32767
Unknown-1 connected primary 1024x768+0+0 (normal left inverted right x axis y axis) 270mm x 203mm
   1024x768      59.92*+
   800x600       59.86  
   640x480       59.38  
   320x240       59.52  
   960x600       59.63  
   928x580       59.88  
   800x500       59.50  
   768x480       59.90  
   720x480       59.71  
   640x400       59.95  
   320x200       58.96  
   1024x576      59.90  
   864x486       59.92  
   720x400       59.55  
   640x350       59.77  

inxi -Fxxc0z | eos-sendlog
https://0x0.st/XBIU.txt

journalctl -k -b -0 | eos-sendlog
https://0x0.st/XBIG.txt

Please some help would be greatly apreciated

On EndeavourOS, please use nvidia-inst. The guide in question is for Arch Linux specifically and it is also done by a cracking group, so it recommends weird things like adding some third-party repo that you may not need and may be malicious.
If you don’t have nvidia-inst installed, I think sudo pacman -S nvidia-inst should install it. I think just running it should work.

If you want the manual approach, then:

  1. Perform a system update with yay or sudo pacman -Syu
  2. Use sudo pacman -S nvidia-dkms nvidia-utils nvidia-settings nvidia-dkms is the driver for any kernel. It will be built after installing. nvidia-utils is for different utilities. nvidia-settings is for the Nvidia control panel thingy.
  3. Navigate to /boot/loader/entries and open up the files there as a root like so sudo nano <filename>.conf
  4. Append to the options line nvidia-drm.modeset=1 and then save.
  5. Save and rebuild the kernels with sudo reinstall-kernels
  6. Reboot.
1 Like

That worked!! For reference I did:

  • sudo pacman -S nvidia-inst
  • nvidia-inst
  • reboot

Thank you, do you know what I did wrong?? or what was the cause that was doing this?

in case you want/do run wayland session on Gnome or KDE/plasma you need to have DRM Modesetting enabled in early boot process, nvidia-inst enables this in case you are only installing the packages it is missing.

Just as FWIW:

The .conf files in /boot/loader/entries will be regenerated and overwritten after the next kernel update.

For making the addition of the kernel boot option permanent, it is recommended to add it in:
/etc/kernel/cmdline and then run sudo reinstall-kernels.

2 Likes

:100:

1 Like

Thank you. I didn’t knew this. I used a guide that was for Arch Linux myself to do this, until I learnt about nvidia-inst, which I think does this for you automatically?

1 Like

Probably the fact the guide doesn’t really install the drivers for you it seems. They install everything else you might, including a repo that might have infected packages, BUT the drivers.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.