I beg you for help: I have a website in a folder and need to host it, wherever it is. how


You’ve been very kind until now so I try my luck…
I made a nice website with hugo, for now it’s a directory, waiting.
I tried all of yesterday to make a github repository and push it, sometimes it accepts the push sometimes not and it’s stupidely complicated with security I couldn’t care less about,
but then it still doesn’t work, clicking on the adresse github provides to access the site.

I don’t know if it has to be with hugo, or github, or both. gitlab seems even more complicated to me. I had made progress in regexp and css/html, but now I’m so done with that $…t

Could someone who did this already, help me step to step ? I did try tutos but to no avail.

If you provided information about what you’re doing and what doesn’t work then someone might help you, even though this is absolutely nothing whatsoever to do with EndeavourOS.

Keep in mind that this sort of question - and the way it is asked - could land you in the territory of Help Vampirism, so do be aware of that behaviour so you can avoid it:



Might also be seen (and treated by @moderators) as generic trolling, which seems to be happening more often lately.

Just my 2 cents.

@sentinel166 This be better place for ask .

" https://discourse.gohugo.io/ "




I love this thread and that I didn’t have to say the thing that gets me in trouble everytime.

I may have a bloody Mary just to be part of the festivities.


You really cracked me up :wink: and I have a terribile personality.

Unfortunately the hugo developper are absolutely flooded, not having the staff the correct all issues even annoying ones, for years. I’m not saying they don’t work, but the priorities seem skewed as in a lot of big open source projects. cathedral vs bazaar etc…
Their website is full of documentation useful when it works. And not all options are documented either…

Beside they would say “github problem”, which might or might not be wrong.


baseURL = ‘http://evanescente-ondine.github.io/final_worldview/
languageCode = ‘en-us’
title = ‘Final Worldview’

theme = “hugo-book”
BookTheme = ‘light’

(Optional) Set this to true if you use capital letters in file names

disablePathToLower = true

enableGitInfo = true
disableKinds = [‘taxonomy’, ‘taxonomyTerm’]
BookToC = true

BookLogo = ‘logo.png’

BookMenuBundle = none

BookMenuBundle = ‘/menu’

BookSection = ‘docs’
BookRepo = ‘https://github.com/evanescente-ondine/final_worldview
BookCommitPath = ‘commit’

BookEditPath = ‘edit/master/exampleSite’

BookDateFormat = ‘Jan 2, 2006’
BookSearch = true
BookComments = true
BookPortableLinks = true
BookServiceWorker = true

defaultMarkdownHandler = ‘goldmark’
backend = ‘html5’
extensions = []
failureLevel = ‘fatal’
noHeaderOrFooter = true
preserveTOC = false
safeMode = ‘unsafe’
sectionNumbers = false
trace = false
verbose = false
workingFolderCurrent = false
enableInlineShortcodes = true

  definitionList = true
  footnote = true
  linkify = true
  linkifyProtocol = 'https'
  strikethrough = true
  table = true
  taskList = true
  typographer = true
  autoHeadingID = true
  autoHeadingIDType = 'github'
    block = true
    title = true
  hardWraps = false
  unsafe = true
  xhtml = false

anchorLineNos = false
codeFences = true
guessSyntax = true
hl_Lines = ‘’
hl_inline = false
lineAnchors = ‘’
lineNoStart = 1
lineNos = false
lineNumbersInTable = true
noClasses = true
noHl = false
style = ‘monokai’
tabWidth = 4
endLevel = 5
ordered = true
startLevel = 1

hugo v0.101.0+extended linux/amd64 BuildDate=unknown

About all the info you could need !
And the repository address is: https://github.com/evanescente-ondine/FinalWorldview.git

I can’t really do more.

I create the site with “hugo”, then do
git add -A public/*
git commit -m “blabla”
git push;
it seems to work but it always send the public folder as a whole to the repository, not just its content.
And I can’t manage to reliably remove that “public” folder, not even from the github site interface.

I try :
rm -rf public/
git gc --prune=all --aggressive
git commit -m “Your Commit Message”
git push

But it doesn’t work.

Looks like you need to read up on how Git works. I can recommend the free book from here:



So it really is stupidly complicated compared to my goal, huh. Thanks, I’ll read it. It’s so omnipresent today, it’s foolish to think one can do without anyway.
But do you have an idea, or is it a standard RTFM response ? I applied what the instructions I read, shouldn’t it work ?

The issue at hand is that you’re trying to use certain tool(s) whose even the basics you’re not familiar with. One can go on to teach you from scratch, but there’s a reason why documentation/ wiki/ tutorial/ manuals exist.

Specifically speaking, I believe the “issue” here is that you’re not able to use git properly.

My thoughts based on the partial information you gave us

If you want to send contents of public folder but not the folder itself, then create your repository inside the folder.

cd public
git init
git remote add origin git@github.com:evanescente-ondine/FinalWorldview.git
git add .
git commit -m "message"
git push -u origin main

In the last command, replace main with master if your default branch is master. You can know which is it by running git branch in the same folder. Also, I’m assuming your ssh keys are set up and working.

Going on about it, you can use a GitHub Action to build your website on GitHub itself and deploy it. While its not necessary, it certainly is convenient.

Final thing : your post title can be clearer. With the current title, its unlikely that anyone would take interest in reading your post. Not to mention, it comes off as spam or troll attempt. If instead you write something like Hugo site cannot be pushed to Github, there’s greater chance of Hugo or GitHub users clicking the post and reading it.


I do have an idea, but it’s not going to be effective to give you a list of git commands to copy-paste as opposed to you learning how to use (and how to find out more about) git. This sort of response also doesn’t engender any sympathy - trying to trigger or trick people into giving you a copy-paste answer is selfish at best.

My response to “I beg you for help” is that “the best charity is to allow people to no longer rely on charity.” My alms is the reference to git, which would allow you to help yourself, but you’re only here for “the loaves and the fishes”.


ah, so I’ve got to make amend because I actually mixed up two messages that had nothing to do with each other, one with the images not showing (resolved on its own…) and the one with github. That made the question seems extra needy and extra annoying .

thank you flyingcakes, it worked. I mean, It pushed the content of “public”.
I had to redo it though, to put this:

baseURL = 'https://evanescente-ondine.github.io/finalworldview/'
publishDir = "docs"

as I read it had to be done or githubpage wouldn’t work. Then I chose branch = main on the interface with root = /docs/

But the result of the address I obtain (https://evanescente-ondine.github.io/finalworldview/) is:


I’ll try tomorrow…

While I do understand that one has to learn by oneself, in the end I am not a computer scientist nor a hacker.
I wrote about genetics, diet, politics, and I don’t want to waste my limited brain space on things that for my use case I think should be transparent, intuitive. It isn’t, and it’s the developper’s fault. When you ask “how are you ?”, do you need a ten foot long contrived sentence ? Do you need a diploma in linguistics to speak ? No, it’s a tool that makes itself silent. Not the case with github. I like to learn straightforward, sound predictable things otherwise I’m fine with a command recipe that works everytime and not having a clue what it does, as long as the result is fine.

Please be magnanimous and forgive them for having wasted their limited brain space, limited time and limited material resources to give you freely and free of charge something that “should be transparent and intuitive” to you and IT ISN’T!

Just sayin’ :crazy_face:


Except github ain’t primarily meant to host website so I can’t really blame to tool for getting over my head.

But yeah, I’m used to accuse people of making wrong design decisions when I know there were exemples to take inspiration from.
Hell, I could quote the exemple of the C programming language… why not, let’s add oil to the fire shall we. Horrendous syntax, totally insecure, costs at least millions if not tens of milliions each year in time and money spent in correcting ever present bugs because the hard limitations of the tools and language, while there was and a lot more had been since then, alternatives like Ada (others too though not much I wager), which aren’t the Downie offsprings of benevolent “geeks” but of professionals, thinking things through from top to bottom . At first for “muh money” sure but it’s been open/free since the 90s.
Actual quality, thorough thinking, care for the end user and getting things done trump muh freedom and ideology.

The fact the BSDs systems aren’t nearly as used (and about dead for a desktop use not throwing you back 10 years behind if not more) but they were technically supeior in all ways in their design, if instead of muh freedom n sheiiiit developpers had felt the duty to contribute or fork with a similar spirit, we would be better off…

ps: I’ll try other (free) web hosting platforms, that don’t require git.

I did it with netlify… incredibly simpler.

OK. Well, it seems this has been solved so it is probably best to close it before it goes any further off-track.