Hplip messed up once again?

Can’t get my HP laser printer to work once again. Same old problem. It happens over and over in time. I’ve got the latest Hplip installed. It was working just a few days ago and today. . . nada. I was attempting to save on-line documents and correspondence from purchases made on-line and can’t print them up as hard copies. below is what I get:


Any idea’s or suggestions would be welcome.

This Hplip app will recognize the printer and then allows you to type in your ‘root’ password which then allows it to function. It has worked in the pass but now doesn’t even download the software app from within the program.

It’s a usb laser printer, which I’ve turned on and off several times allows it to be recognized if it didn’t initalize properly. That’s always worked in the past, now it doesn’t even allow reinitialization.

Rich;)

Probably the plugin failed to download, printer will not function without it if you have a model that needs it.

Try the binary plugin from aur hplip-plugin (be sure it matches the same version as hplip)
If that fails it could be that the download server is down…

You can get the installer from hp itself:
https://developers.hp.com/hp-linux-imaging-and-printing/plugins

I’ll play some more with it later today. . . I’ve got it on two different computers running Cinnamon with EndeavourOS. The other computer which I’m now on works with the printer and software. I try to keep both of them up to speed together at the same time with updates etc. The only difference between computers is video. One is also using btrfs, snapper and timeshift. The one I’m on is using timeshift and rsync (ext4) backups. Maybe something is amiss with the other. If I can’t fix the issue I’ll just re-install the OS again on the other computer. Sounds like a lot of work but it can be done in a day. . . no big deal. Practice makes perfect.

I did re-install hplip on the faulty computer with the same results. Didn’t work. Maybe the server is down for Hplip. . .dunno.

Will get back to it later. . . time to rcoup, rest, and rethink. . . .

Rich;)

I’ve got a few things that need clarification in my mind. . . . My other computer with the printer problem has not been shutting down properly. . . i.e. it reaches shutdown in terminal mode and then more lines of code come up repeating with line numbers in the code saying once again its shutting down… . .Then the computer sits there stalled out. . . I can’t say if this is because of btrfs and the dozens of backups it makes to disk has corrupted things. (I’ve got a bunch of backups in hourly, daily, weekly and monthly checked in Timeshift.) It says it’s make backup successfullly. I will go in and delete all but the first and latest backups that have been saved in Timeshift. . .If you go into timeshift it has created subfolders in the main folder with these backups (hourly, day, week,month). I go into btrfs assisstant and delete all but the last 3 saved backups these are sequential and by date… and numbered as such. Am I possibly screwing things up? I need to know just what is the preferred method in saving and deleting backups in both programs I guess. I was thinking I was just streamlining the process and saving space on the drive and maybe things got corrupted from all of this. . . Dunno. . . .Probably why I’ll do a complete re-install later today just for the sake of it and maybe if I get this timeshift, btrfs-assistant backup process figured out and streamlined I may not have other issues which maybe related . . . dunno. Maybe the printer issue is still something else?

Rich:) a lot of questions. . . anyone got time?

it may sound stupid but your large amount of backups is it possible the plugin install fails of no more disk space?

I can’t help with your backup situation and i don’t know anything about btrfs

My brain is toast. . . ignore all that was posted here. . . my apologies to everyone. . . .

Rich;)