HP Victus with Endeavour OS not booting up ( display not even powering on )

Hardware specifications : Ryzen 7 5000 series , 32 gb ram , NVIDIA RTX 3050 Ti

I was updating Endeavour OS by today morning

sudo pacman -Syu

And i left my laptop for a while, then when I came back after few minutes, my screen was frozen when I tried to navigate to tty2 even that didn’t open and nothing changed.

So , i forcibly turned off my , and then I tried turn on my laptop , only the machine turned ( fans , power button clearly turned on ) but the display didn’t turn on ( it was completely blank )

Then i tried to hard reset my laptop ( i just tried ) , even that didn’t work out

In similar scenarios, the normal course of action is to boot up the machine with the live usb, chroot to the installed system and run the update again. This should generally work.

Here are the instructions to follow for how to chroot:


@pebcak The problem is that the priority for live usb is low, so each and every time I need to manually boot the live usb and now i can’t even access the bios

Something you could try is, if possible, to disconnect your disk.
Turn on your machine. This should now start on BIOS.
Change the boot priority to the USB.
Put the disk back in.
Boot up with the USB.

Hope this helps.

1 Like

I will refer the internet about disconnecting the disk

1 Like

Could i access the bios without disconnecting the disk is it possible

Of course it should be possible normally by pressing one of the Fn keys while powering up the machine.
Depending on the make and model of your machine, you would need to find out which key to use.
Consult the manual for your PC.

If that won’t let you to get into the firmware settings, I’m afraid I wouldn’t know of any other way than the one I mentioned before which does sound a bit “drastic” admittedly.

There may be other ways I am not aware of so you might perhaps wait for more input from other forum members.

to add to @pebcak also try using the delete key. Turn on system and just press the key a few times


Pressing F10 should take me to the BIOS but even it’s not doing it

No even that didn’t work

if memory serves me correct pressing F9 should bring up a boot menu. In the boot menu there used to be an entry for setup (efi/bios)

Lemme try that then

Nope still the same :sob:

In my Victus laptop, whenever i boot it goes straight into grub instead of going through bios . When i used to daily drive windows the bios screen used to appear but after dual booting EOS with windows 11 , the pc boots straight into grub and the bios appears only when i opt for windows (i.e) the Victus bios appears only after the grub bootloader that too only for windows

then go to the bios this way and change the boot order to boot from the usb as @pebcak suggested in post 2

1 Like

Okie will try

Have you tried accessing the Bios this way?

You have several ways to access the Setup Utility (BIOS).
IMPORTANT: Use extreme care when making changes in Setup Utility (BIOS). Errors can prevent the
computer from operating properly.
▲ Turn on or restart the computer and quickly press f10.
– or –
Turn on or restart the computer, quickly press esc, and then press f10 when the Start menu is displayed.

Edit: This is how it’s done on the HP.

1 Like

The Fn key could be anything between F1 and F12, those included.
I’d guess one of F2, F8, F9 or F11.
Note that you need to keep pressing that key very shortly after you power the machine on.

In Addition, Ctrl-Fn or Alt-Fn might also work. On my old Vaio years ago I had to use Ctrl-Fn (just can’t remember anymore which Fn…)

One tip for the record: search for REISUB in this forum, it helps to deal with the case where nothing seems to work and you think turning off the power switch is the only way ahead… but it isn’t!

1 Like

It did not work , where i may go wrong possibly

I tried all those things , they didn’t work ,lemme checkout REISUB