How to turn on bluetooth by default at start up?

Hi, I’m a new user and I might ask silly questions… I hope this will help future new users like me :slight_smile:

I checked the wiki about bluetooth, here, but it uses gnome Bluetooth.
I’m using blueman and it works very well auto-pairing with my bluetooth headphones in good quality (A2DP) (something I havent been able to do with manjaro/gnome !)

but everytime I restart my computer, before opening blueman, I manually start bluetooth using this command :

sudo systemctl start bluetooth

How can I set up bluetooth to start up auto by default ?

many thx

I found an answer in ArchWiki, here,

We can edit the last line of bluetooth config file using this command :

sudo nano /etc/bluetooth/main.conf

and " add the line AutoEnable=true in /etc/bluetooth/main.conf at the bottom in the [Policy] section"

like that :


Thanks for sharing this solution!

I don’t know the answer to this question, but hoping you or someone else does:

Does this solution also (or as an alternative to modifying the /etc/bluetooth/main.conf as you described) require the systemd unit to be enabled (not just started), e.g. by:

sudo systemctl enable bluetooth

Sorry if this is an elementary question—I’m still trying to learn too! :smile:

The actual command you need to use is:

sudo systemctl enable bluetooth.service

You need to use this command only once. Your computer will automatically start Bluetooth from then on. (The first time you use Bluetooth you may see a question asking if Bluetooth should always be enabled; obviously the answer is yes!)

I had the same question some time ago and this command has permanently enabled Bluetooth on all of my computers which are running EndeavourOS.

I hope that this is helpful to you.



Thank you!