How to rollback from new update while locked out on logging screen

Hey there, this is Atharva,
An hour ago I’ve updated my system due to some tkinter issues(it was showing corrupted package and I denied) so I upgraded the system, after which I was asked to reboot the system.
Now that I did, I am locked out, when I enter my password a sudden black screen appears and brings me back to lockscreen.
I’ve rebooted several times and same situation is occuring again and again.
I’ve went through few other posts here but they didnt help in underatanding.
also I have little to no knowlege of linux and others.

Hi

Which DE were you using?

Please post some logs to help understand the issue.

https://discovery.endeavouros.com/forum-log-tool-options/how-to-include-systemlogs-in-your-post/2021/03/

You should be able to access the shell by pressing Ctrl + Alt + F1 on the login page. In case you’re using a laptop, you may require pressing the Fn key too.

Hey there flyingcakes,
As per your instruction I opened this command console, it had only underslash blinking and nothing else could be typed or any response when pressed any keys.
So I tried using tty5 console and asked for journal, it did show logs, but when using
’ | eos-sendlog ’
it shows :
(yad:881): Gtk-WARNING **: 23:31:02.703: cannot open display:
Nothing sent.

and similar it shows similar result while using root but with different timestamp.

Also, I have XCFE de.

===============================
adding what I could copy using lens :

nay

May 03 May 03

23:24:08 23:24:08

Lenovo-81nt kernel: Idrn] DM_PPLIB: Validation clocks:

Lenovo-81st kernel: Idrm] DM_PPLIB: engine_max_clock: 68572 Lenovo-81st kernel: [drm] DM PPLIB: memory_max_clock: 106600

May 03

23:24:08

May 03

23:24:08

Lenovo-8int kernel: Idrm] DM PPLIB: level :8

May 03 May 03

23:24:08 23:24:08

Lenovo-81nt kernel: [drm] DM_PPLIB: values for Display clock Lenovo-Bint kernel: [drm] DM_PPLIB:

300000

400000

496560 Lenovo-8int kernel: Idrm] DM PPLIB:

626090

685720

757900

847060 Lenovo-81nt kernel: [drm] DM PPLIB:

engine_max_clock: 68572 Lenovo-Bint kernel: [dra] DM_PPLIB:

memory_max_clock: 106600 Lenovo-8int kernel: [drn] DM_PPLIB: level :8

Validation clocks: Lenovo-81nt kernel: [drm] DM_PPLIB:

May 03 23:24:08 May 03 23:24:08

Lenovo-81mt kernel: [drn] DM PPLIB:

May 03

23:24:08

Lenovo-Bint kernel: [drm] DM PPLIB:

May 03 23:24:08 May 03 23:24:08

Lenovo-81mt kernel: [drm] DM PPLIB:

Lenovo-8int kernel: [drm] DM PPLIB:

May 03

23:24:08

Lenovo-8int kernel: [dra] DM PPLIB:

May 03 23:24:08 May 03 23:24:08

May 03 23:24:08 May 03 23:24:08 Lenovo-8int kernel: [drm] DM PPLIB:

May 03 23:24:08

May 03 23:24:08

Lenovo-8int kernel: Idrn] DM_PPLIB: values for Memory clock

May 03

23:24:08

Lenovo-Bint kernel: [drm] DM_PPLIB:

May 63

23:24:08

Lenovo-Bint kernel: [drm] DM PPLIB: 667000 1066000

May 03 May 03

23:24:08 23:24:08 Lenovo-Bint kernel: [drm] DM

Lenovo-Bint kernel: [dra] DM_PPLIB: PPLIB: Validation clocks:

May

03 23:24:88

Lenovo-8int kernel: [drm] DM PPLIB: memory_max_clock: 106600

May 03 23:24:08 May 03

Lenovo-Bint kernel: Idrn) DM PPLIB: : B

engine_max_clock: 68572

level

23:24:08 Lenovo-81nt kernel: Idrn] Display Core 03.2.266 initialized on DCE 11.0

May 03

23:24:08 Lenovo-Bint kernel: snd_hda_intel 0000:00:01.1: bound 0000:00:01.0 (ops andgpu_dm_audio_component_bind_ops [andgpu])

May 03 23:24:08 Lenovo-81nt kernel: Idrm) UUD initialized successfully.

May 03

23:24:08 Lenovo-81nt kernel: Idrn] UCE initialized successfully. May 03 23:24:08 Lenovo-Bint kernel: andgpu 0000:00:01.0: andgpu: SE 1, SH per SE 1, CU per SH 3, active_cu_number 3

May 03 23:24:08 May 03

Lenovo-8int kernel: andgpu: pp_dpm_get_sclk_od was not implemented.

23:24:08 Lenovo-81nt kernel: andgpu: pp_dpm_get_nclk_od was not implemented.

May 03 23:24:08 May 03 23:24:08

Lenovo-Bint kernel: [dra) Initialized andgpu 3.57.0 20150101

for 0000:00:01.0 on minor 1

Lenovo-Bint kernel: fbcon: andypudrmfb (fbo) is primary device

Nay 03 23:24:09 May 03 23:24:09

Lenovo-8int kernel: Console: switching to colour frame buffer device 170x48 Lenovo-Bint kernel: andgpu 0000:00:01.0: [drm] fbe: andgpudrmfb frame buffer device

May 03 23:24:10

Lenovo-Bint systend-journal41283]: File /var/log/journal/36739fa268134f179626766eabff3794/user-1000. Journal corrupted or uncleanly shut down, renaming ang not resolve symbol I PR.CO02.PPCV1, AE NOT FOUND (20230628/psargs-330)

May 03 23:24:21 May 03 23:24:21

Lenovo-Bint kernel: ACPI BIOS Error (bug): Could Lenovo-Bint kernel: ACPI Error: Aborting method SB.PC10.LPCO ECO APCL due to previous error (AE NOT FOUND) (20230628/psparse-529)

May 03 23:24:21

Lenovo-Bint kernel: ACPI Error: Aborting method SB.PC10.LPCO. ECO. PCLK due to previous error (AE NOT FOUND) (20230628/psparse-529) SB.PC10.LPCO ECO. 41D due to previous error (AE NOT FOUND) (28230628/psparse-529) symbol I FR.CO02.PPCV], AE NOT_FOUND (20230628/psargs-330)

May 03 May 03

23:24:21 Lenovo-Bist kernel: ACPI Error: Aborting nethod 23:24:30 Lenovo-Bint kernel: ACPI BIOS Error (bug): Could not resolve SB.PCIO.LPCO.ECO.APCL due to previous error (AE NOT FOUND) (20230628/psparse-529)

May 03 23:24:38 Lenovo-Bint kernel: ACPI Error: Aborting method

May 03 23:24:30 Lenovo-Bint kernel: ACPI Error: Aborting method May 03 23:24:30 Lenovo-Bint kernel: ACPI Error: Aborting method SB.PC10.LPCO.ECO.PCLK due to previous error (AE NOT FOUND) (28238628/paparse-529) SB.PC02405.0593,220 due to previous error (AE NOT FOUND)

=============

also, this is error only command without sendlog.


journalctl-b-01 grep fail | eos-send log

(yad:1097): Gtk-WARNING **: 23:55:48.142: cannot open display:

Nothing sent.

[root@Lenovo-8int atharval journalctl-b-01 grep fail

May 03 23:47:18 Lenovo-81nt kernel: ACPI: OSC evaluation for CPUs failed, trying_PDC

May 03 23:47:18 Lenovo-81nt kernel: button: probe of PNPOCOD:01 failed with error -17

May 03 23:47:18 Lenovo-81mt kernel: tpm_crb: probe of MSFT0101:00 failed with error -16

May 03 23:47:25 Lenovo-81mt (udeo-worker) [338]: cfg80211: Process ‘/usr/bin/set-wireless-regdom’ failed with exit code 1. May

03 23:47:36 Lenovo-81nt sddm[500]: Attempt 1 starting the Display server on ut 2 failed

23:47:38 Lenovo-8int dbus-broker-launch[392]: Activation request for ‘org.freedesktop.home1’ failed: The systemd unit ‘dbus-org.freedesktop.home1.service’ could no

May 03 dbus_interface-fi.w1.wpa_supplicant1.Interface. PZPDevice dbus_property-P2PDeviceConfig ge

t be found.

May 03 23:47:43 Lenovo-81nt wpa_supplicant[497]: dbus: fill_dict_with_properties

tter failed May 03 23:47:57 Lenovo-81nt sddn-greeter-qt6[663]: failed to create compose table

May 03 23:48:24 Lenovo-81nt agetty[714]: failed to open credentials directory

May 03 23:48:24 Lenovo-81nt agetty[716]: failed to open credentials directory

May 03 23:48:37 Lenovo-81nt agetty[718]: failed to open credentials directory

May 03 23:48:50 Lenovo-Bint NetworkManager [447]: [1714760330.2857] device (wlane): state change: need-auth-> failed (reason ‘no-secrets’, sys-iface-state: 'manag

ed’)

May 03 23:48:50 Lenovo-8int NetworkManager [447]: [1714760330.2868] device (wland): Activation: failed for commection ‘Jiofiber’ May 03 23:48:50 Lenovo-81nt NetworkManager [447]: [1714760330.28721 device (wlane): state change: failed → disconnected (reason ‘none’, sys-iface-state: ‘managed’

)

May 03 23:51:28 Lenovo-81mt sdde-greeter-qt61852]: failed to

Welcome to the forum! :smile:

Please note that you can use option --no-yad with eos-sendlog if display cannot be opened, for example:

echo foobar | eos-sendlog --no-yad

I suggest you try changing your logging manager/display manager. Try sddm instead of lightdm which gets installed by default.

Here’s how.

$ yay sddm 
$ sudo systemctl disable lightdm 
$ sudo systemctl enable sddm
$ sudo reboot --now

hey there manuel,
after inserting the command in the format you’ve provided as

journalctl -k -b -0 | eos-sendlog --no-yad

it givers error :
t1.
==> ‘curl’ failed with code 6
==> info : 0x0 failed, trying dpaste

Continue sending (Y/n)? y
t2.
==> Info : dpaste failed, trying termbin …

Continue sending (Y/n)? y
t3.
eos-sendlog-helper: error: configured pastebin services failed!

in sudo mode
su
journalctl -k -b -0 | eos-sendlog --no-yad
/usr/bin/eos-sendlog-helper: line46: /tmp/tmp.eos-sendlog-helper.log: Permission denied
==> Info: 0x0 failed. trying dpaste…
Continue sending (Y/n)? y
<>

t2.
/usr/bin/eos-sendlog-helper: line46: /tmp/tmp.eos-sendlog-helper.log: Permission denied
==> Info : dpaste failed, trying termbin…
<>
Continue sending (Y/n)? y

t3.
/usr/bin/eos-sendlog-helper: line46: /tmp/tmp.eos-sendlog-helper.log: Permission denied
eos-sendlog-helper: error: configured pastebin services failed!

Hey there s4ndm4n,

I dont think its launcher issue, I am pretty much sure that it is a machine issue which isnt able to handle new update.

continuing,
I am following the lines you’ve given me from up to down order:

yay sddm
→ Error during AUR search: 1 error occured:
* request failed: Get “https:aur.archlinux.org/rpc?arg=sddm&by=name-desc&type=search&v=5”: dial tcp: lookup aur.archlinux.org: Temporary failure in name resolution.

→ showing repo packages only
4. endevouros/eos -plasma-sddm-config 22.03.1.2-1 (13.3KiB 291.0B) isntalled.
endevourOS Theme dor SDDM for plasma
3. endevouros/eos-sddm-theme 2.5-1 (3.8 MiB 3.8MiB)
endevourOS theme for SDDM
2. extra/sddm-kcm 6.0.4-1 (134.9KiB 510.6KiB) [plasma] (Installed)
KDE config for SDDM

  1. extra/sddm 0.21.0-4 (3.5 MiB 5.3 MiB) (Installed)
    QML based X11 and Wayland display manager
    ==> packages to install (eg. 1 2 3, 1-3 or ^4)
    ==> (I chose 3, as it wasnt installed) 3
    Sync Explicit (1): eos-sddm-theme-2.5-1
    sudo password : *****
proceed to inatallation? [Y/n]: Y error: failed retriving file 'eos-sddm-themr-2.5-1-any.pkg.tar.zst' from mirror.alpix.eu: Could not resolve hosy : mirror.alpix.eu warning: fatal error from mirror.alpix.eu, skipping remainder of this transaction. . . . . -> error installing repo packages

$ sudo systemctl disable lightdm
Failed to disablw unit: Unit file lightdm.service does not exist.

$ sudo systemctl enable sddm
(entered)

$ sudo reboot -n

result : Nothing, similar case of looping.

system starts,
password screen,

a underscore on top-left
password screen.

issue drop notice

I have changed to another OS as the expected time frame has been exceeded for fixing the issue.
thank yor your time.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.